INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Multiple instances (1 video, 1 audio) - 2nd Instance Plays Audio at HALF Speed!  (Read 4613 times)

scm

  • World Citizen
  • ***
  • Posts: 171

Open MC20, play video.  Open 2nd instance, play audio.  Audio plays back at exactly half speed, and I have no idea why.  It sounds awful of course.  Any ideas?
Logged

Trumpetguy

  • Citizen of the Universe
  • *****
  • Posts: 974
Re:
« Reply #1 on: September 12, 2015, 01:15:15 am »

Your Dac is getting wrong sample rate info. If you are playing 96kHz material and your dac is fixed at 48kHz, it will play at exactly half speed and one octave lower so it all sounds very dark.

Will your dac automatically switch sample rate, or is it on s fixed rate?
Logged

AndrewFG

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3392

Personally I think that the problem is more likely either a) the two instances of MC are interleaving audio samples to the same DAC, or possibly b) the instance of MC that is playing video has told the DAC to expect 3.1 channels, and the audio instance is pushing 2 channels. Solution is: don't use two instances in parallel...

Logged
Author of Whitebear Digital Media Renderer Analyser - http://www.whitebear.ch/dmra.htm
Author of Whitebear - http://www.whitebear.ch/mediaserver.htm

scm

  • World Citizen
  • ***
  • Posts: 171

That's not a solution to the problem of how to play multiple instances in parallel.  I've successfully played 8 instances in parallel before with no problems, using the same hardware setup, even in prior versions of MC.  My sound is going out via USB to a mixer, and that mixer is the DAC. 

So I'm trying to see if anyone knows how I can play multiple instances of MC in parallel without this happening. 

Also, does anyone else have this problem when they do this?  Or is it something specific to my system?

Personally I think that the problem is more likely either a) the two instances of MC are interleaving audio samples to the same DAC, or possibly b) the instance of MC that is playing video has told the DAC to expect 3.1 channels, and the audio instance is pushing 2 channels. Solution is: don't use two instances in parallel...


Logged

mojave

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3732
  • Requires "iTunes or better" so I installed JRiver

First, use two zones instead of two instances of JRiver. It is much more stable and easier to manage.

Second, Trumpetguy is correct. You need to set the output of each zone to the same sample rate.
Logged

scm

  • World Citizen
  • ***
  • Posts: 171

First, use two zones instead of two instances of JRiver. It is much more stable and easier to manage.

Second, Trumpetguy is correct. You need to set the output of each zone to the same sample rate.


Hey that totally worked thanks!  Now I don't have to overload my system with all these instances of MC!

Should have tried that before, but I didn't realize multiple zones could play to the same output speakers.  And it's nice to select "Internal Volume" to achieve independent volume controls for each zone.

Thanks again!
Logged

scm

  • World Citizen
  • ***
  • Posts: 171

Well it worked for multiple videos simultaneously, but when playing some music from another zone it seems like it's still playing half speed again, so in order to take your suggestion of setting the output of each zone to the same sample rate, where do I go to do this?
Logged

mojave

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3732
  • Requires "iTunes or better" so I installed JRiver

You set the output sample rate in DSP Studio > Output Format. You can access this in Tools > Options > Audio > Settings or by clicking the EQ slider icon at the top right of the screen. Movies are being played at 48 kHz and most music is at 44.1 kHz. You want to set the sample rate for all incoming sample rates to either 48 kHz or 96 kHz. I recommend 96 kHz if your hardware works with it.
Logged

scm

  • World Citizen
  • ***
  • Posts: 171

You set the output sample rate in DSP Studio > Output Format. You can access this in Tools > Options > Audio > Settings or by clicking the EQ slider icon at the top right of the screen. Movies are being played at 48 kHz and most music is at 44.1 kHz. You want to set the sample rate for all incoming sample rates to either 48 kHz or 96 kHz. I recommend 96 kHz if your hardware works with it.

I've never used DSP before, so I did what you said and selected "Set all to 48,000 Hz".  The sound is going out via USB to a Heath and Allen ZED-10FX and the manual says the USB decoder can do 32, 44.1, or 48 kHz.

By default "Channels > Mixing > JRSS mixing" is selected.  But in your graphic you have "No upmixing or downmixing".  Should I change it?

Logged

mojave

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3732
  • Requires "iTunes or better" so I installed JRiver

I would set Output Format to 48 kHz since that is the maximum supported by your mixer.

It looks like your mixer only supports two channels. I would set channels to two and leave JRSS on. This will make sure that multi-channel movies are down mixed to two channels if necessary. I normally have JRSS on, but was using a zone for some testing and had it turned off when I took the screenshot.
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009

I'm not sure what you're doing.  These are just some thoughts on the matter:

You're feeding at least 2 audio signals from MC into a mixer.  My natural thought is that the mixer is going to be used to mix the sounds you are feeding it.  But it only has a single USB interface that supports two channels, so you can't do any mixing in the mixer.  You'll have to do any mixing of MC's outputs in software with MC's volume controls for each zone.  You can only control the overall level of the USB feed.  At that point, I guess it's kinda like a sound card with one stereo output.  Maybe you're mixing other things with the mixer at the same time that I don't know about.

Generally speaking, hardware volume controls and hardware *mixing* controls are easier, faster, more precise, and just plain better as compared to moving software sliders.  If you had a sound card in your computer, you could feed analog audio from that sound card into an analog input on your mixer and have the ability to *mix* with the mixer.

Again, I don't know what you're doing with this setup.  That said, the USB inputs in mixers like this one are very limited.  You generally can't route the USB inputs through effects, or tone controls, or into Aux sends.  In short, they don't act like a regular analog channel.  They are more like an extra "volume only" input.  To me, they're pretty much useless on a mixer.

If I actually wanted to mix multiple feeds from MC with a hardware mixer, I'd get a decent 4, 5, or 8 channel USB DAC (external sound card) and route it's analog outputs into the mixer's analog inputs.  The multi-channel DAC is better than several 2 channel DACs because a single DAC will keep all of it's channels in sync, whereas several external DACs will drift relative to one-another.

I have a funny feeling very little of this applies to your situation.  On the off chance this might help, I decided to share my thoughts.

Good luck.

Brian.
Logged

scm

  • World Citizen
  • ***
  • Posts: 171

I erased some of the zones I had created, and now I haven't had any problems.  If it happens again, I'll repost.  But at the moment I have successfully created 12 zones and I can play multiple videos simultaneously and audio with no problem. 
Logged
Pages: [1]   Go Up