INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: mint 17.2, selected ALSA but cpu maxing out - pulseaudio issue?  (Read 7953 times)

Jay Fora

  • Recent member
  • *
  • Posts: 49
mint 17.2, selected ALSA but cpu maxing out - pulseaudio issue?
« on: October 25, 2015, 12:59:19 am »

Hi, in Linux Mint Cinnamon, uninstalling PulseAudio can cause many problems as it's deeply integrated in system. Has anyone found a way to disable PulseAudio safely so it doesn't start when MC is in action? Have selected ALSA in settings, but suspect PulseAudio is the cause of the 100% Cpu reading when MC starts, when audio analyser is running, and around 75% when playing a song.
This didn't happen when I used JRMC20 in Win 7 on this machine.
Thanks
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13467
Re: mint 17.2, selected ALSA but cpu maxing out - pulseaudio issue?
« Reply #1 on: October 27, 2015, 10:52:30 am »

Hi, in Linux Mint Cinnamon, uninstalling PulseAudio can cause many problems as it's deeply integrated in system. Has anyone found a way to disable PulseAudio safely so it doesn't start when MC is in action? Have selected ALSA in settings, but suspect PulseAudio is the cause of the 100% Cpu reading when MC starts, when audio analyser is running, and around 75% when playing a song.
This didn't happen when I used JRMC20 in Win 7 on this machine.
Thanks
You could go the other way and use pulse with MC and DSP studio to re-sample everything to 48k (or change the default pulse sample rate).
Logged

Jay Fora

  • Recent member
  • *
  • Posts: 49
Re: mint 17.2, selected ALSA but cpu maxing out - pulseaudio issue?
« Reply #2 on: October 27, 2015, 06:52:24 pm »

Thank you. Will try changing settings you suggested in MC. There's no obvious way in Mint Cinnamon to change pulseaudio default sample rate. Do you know how I could do this? Is there anything I should be aware of about any other effects making that change might have?
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13467
Re: mint 17.2, selected ALSA but cpu maxing out - pulseaudio issue?
« Reply #3 on: October 29, 2015, 12:18:12 pm »

Thank you. Will try changing settings you suggested in MC. There's no obvious way in Mint Cinnamon to change pulseaudio default sample rate. Do you know how I could do this? Is there anything I should be aware of about any other effects making that change might have?
I've never done it but I recall seeing a message on the linux MC 21 forum somewhere about modifying the alsa config files to do this. You might want to search around in there...
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7343
  • The color of Spring...
Re: mint 17.2, selected ALSA but cpu maxing out - pulseaudio issue?
« Reply #4 on: October 29, 2015, 02:32:59 pm »

Okay, you can change this by opening a Terminal and using the following command to edit the daemon.conf file in Gedit;

Code: [Select]
sudo gedit '/etc/pulse/daemon.conf'
And uncomment (by removing the ; there) and edit the two following lines here;

Code: [Select]
; default-sample-format = s16le
; default-sample-rate = 44100

Change this to whatever you want. Just remember to keep the sample rate between 1 to 192000 Hz in this case. The bit-depth has multiple options; u8, s16le, s16be, s24le, s24be, s24-32le, s24-32be, s32le, s32be float32le, float32be, ulaw and alaw. So an example of 24-bit 192kHz would look like this;

Code: [Select]
default-sample-format = s24le
default-sample-rate = 192000

Then restart Pulseaudio by either logging out and back in or using this command in the Terminal;

Code: [Select]
pulseaudio -k
That *should* do it.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2023 Update (23H2) 64-bit + Ubuntu 23.10 Mantic Minotaur 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | Topping D50s DAC

Jay Fora

  • Recent member
  • *
  • Posts: 49
Re: mint 17.2, selected ALSA but cpu maxing out - pulseaudio issue? Distro?
« Reply #5 on: November 03, 2015, 02:53:36 am »

Hi, thank you, that was useful for learning how to improve sound quality, but didn't improve cpu. :(
I discovered advice to improve resample rate, which also made a difference to sound quality   resample-method = src-sinc-best-quality.
 I found how to get a fully itemised readout of my cpu usage and sadly, i have learned that MC uses 50% in Cinnamon on my machine without even playing anything, then maxes out and stays there just with a mid quality flac audio file. Same machine that it works like a charm on,  when am using Win 7.  
Debian is not suitable for me, can you recommend a distro suitable for newbies that anecdotal evidence suggests MC Linux works well on?
For instance I notice there's some positive posts from xubuntu users, when I search Mint Mate, or Zorin, I don't see anything
I have tried a few linux media players, but for my preferences none of them come close to the Windows version of MC. Not even Kodi, which is aimed at a different audience and lacks MC library/view/tagging/ playlist/displaying capabilities.
A great media player is important to me, so am willing to try other distros to run MC on.

Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13467
Re: mint 17.2, selected ALSA but cpu maxing out - pulseaudio issue? Distro?
« Reply #6 on: November 03, 2015, 01:04:44 pm »

Hi, thank you, that was useful for learning how to improve sound quality, but didn't improve cpu. :( I found how to get a fully itemised readout of my cpu usage and sadly, i have learned that MC uses 50% in Cinnamon on my machine without even playing anything, then maxes out and stays there just with a mid quality flac audio file. Same machine that it works like a charm on,  when am using Win 7.  
Debian is not suitable for me, can you recommend a distro suitable for newbies that anecdotal evidence suggests MC Linux works well on?
For instance I notice there's some positive posts from xubuntu users, when I search Mint Mate, or Zorin, I don't see anything
I have tried a few linux media players, but for my preferences none of them come close to the Windows version of MC. Not even Kodi, which is aimed at a different audience and lacks MC library/view/tagging/ playlist/displaying capabilities.
A great media player is important to me, so am willing to try other distros to run MC on.


I doubt the cpu issue has anything to do with the distro.
If your hardware is sufficient, perhaps MC is scanning your music to analyze audio or build thumbnails?
You can control that behavior in the options settings.
Logged

Jay Fora

  • Recent member
  • *
  • Posts: 49
Re: mint 17.2, selected ALSA but cpu maxing out - pulseaudio issue?
« Reply #7 on: November 04, 2015, 07:38:04 pm »

Hi, I have made progress! :D
Two things helped. The first was advice to type 'driver Manager' into the mint Menu, and update anything listed there. My AMD video, graphics,ATI, and something called xorg drivers all needed updating. In fact one had never been installed properly, which surprised me because Mint has been so good at installing all the right stuff automatically till now. At first, installing these made everything worse, throwing up lots of error messages after re-booting, and there were a couple of problems. But when I booted up today, ready to do a system restore with Timeshift, I didn't need to, all seemed fine. I tested MC, and there was significant reduction in CPU, but still a bit high without yet playing anything.
The second was the prompt from Bob about auto import. Because I didn't see it running, I assumed it wasn't. But after deselecting auto -import, closing MC completely, waiting for a while then restarting, MC now runs at 50 -60 % CPU when playing audio or video. That's higher than on windows, but I am happy that it's now use-able on Linux Mint. Thank you Bob, Awesome Donkey, and the Mint Forum!
I've only tried it for a few minutes, so I hope it will continue to be a keeper on Mint cinnamon.

P.S Changing pulseaudio resample to best quality made a minor difference to sound along the way          resample-method = src-sinc-best-quality
Logged
Pages: [1]   Go Up