INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Every movie starts with subtitles, even though I have them turned off in Options  (Read 1023 times)

Agent86

  • Recent member
  • *
  • Posts: 22

How do I stop subtitles appearing when I start a movie? I have them Off in the Options menu. I have tried setting MC24 to display subtitles only when default language is different from the audio language but no matter what I set these subtitles options to, the movie starts with Subtitles turned on.

The only way to watch a movie with them is to start the movies and to then right click and turn Subtitles off, after the movie starts.

Thank you.

Logged

johnvandyke

  • Member
  • *
  • Posts: 1

I have the same issue. No matter what combination of settings I use for subtitles, my movies and tv shows always start with subtitles on. This happens on all connected jriver clients. The software is version 24.0 7 64 bit running on windows 10.
Logged

RoderickGI

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 8186

The latest version is MC24.0.72. Is that what you meant? Upgrade to the latest anyway.

I've seen this on some MKV files lately. But not all. I don't believe it is a function of MC, but of how the MKV file is tagged. For example, if the file was marked as German, even though it was English, and had English Subtitles, then MC would show the Subtitles as it is supposed to.

Note also that when you set Subtitles "Off" that actually means forced subtitles. In my cases above MC isn't showing forced Subtitles, but maybe it is in your case. If you want no Subtitles at all, select "NULL".
Logged
What specific version of MC you are running:MC27.0.27 @ Oct 27, 2020 and updating regularly Jim!                        MC Release Notes: https://wiki.jriver.com/index.php/Release_Notes
What OS(s) and Version you are running:     Windows 10 Pro 64bit Version 2004 (OS Build 19041.572).
The JRMark score of the PC with an issue:    JRMark (version 26.0.52 64 bit): 3419
Important relevant info about your environment:     
  Using the HTPC as a MC Server & a Workstation as a MC Client plus some DLNA clients.
  Running JRiver for Android, JRemote2, Gizmo, & MO 4Media on a Sony Xperia XZ Premium Android 9.
  Playing video out to a Sony 65" TV connected via HDMI, playing digital audio out via motherboard sound card, PCIe TV tuner

Agent86

  • Recent member
  • *
  • Posts: 22

The latest version is MC24.0.72. Is that what you meant? Upgrade to the latest anyway.

I've seen this on some MKV files lately. But not all. I don't believe it is a function of MC, but of how the MKV file is tagged. For example, if the file was marked as German, even though it was English, and had English Subtitles, then MC would show the Subtitles as it is supposed to.

Note also that when you set Subtitles "Off" that actually means forced subtitles. In my cases above MC isn't showing forced Subtitles, but maybe it is in your case. If you want no Subtitles at all, select "NULL".

Hi there, thanks for trying to assist.

I have 24.0.72. This subtitle behaviour is on all movies, MP4 or MKV. As an example: on a movie with forced subtitles for a small part of the movie, MC shows the non-forced subtitles for the entire movie and BOTH non-forced and forced subtitles (on top of one another) for the small part that has forced subtitles. MC also shows subtitles for all movies that have no forced subtitles. So Forced titles aren't the issue.

I want forced subtitles to show (for those movies that have them) and no subtitles to be the default for all others. Isn't that what "Do not show subtitles" is supposed to work? It certainly used to work that way some time ago.

You know, I think this started to happen once I foolishly selected to show subtitles if the audio language didn't match my default language, and suddenly they showed 100% of the time. So I went back to "Do not show subtitles" and it never went back to how it was so there may be something amiss with that software switch. I believe this is a bug that once didn't exist but now does so hopefully it gets fixed soon.

Merry Xmas everyone.


Logged

RoderickGI

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 8186

There have been a bunch of Subtitle fixes and changes in MC24. Maybe something needs to be turned off and then back on, or visa versa. Maybe one of the Options, Right-click, or OSD methods of changing Subtitles still isn't working.

Take a look at the changes in here: https://wiki.jriver.com/index.php/Release_Notes_MC24  Search for Subtitle. Something may hint at the problem

I use the "Show subtitles only if selected language is different from audio language", and that still seems to work. But I haven't used it a lot recently.
Logged
What specific version of MC you are running:MC27.0.27 @ Oct 27, 2020 and updating regularly Jim!                        MC Release Notes: https://wiki.jriver.com/index.php/Release_Notes
What OS(s) and Version you are running:     Windows 10 Pro 64bit Version 2004 (OS Build 19041.572).
The JRMark score of the PC with an issue:    JRMark (version 26.0.52 64 bit): 3419
Important relevant info about your environment:     
  Using the HTPC as a MC Server & a Workstation as a MC Client plus some DLNA clients.
  Running JRiver for Android, JRemote2, Gizmo, & MO 4Media on a Sony Xperia XZ Premium Android 9.
  Playing video out to a Sony 65" TV connected via HDMI, playing digital audio out via motherboard sound card, PCIe TV tuner

Agent86

  • Recent member
  • *
  • Posts: 22

Thanks for the advice. I had a good look at the release notes but nothing seemed relevant. I have toggled everything in options and the right click menu  several times and nothing will stop subtitles from showing at the start of every movie.

So for now I will just have to right click and turn them off every time.  Hopefully this is fixed in a future release.

Thanks again.
Logged
Pages: [1]   Go Up