INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Playback stops when streaming to Pi [Solved]  (Read 1678 times)

NealJ

  • Recent member
  • *
  • Posts: 22
Playback stops when streaming to Pi [Solved]
« on: March 13, 2019, 08:09:00 am »

A problem has occurred today when I try to play from JRiver on my laptop to all of my three Raspberry Pi streamers running Volumio 2. Playback stops after approximately 5 seconds when I play from the library stored on my windows laptop. The laptop is connected to the network via ethernet as are the streamers. I can send music to the Pi streamers via my phone using Bubble UPnP with no problems. Windows updated this morning, any connection there?

I'm on 24.0.75 64bit
Logged

NealJ

  • Recent member
  • *
  • Posts: 22
Re: Playback stops when streaming to Pi
« Reply #1 on: March 15, 2019, 04:47:32 am »

As an update, I can access the Pi devices via Volumio from my laptop, point to my laptop with JRiver as the media server and it sends music to my Pi devices with no problems.

I have also tried using JRiver to send music stored on my NAS rather than the laptop to the Pi's but the same problem occurs - approximately 5-10 seconds of audio before stopping.

This seems to suggest that the problem is with JRiver, rather than with the Pi's themselves, as other means of sending music to them seems to be working as normal. It seems to only occur when I use the JRiver interface.

Any suggestions please?
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598
Re: Playback stops when streaming to Pi
« Reply #2 on: March 15, 2019, 08:22:37 am »

How many DLNA servers are configured on your MC and how are they configured? (Audio format settings, etc)
Tools->Options->Add or configure DLNA servers->
Logged

NealJ

  • Recent member
  • *
  • Posts: 22
Re: Playback stops when streaming to Pi
« Reply #3 on: March 15, 2019, 02:57:13 pm »

Just the standard install I presume, one generic DLNA with original audio format selected.
Logged

NealJ

  • Recent member
  • *
  • Posts: 22
Re: Playback stops when streaming to Pi
« Reply #4 on: March 17, 2019, 03:16:41 am »

I have done the obvious, rebooted the router, rebooted all of the Pi devices. I've updated MC to 24.0.77 to see if that had any effect. No change.
Any suggestions please?
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598
Re: Playback stops when streaming to Pi
« Reply #5 on: March 19, 2019, 08:07:42 am »

I'll see if I can duplicate that here.
What version of volumio are you using and what is the format of the source material (file format, sample rate, bitdepth, etc)?
Logged

NealJ

  • Recent member
  • *
  • Posts: 22
Re: Playback stops when streaming to Pi
« Reply #6 on: March 19, 2019, 08:58:42 am »

Thanks for the reply.

Windows 10 v.1809
Updated to Volumio 2.565 after I noticed the problem, no change.
Spotify Connect 2 plugin 0.9.1, again, updated after problem, no change.

Primarily FLAC 16/44.1 ripped from my own CDs, a few 24/48 and 24/96 from Qobuz and Bandcamp again in FLAC. All of the albums were ripped using JRiver ripping JRiver (incidentally, this is also proving problematic. Lately when I try to rip more than one CD, JRiver causes the CD drive to disappear. I have to reboot, but as soon as I put the CD back in, the drive disappears again. This can go on for multiple shutdowns to presumably reinstall the driver. I though the drive was on its way out but I installed EAC and it doesn't have this problem.).

Cheers
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598
Re: Playback stops when streaming to Pi
« Reply #7 on: March 19, 2019, 11:22:49 am »

Looks like volumio broke SetNextAVTransportURI support in their last update.
If you go to controller options for the Volumio zone (right-click on the zone) and disable SetNext support your playback will work (albeit without gapless transitions).


Here's the proof in the log:
Code: [Select]
0037047: 5724: Playback: CPlayerZoneDisplayInfo::UpdateFileInfo: Zone {Volumio} Playback state is PLAYING, Sucessfully sent next track using SetNextAVTransportURI. Position 10000, Duration 443000
0037125: 3280: Sharing Plugins: CHTTPListenerWorker::HandleRequest: TCP: 199.242.131.229: NOTIFY: http://199.242.131.131:52103/eventSub
0037125: 3280: Playback: CPlayerZone::DLNADeviceSubscription_PropertyChanged: Start
0037125: 3280: Playback: CPlayerZone::DLNADeviceSubscription_PropertyChanged: Transport state was 2 changing to 0
0037125: 3280: Playback: CPlayerZone::DLNADeviceSubscription_PropertyChanged: Finish (0 ms)
0037125: 8016: Playback: CPlayerZone::DLNAProcessPlaybackState: Start
0037140: 8016: Playback: CPlayerZone::DLNAProcessPlaybackState: Device stopped by another controller at: 11016 of 443000 MS

What this is basically showing is that Volumio sends an event changing the state from Playing to Stopped after we send it the next track to queue up (10 seconds into playing the first track). It's not supposed to stop.
Logged

NealJ

  • Recent member
  • *
  • Posts: 22
Re: Playback stops when streaming to Pi
« Reply #8 on: March 19, 2019, 11:58:39 am »

That's working on mine too.
Thank you for looking into this for me, much appreciated.
I will send details to the Volumio team.

Cheers
Neal
Logged

fyusmal

  • Recent member
  • *
  • Posts: 9
Re: Playback stops when streaming to Pi
« Reply #9 on: May 02, 2019, 12:54:55 am »

Had the same problem. Solution works for now. Thanks.

Volumio Version 2.575
JRiver MC24 latest build
Logged
Pages: [1]   Go Up