INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Terrible Video Colours - Wrong Codec?  (Read 802 times)

djs

  • Recent member
  • *
  • Posts: 6
Terrible Video Colours - Wrong Codec?
« on: June 12, 2019, 02:51:21 am »

Hoping for some guidance here. When playing a video file in MC24, the colour always looks too red and orange. The file I am playing is an H264 mov file generated from DaVinci Resolve, Youtube publish setting, but this happens on all other video files as well. When I play the file with VLC, it looks normal. I have attached two stills, one from JRiver and the other from VLC.

Do I need a special codec or change a setting somewhere?

Many thanks.
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10776
Re: Terrible Video Colours - Wrong Codec?
« Reply #1 on: June 12, 2019, 03:00:20 am »

Looks like the saturation is cranked up for some reason.
You can check this in the Color Controls, in the menu Player -> Display Options -> Color Controls

They should all be set to neutral at 0
Logged
~ nevcairiel
~ Author of LAV Filters

djs

  • Recent member
  • *
  • Posts: 6
Re: Terrible Video Colours - Wrong Codec?
« Reply #2 on: June 12, 2019, 03:17:11 am »

Thanks Hendrik

But I don't have that menu option. See attached.

Regards
David
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10776
Re: Terrible Video Colours - Wrong Codec?
« Reply #3 on: June 12, 2019, 03:25:52 am »

You need to be playing a video for the option to be available.

Its also possible that the video settings are changed in a similar manner in the graphics cards control panel. I would also check there. The settings there don't affect all players, but MC uses video playback components that actually would be impacted by it (while VLC would likely not)
Logged
~ nevcairiel
~ Author of LAV Filters

djs

  • Recent member
  • *
  • Posts: 6
Re: Terrible Video Colours - Wrong Codec?
« Reply #4 on: June 12, 2019, 03:20:34 pm »

Thanks again. I tried the controls when playing a video. They were set to default and even when sliding them around nothing changes in the colour displayed. Could this be a clue to what's wrong?

The video card (Intel UHD630) controls are also set to default and all my other video software plays the files with correct colour. DaVinci Resolve, Edius 9 Pro, and web browsers. It is only MC24 that shows the incorrect colours. Very puzzling and frustrating.
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10776
Re: Terrible Video Colours - Wrong Codec?
« Reply #5 on: June 14, 2019, 07:34:34 am »

You could try switching to Red October HQ in the video settings. That usually avoids the majority of weirdness from graphics drivers etc.
Logged
~ nevcairiel
~ Author of LAV Filters

djs

  • Recent member
  • *
  • Posts: 6
Re: Terrible Video Colours - Wrong Codec?
« Reply #6 on: June 15, 2019, 06:24:34 pm »

Many thanks Hendrik, that did it! It was set to Red October Standard. I changed to Red October HQ, it said Adding required components, I restarted MC24 and now, proper colours. Many thanks for your help.
Logged
Pages: [1]   Go Up