INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Unchanged Cover Art  (Read 1114 times)

alb

  • Recent member
  • *
  • Posts: 34
Unchanged Cover Art
« on: November 25, 2019, 05:07:08 pm »

I have my JRiver Media Server and one Client.  If I make a change of a TV Show's Cover Art on the Server, shouldn't the Client update to that new Cover Art as well?  I swear, I can remember this happening, but now it doesn't any longer.  Did I mess something up in a Setting somewhere?
Logged

RoderickGI

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 8186
Re: Unchanged Cover Art
« Reply #1 on: November 25, 2019, 05:55:59 pm »

If the Cover Art and Thumbnail are showing correctly on the Server, restart MC on the Client.

Does that fix the issue?
Logged
What specific version of MC you are running:MC27.0.27 @ Oct 27, 2020 and updating regularly Jim!                        MC Release Notes: https://wiki.jriver.com/index.php/Release_Notes
What OS(s) and Version you are running:     Windows 10 Pro 64bit Version 2004 (OS Build 19041.572).
The JRMark score of the PC with an issue:    JRMark (version 26.0.52 64 bit): 3419
Important relevant info about your environment:     
  Using the HTPC as a MC Server & a Workstation as a MC Client plus some DLNA clients.
  Running JRiver for Android, JRemote2, Gizmo, & MO 4Media on a Sony Xperia XZ Premium Android 9.
  Playing video out to a Sony 65" TV connected via HDMI, playing digital audio out via motherboard sound card, PCIe TV tuner

alb

  • Recent member
  • *
  • Posts: 34
Re: Unchanged Cover Art
« Reply #2 on: November 26, 2019, 07:28:47 pm »

Unfortunately, that did not help.  I've restarted both machines and I still suffer from this problem. 

I meant to include this in my OP.



This is a snippet from the JRiver server (Above).  Star Wars Resistance is the TV show I'm using as an example.  But, it happens with all TV shows now.  The Cover Art currently displayed is what I would like the Client to use as well.



Notice that there is a different piece of Cover Art for Star Wars Resistance.  However, if I bring up Right-Click > Cover Art > Get From Internet you can see that JRiver is confirming that the current piece of Cover Art in my library is what I have on my Server.  No matter what I select on the Server...the Client doesn't match it.  I've even tried to manually change the Cover Art within the Client JRiver and no matter what, nothing changes.
Logged

RoderickGI

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 8186
Re: Unchanged Cover Art
« Reply #3 on: November 26, 2019, 08:49:21 pm »

On the Client, right-click on the thumbnail for the TV Show and select "Cover Art > Rebuild Thumbnail".

Does that fix the problem?

If so, the Client thumbnail database is probably corrupted. The best way to fix that completely is to follow this procedure outline: https://yabb.jriver.com/interact/index.php/topic,122365.msg846919.html#msg846919

Of course in your case you would be checking Show Views to see if this worked.

Yes, it means deleting directories. Yes, it may take time to rebuild all thumbnails. But based on your image, something weird is going on that I can't duplicate, so I think the above is the easiest, best, and most thorough solution.
Logged
What specific version of MC you are running:MC27.0.27 @ Oct 27, 2020 and updating regularly Jim!                        MC Release Notes: https://wiki.jriver.com/index.php/Release_Notes
What OS(s) and Version you are running:     Windows 10 Pro 64bit Version 2004 (OS Build 19041.572).
The JRMark score of the PC with an issue:    JRMark (version 26.0.52 64 bit): 3419
Important relevant info about your environment:     
  Using the HTPC as a MC Server & a Workstation as a MC Client plus some DLNA clients.
  Running JRiver for Android, JRemote2, Gizmo, & MO 4Media on a Sony Xperia XZ Premium Android 9.
  Playing video out to a Sony 65" TV connected via HDMI, playing digital audio out via motherboard sound card, PCIe TV tuner

alb

  • Recent member
  • *
  • Posts: 34
Re: Unchanged Cover Art
« Reply #4 on: November 29, 2019, 04:22:00 pm »

Thanks for the help @RoderickGI... I really appreciate it.

Unfortunately, I wasn't able to fix my situation.  :(  So, I thought the only honorable thing to do was to perform seppuku.  I was seconds away from thrusting my sword into my stomach when I had another idea.  I'm going to completely uninstall/re-install both the server and the client.  Thankfully, I can report that now everything is working A-OK.  Then I placed my sword back into its gorgeous case and slid the case under my bed.  The sword lies waiting for my inevitable dishonor one day.

Seriously, thank you very much.  I can honestly say, at least I learned a couple of new things due to your suggestions.
Logged

RoderickGI

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 8186
Re: Unchanged Cover Art
« Reply #5 on: November 29, 2019, 04:39:38 pm »

Oh well, that is a good result.

Just deleting the thumbnails databases may have also worked, as that seemed to be where the problem was, and an uninstall would remove them, while a reinstall would rebuild them. But no matter, it's working again.  8)

PS: Get that sword mounted on a wall. It should be seen, and be a reminder to maintain honor, and of how fragile life is!  ;D
Logged
What specific version of MC you are running:MC27.0.27 @ Oct 27, 2020 and updating regularly Jim!                        MC Release Notes: https://wiki.jriver.com/index.php/Release_Notes
What OS(s) and Version you are running:     Windows 10 Pro 64bit Version 2004 (OS Build 19041.572).
The JRMark score of the PC with an issue:    JRMark (version 26.0.52 64 bit): 3419
Important relevant info about your environment:     
  Using the HTPC as a MC Server & a Workstation as a MC Client plus some DLNA clients.
  Running JRiver for Android, JRemote2, Gizmo, & MO 4Media on a Sony Xperia XZ Premium Android 9.
  Playing video out to a Sony 65" TV connected via HDMI, playing digital audio out via motherboard sound card, PCIe TV tuner

alb

  • Recent member
  • *
  • Posts: 34
Re: Unchanged Cover Art
« Reply #6 on: December 03, 2019, 08:32:59 am »

Oh well, that is a good result.

Just deleting the thumbnails databases may have also worked, as that seemed to be where the problem was, and an uninstall would remove them, while a reinstall would rebuild them. But no matter, it's working again.  8)

PS: Get that sword mounted on a wall. It should be seen, and be a reminder to maintain honor, and of how fragile life is!  ;D

One last thing...

When you said to delete the thumbnail databases, I deleted everything that was in C:\Users\ALB\AppData\Roaming\J River\Media Center 25\Thumbnails on the Client machine.  I then rebooted and restarted that Client and after it finished populating everything with a Thumbnail, I still had the problem.  At that point, I said to myself, "Should I have done this to the Server too?  Is something borked on the Server-side that messes up the sharing with the single Client?"  Rather than making any additional attempts to fix the problem, at that point, I thought it's not that much work to uninstall and reinstall on both sides.  Before I got off the computer for the night, I performed that action so I didn't have to watch the entire rebuilding processes.

I wanted to say the above because I don't want you to think I blew off your advice to fix the problem.  I did try.  Again, I'm extremely thankful for your help & suggestions.
Logged

RoderickGI

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 8186
Re: Unchanged Cover Art
« Reply #7 on: December 03, 2019, 03:07:06 pm »

No problem ALB. You have been one of the more grateful users I have helped.

Also, you are correct. If the thumbnail database was corrupted on the Server, it would probably cause issues on the Client as well. If that was the case you would have to fix the Server first, and then the Client. But often just fixing the Client has been enough for other users.

Cheers.
Logged
What specific version of MC you are running:MC27.0.27 @ Oct 27, 2020 and updating regularly Jim!                        MC Release Notes: https://wiki.jriver.com/index.php/Release_Notes
What OS(s) and Version you are running:     Windows 10 Pro 64bit Version 2004 (OS Build 19041.572).
The JRMark score of the PC with an issue:    JRMark (version 26.0.52 64 bit): 3419
Important relevant info about your environment:     
  Using the HTPC as a MC Server & a Workstation as a MC Client plus some DLNA clients.
  Running JRiver for Android, JRemote2, Gizmo, & MO 4Media on a Sony Xperia XZ Premium Android 9.
  Playing video out to a Sony 65" TV connected via HDMI, playing digital audio out via motherboard sound card, PCIe TV tuner
Pages: [1]   Go Up