INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Television EPG not refreshing (next load of EPG is scheduled in the past)  (Read 1092 times)

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5168
  • "Linux Merit Badge" Recipient

So I recently noticed that my Linux TV EPG stopped refreshing about a month ago.  I have it set to automatically refresh every 24 hours at 7am, and the machine it runs on never turns off or goes to sleep (it's on my server).  However, the EPG never seems to actually get refreshed automatically.  It previously worked during MC 27, but I don't know exactly when it stopped working unfortunately.  Running the EPG loader manually works just fine, and that's what I'm doing for now.

One quirk that seems like it may be relevant is that on the "Load Program Guide" option dialog box, I can see my EPG reloading mode in the list, and in the "next load" column it shows the correct time (6:57am), but shows yesterday's date (December 11) instead of tomorrow's date (December 13), which is puzzling.  No matter what time I choose, the next load is always in the past. 

I tried setting the auto-load time to a time that I could watch MC, and when I look at the logs or at reporter, the EPG load action doesn't appear to be firing at all (it doesn't try and fail, just never runs).  This seems independent of the EPG mode I use, and my normal mode is to load from a local xml file anyway which seems like the least complicated option (i.e. no network access is involved, MC just needs to read a file).  So I suspect the fact that the next load is always in the past is what's stopping things from working correctly.

And yes, I checked my system time (it's correct) ;D
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5168
  • "Linux Merit Badge" Recipient
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #1 on: December 15, 2020, 09:54:52 am »

Just a gentle bump.  If this would be better to post over on the TV forums, let me know!
Logged

Yaobing

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10850
  • Dogs of the world unite!
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #2 on: December 17, 2020, 08:20:29 am »

"Next Load" being in the past is just an indication that a load was not executed when it should.  It is puzzling why though.  What is your EPG source?
Logged
Yaobing Deng, JRiver Media Center

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5168
  • "Linux Merit Badge" Recipient
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #3 on: December 17, 2020, 09:30:04 am »

"Next Load" being in the past is just an indication that a load was not executed when it should.  It is puzzling why though.  What is your EPG source?

It's loading from an XML file on my drive.  I manually update that file outside of JRiver because I had some trouble getting JRiver for Linux to successfully execute the helper programs itself.  For a while it loaded from the file automatically no problem, but then it stopped.

When I tell JRiver to manually refresh the EPG it works just fine loading from the file (so the file is accessible), JRiver just stopped reloading automatically.
Logged

Yaobing

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10850
  • Dogs of the world unite!
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #4 on: December 17, 2020, 12:16:49 pm »

Do you see any error messages under "TV Logs" in Standard View?
Logged
Yaobing Deng, JRiver Media Center

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5168
  • "Linux Merit Badge" Recipient
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #5 on: December 17, 2020, 03:49:28 pm »

Thanks for the tip, I was looking in the main logs not in the TV logs.  There are no errors under TV Logs, but the logs suggest that the EPG was loading everyday until 11/22/2020 and then the logs end.  No errors or anything else are recorded after 11/22.

The info below the window says "Program guide last refreshed: 12/11/2020..." which was my last manual refresh, and the "next load" still shows yesterday's date. 

The timing suggests that something happened in build 35, which was released for Linux on 11/20.

EDIT: I had initially written something else in this post, but realized after I wrote it that I was misreading the dates in my logs.  The above is now correct.
Logged

Yaobing

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10850
  • Dogs of the world unite!
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #6 on: December 18, 2020, 11:38:51 am »

I did a test and it seems to work?

Yesterday I started MC in a Linux virtual box.  Manually refreshed EPG and left MC running overnight.  This morning, I logged in everything was still OK.  Later in the morning, I had to re-log-in because I got automatically logged out of it.  MC was still running, and scheduled EPG time just past - but for some reason, when I got logged out, the Linux box's system time stopped updating too.  So technically the EPG updating time did not pass.  So I let it run, and waited.  Yes, it did run EPG update, and it was successful.
Logged
Yaobing Deng, JRiver Media Center

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13487
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #7 on: December 18, 2020, 12:37:28 pm »

What's your timezone set to? Did you change from UTC to localtime or vice versa recently?
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5168
  • "Linux Merit Badge" Recipient
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #8 on: December 18, 2020, 12:58:07 pm »

I did a test and it seems to work?

Yesterday I started MC in a Linux virtual box.  Manually refreshed EPG and left MC running overnight.  This morning, I logged in everything was still OK.  Later in the morning, I had to re-log-in because I got automatically logged out of it.  MC was still running, and scheduled EPG time just past - but for some reason, when I got logged out, the Linux box's system time stopped updating too.  So technically the EPG updating time did not pass.  So I let it run, and waited.  Yes, it did run EPG update, and it was successful.

Hmm, that's odd.  It's definitely not updating here and the virtual machine doesn't lock/log out at all, it just keeps running.  I can set the next refresh to ten minutes in the future and watch the interface and it won't run.  I wonder what's different here?

To test, I just rolled back to 27.0.30 and the background task immediately fired and executed correctly.  So something changed between version 30 and 35, at least for me.

What's your timezone set to? Did you change from UTC to localtime or vice versa recently?


My Timezone is set to EST and I haven't changed anything related to system time recently.  I also run an ntp client for time sync and system time appears to be correct within a few microseconds.  The fact that it works in version 30 and not in 35-37 seems to suggest something changed in Media Center. 

To provide a little more info about my environment, I'm running MC on Debian Buster (64-bit) in xfce.  I've configured it never to sleep or log out (it's a headless virtual machine).  I run MC using a systemd service that runs with the /MediaServer flag.
Logged

Yaobing

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10850
  • Dogs of the world unite!
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #9 on: December 18, 2020, 03:03:30 pm »

Have you scheduled any TV recordings at all recently?  If you have never scheduled a recording on this computer, then the issue is likely caused by something I did recently, and it is now fixed:

Fixed: TV background tasks might not be performed if no recording actions were scheduled.
Logged
Yaobing Deng, JRiver Media Center

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5168
  • "Linux Merit Badge" Recipient
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #10 on: December 18, 2020, 03:33:15 pm »

Have you scheduled any TV recordings at all recently?

No, I haven't tried scheduling any TV recordings recently at all.  Should I? Would that give some useful info?

Probably unrelated to this issue, but I've also been seeing some UI weirdness related to the record button in the TV view in standard view (see attached).  Just thought I'd note that as well in case there's anything significant about it.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5168
  • "Linux Merit Badge" Recipient
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #11 on: December 18, 2020, 03:33:53 pm »

Have you scheduled any TV recordings at all recently?  If you have never scheduled a recording on this computer, then the issue is likely caused by something I did recently, and it is now fixed:

Fixed: TV background tasks might not be performed if no recording actions were scheduled.

Oh aces!  I'm glad you found it.  Thanks for the help!
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13487
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #12 on: December 18, 2020, 05:33:20 pm »

Try the beta, I just updated it.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5168
  • "Linux Merit Badge" Recipient
Re: Television EPG not refreshing (next load of EPG is scheduled in the past)
« Reply #13 on: December 18, 2020, 10:10:26 pm »

I just updated and restarted, and the EPG background loading task fired immediately and completed successfully.  So I think it's fixed.  Thanks again!
Logged
Pages: [1]   Go Up