INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Problems playing ALAC files from HDTracks to the local device  (Read 2130 times)

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 12085
Problems playing ALAC files from HDTracks to the local device
« on: January 04, 2021, 04:37:39 pm »

The new HDTracks downloader produces files that play locally but will not when streamed to a local device (iPhone, etc) with JRemote.
This is because the process HDTracks (and presumably others) use to produce their ALAC files put's the ATOMS in an order that prevents them from being streamed on devices that need the file length for seekability, etc. This is simple to fix by simply reconverting the file from ALAC to ALAC in MC which will re-write the tags in the proper order.
Here's a link to a thread with a description of the issue:
https://yabb.jriver.com/interact/index.php/topic,128156.0.html
Logged

wer

  • Citizen of the Universe
  • *****
  • Posts: 2640
Re: Problems playing ALAC files from HDTracks to the local device
« Reply #1 on: January 04, 2021, 05:03:00 pm »

That's good detective work. Thank you, Bob.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 12085
Re: Problems playing ALAC files from HDTracks to the local device
« Reply #2 on: January 04, 2021, 05:21:27 pm »

That's good detective work. Thank you, Bob.
Thanks! I had forgotten that I'd seen it before.
I think that with programs that use FFMpeg for conversion a person might be able to solve the problem at the source if they have access to the command line args sent to FFMpeg by adding:
-movflags faststart
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 12085
Re: Problems playing ALAC files from HDTracks to the local device
« Reply #3 on: January 05, 2021, 05:25:14 pm »

Thanks! I had forgotten that I'd seen it before.
I think that with programs that use FFMpeg for conversion a person might be able to solve the problem at the source if they have access to the command line args sent to FFMpeg by adding:
-movflags faststart
It's been verified this works with EAC and FFMpeg. Someday maybe HDTracks will fix theirs.
Logged
Pages: [1]   Go Up