INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Trouble installing MC27 - libc6 dependency issue  (Read 1403 times)

dhdezzo

  • Recent member
  • *
  • Posts: 9
Trouble installing MC27 - libc6 dependency issue
« on: May 09, 2021, 12:53:24 pm »

I want to upgrade MC on my HTPC (Windows version) and I was planning to buy a full license for MC28 and install it on my Linux desktop computer as well (running Linux Mint 19.3 Cinnamon). When following the instructions to install MC27 in Linux, I get the following error. I was able to download and install MC26 without issue. I'm not a Linux expert, so hopefully there is a simple fix for this. I read that installing a newer version of libc6 could cause issues. Please help. Thanks.

$ sudo apt-get install mediacenter27
[sudo] password for derek:         
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 mediacenter27 : Depends: libc6 (>= 2.28) but 2.27-3ubuntu1.4 is to be installed
                 Depends: libasound2 (>= 1.1.8)
                 Depends: libuuid1 (>= 2.33) but 2.31.1-0.4ubuntu3.7 is to be installed
                 Depends: libgtk-3-0 (>= 3.24) but 3.22.30-1ubuntu4 is to be installed
                 Depends: libpango-1.0-0 (>= 1.42) but 1.40.14-1ubuntu0.1 is to be installed or
                          libpango1.0-0 (>= 1.42) but it is not going to be installed
                 Depends: libpangoft2-1.0-0 (>= 1.42) but 1.40.14-1ubuntu0.1 is to be installed or
                          libpango-cairo-1.0-0 (>= 1.42) but it is not installable
                 Depends: libpangoxft-1.0-0 (>= 1.42) but 1.40.14-1ubuntu0.1 is to be installed
                 Depends: libnss3 (>= 2:3.42) but 2:3.35-2ubuntu2.12 is to be installed
                 Depends: libnspr4 (>= 2:4.20) but 2:4.18-1ubuntu1 is to be installed
                 Depends: libfribidi0 (>= 1.0.5) but 0.19.7-2 is to be installed
                 Depends: libfontconfig1 (>= 2.13) but 2.12.6-0ubuntu2 is to be installed
                 Depends: libfreetype6 (>= 2.9.1) but 2.8.1-2ubuntu2.1 is to be installed
                 Depends: libharfbuzz0b (>= 2.3.1) but 1.7.2-1ubuntu1 is to be installed
                 Depends: libva2 (>= 2.4.0) but 2.1.0-3 is to be installed
                 Recommends: vorbis-tools (>= 1.4.0) but it is not going to be installed
                 Recommends: musepack-tools but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7128
  • Autumn shade...
Re: Trouble installing MC27 - libc6 dependency issue
« Reply #1 on: May 10, 2021, 04:21:41 am »

You need to update Linux Mint 19.3 to Linux Mint 20.1 for it to work, the versions of dependencies MC27 needs are too old in Linux Mint 19.3.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2023 Update (23H2) 64-bit + Ubuntu 23.10 Mantic Minotaur 64-bit | Ubuntu 22.04.3 LTS Jammy Jellyfish 64-bit (Orange Pi 5B 16GB/128GB eMMC)
JRiver Media Center 31 (Windows + Linux) | Topping D50s DAC

dhdezzo

  • Recent member
  • *
  • Posts: 9
Re: Trouble installing MC27 - libc6 dependency issue
« Reply #2 on: May 10, 2021, 09:19:10 am »

Ok, thanks. That makes sense.

If I buy the master license for MC28 to upgrade my Windows HTPC, can I also use that license for MC26 on my Linux computer? Iím not ready to upgrade Linux.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7128
  • Autumn shade...
Re: Trouble installing MC27 - libc6 dependency issue
« Reply #3 on: May 10, 2021, 01:30:03 pm »

Nope, it won't work for MC26.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2023 Update (23H2) 64-bit + Ubuntu 23.10 Mantic Minotaur 64-bit | Ubuntu 22.04.3 LTS Jammy Jellyfish 64-bit (Orange Pi 5B 16GB/128GB eMMC)
JRiver Media Center 31 (Windows + Linux) | Topping D50s DAC
Pages: [1]   Go Up