INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Library "Forgotten"  (Read 1409 times)

cycler2

  • Recent member
  • *
  • Posts: 46
Library "Forgotten"
« on: May 29, 2021, 02:28:36 pm »

Media Center 27.0.84 on Linux Mint 20.1 Cinnamon “forgets” my library every time I boot Linux from a shut down computer.  When I start Media Center I shows my most recent playlist (grayed-out) and music file thumbnails, but will not play any file.  Instead I get an error message that says “Playback Problem—the file could not be found.  Check that the filename in the library matches the filename on disk.” 
To play music, I have to re-import my library from my music folder using “import a single folder-→browse-→other locations-→select volume-→finish.”  Media Center then adds my music files to the library and all is well.  Until I shut down the machine and come back to it later.

I tried mwillems’ suggestion elsewhere on the forum by creating a library backup and restoring it.  But that did not work to produce playable music.  I've also read several posts about library problems, but they did not seem to fit my situation...or I'm too much of a newb to recognize a solution when I see one.

This may or may not be a bug in Media Center and might well result from the configuration of my hardware and software, which is:  Both Linux Mint and Windows 10 exist on my machine, but not in dual-boot form.  Each operating system in on a physically separate SSD drive.  I boot into one or the other by going into the bios on startup and selecting the appropriate boot disk.  Only a couple of clicks and this configuration avoids problems with grub if I decide to remove Linux—as has happened in previous Linux trials.  My music files are on yet another drive, this one a mechanical drive.  FWIW Media Center works flawlessly with Windows 10.

I’d be grateful for your thoughts on how I can get Media Center to function properly in Linux Mint.

Thanks
Rich
 
Logged

zybex

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 2223
Re: Library "Forgotten"
« Reply #1 on: May 30, 2021, 03:32:21 am »

Sounds like Linux is not automounting your drive, so when you run MC it doesn't see any files. Or perhaps it's only automounting it when you access the volume root itself, either by using a desktop shortcut or by selecting the root folder to import.

Try enabling automount for that disk/volume, or just adding it to fstab to always mount on boot.

Autofs should also work, check if it's installed and configured for that volume:
https://help.ubuntu.com/community/Autofs
Logged

cycler2

  • Recent member
  • *
  • Posts: 46
Re: Library "Forgotten"
« Reply #2 on: May 30, 2021, 09:04:52 am »

Thanks, zybex.  I will try to configure automount, just as soon as I figure out what that means  :)  All part of my Linux learning curve.
Rich
Logged

cycler2

  • Recent member
  • *
  • Posts: 46
Re: Library "Forgotten"
« Reply #3 on: May 30, 2021, 02:20:04 pm »

You were absolutely right, zybex.  I fumbled my way through enabling automount by following MintBean's guide, because it seemed newb-friendly.  I post it below in case others new to linux run into the same problem.  MintBean's instructions resulted in my music drive appearing on my desktop and I had to point Media Center to that location for it to work.
Thanks, again.
Rich


Easily set drives to mount automatically at boot
Posted: Tue Oct 10, 2017 5:06 pm
by MintBean
This is for people who to enable a second drive to auto-mount at system start up WITHOUT editing a system file by hand.

1. Open the application 'Disks' from the Mint menu. (It's under 'Accessories.')
2. In the left hand part of the window, click on the disk which contains the partition you wish to mount.
3. The partition layout of the selected disk will appear in the right hand portion of the window.
4. Select the partition you wish to auto-mount by clicking on it. The selected partition will be highlighted.
5. Optional - If you wish to immediately mount the disk, you can do so by pressing the triangular 'play' button that appears to the left below the partition display. This will NOT cause it to auto-mount on next boot.
You may unmount the partition if you wish by pressing the square 'stop' button that appears where the play button was.
6. Click the cog icon <additional partition options> and select 'edit mount options.'
7. Switch 'automatic mount options' to OFF.
8. Check the 'mount at startup' box.
9. Optional - choose a custom mount point - in the 'Mount point' box, enter the mount point. I always choose something in the /mnt directory. e.g. '/mnt/Mydiscname'
10. Optional - give your disk a nice display name. This is the name it will appear as on the desktop. Enter your chosen name in the 'display name' field.
11. Hit OK and close the disks application. The disk should automount on next boot.
Logged

zybex

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 2223
Re: Library "Forgotten"
« Reply #4 on: May 30, 2021, 03:56:54 pm »

You're welcome, glad it works!
Logged
Pages: [1]   Go Up