INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Exclusively using a device  (Read 1338 times)

vdidenko

  • Recent member
  • *
  • Posts: 25
Exclusively using a device
« on: June 13, 2021, 09:18:19 pm »

As @mwillems mentions in a previous release thread:

Quote
I have had an issue where my web browser will sometimes (through pulse) open up a sink on my audio device even when no sound is playing through the browser.  This effectively prevents JRiver from using a hardware direct output as long as the browser is open.  So in that case the easiest thing is to set JRiver to use the pulseaudio output like everything else on the system, or if I want to use a hardware direct device for critical listening, I close my browser before starting playback.  It might be something different for you, that's just an example.

I do have exactly the same issue and it is hugely annoying - as I would like to be able to bring up the browser while listening, and I do not want to switch to switch MC27 to pulseaudio.

Here is what works for me as a manual (for now) procedure:
Code: [Select]
$ pactl list modules short
...............
25 module-alsa-card device_id="4" name="usb-Generic_USB_Audio-00" card_name="alsa_card.usb-Generic_USB_Audio-00" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
26 module-alsa-card device_id="3" name="usb-046d_Logitech_Webcam_C930e_7C6E4AAE-02" card_name="alsa_card.usb-046d_Logitech_Webcam_C930e_7C6E4AAE-02" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
27 module-alsa-card device_id="1" name="usb-Schiit_Audio_Schiit_USB_Multibit-00" card_name="alsa_card.usb-Schiit_Audio_Schiit_USB_Multibit-00" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
$ pactl unload-module 27
As a result all other apps happily work with the builtin audio (module 25), while MC27 uses it's own proper path.

Sure, it seems that it may be matched and disabled in UDEV rules given module-udev-detect.discovered=1  (per, for example, this suggestion), but it turned out finicky and needs a better match than I found so far.
Logged
Pages: [1]   Go Up