INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Unable to play to AirPods Pro  (Read 1514 times)

edbro

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 733
Unable to play to AirPods Pro
« on: March 31, 2022, 07:07:05 pm »

I am still unable to play standard 16bit Flac files to my AirPods Pro. These are 44.1khz files. Exclusive is not checked in Audio options. I've been having this problem since MC28.
Mac OS 12.3.1
MC 29.0.25 (Silicon)
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: Unable to play to AirPods Pro
« Reply #1 on: April 01, 2022, 07:37:01 am »

I suspect that AirPods Pro use some unusual native playback rate like 96kHz or something. 

You could try this setting and see if it helps:

Tools > Options > Audio > Advanced > auto configure output settings on playback error > YES

After you set the option, close and re-open MC, then try playing to your device.

Good luck.
Brian.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7349
  • The color of Spring...
Re: Unable to play to AirPods Pro
« Reply #2 on: April 01, 2022, 08:27:22 am »

AirPods Pro are limited to 48 kHz, aren't they? Seem to recall reading that. In addition to what Brian said, (and if they are limited to 48 kHz) you can also try opening up DSP Studio > Output Format and setting all the output sample rates to 48,000 Hz or whichever sample rate(s) they're limited to and see if that works.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2023 Update (23H2) 64-bit + Ubuntu 23.10 Mantic Minotaur 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | Topping D50s DAC

edbro

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 733
Re: Unable to play to AirPods Pro
« Reply #3 on: April 01, 2022, 09:14:18 am »

That seems to do the trick. I knew from previous problems that I had to change higher sample rates on hi-res files down to 48 but I didn't realize I had to alter the lower rates too. I'm curious though that I don't seem to have these considerations in any other program (VLC, Plex, Apple Music, etc)
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7349
  • The color of Spring...
Re: Unable to play to AirPods Pro
« Reply #4 on: April 01, 2022, 09:17:01 am »

I'm curious though that I don't seem to have these considerations in any other program (VLC, Plex, Apple Music, etc)

They all very likely resample in the background without informing the user.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2023 Update (23H2) 64-bit + Ubuntu 23.10 Mantic Minotaur 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | Topping D50s DAC

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13475
Re: Unable to play to AirPods Pro
« Reply #5 on: April 01, 2022, 03:41:33 pm »

DSP Studio in MC will do that as well if you set the MC option Audio->Advanced->Auto Configure Output Settings on Playback Error to YES.
Logged

edbro

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 733
Re: Unable to play to AirPods Pro
« Reply #6 on: April 01, 2022, 06:38:34 pm »

DSP Studio in MC will do that as well if you set the MC option Audio->Advanced->Auto Configure Output Settings on Playback Error to YES.
My MC had that option set to yes when I was getting the errors. I never set that so I assume that's the default? In any case, it didn't work for me.
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: Unable to play to AirPods Pro
« Reply #7 on: April 02, 2022, 06:45:08 am »

They all very likely resample in the background without informing the user.

It's not the programs doing the resampling; MacOS Core Audio does that.  It's not that the other programs are more sophisticated.  They are less sophisticated.  They just "throw" the audio at the Core Audio system and it takes care of all of the resampling, etc.

MC is much more specific:  They send a specific rate to a specific device.  This is a design choice because MC is supposed to be a very high audio quality player and MC customers want to know that they are sending the exact audio rate they specify to the audio device.  Generally speaking this is a great thing.  But in the case of Bluetooth devices it's a bit of a pain.

Brian.
Logged

aliciaviola

  • Galactic Citizen
  • ****
  • Posts: 391
Re: Unable to play to AirPods Pro
« Reply #8 on: April 19, 2022, 11:08:53 am »

You can make a new setting in the Audio-Midi setup tool on the MAC.
I did that on a German Mac with Monterey and it works with MC and all other programs that can control the audio in- and outputs.
Appended is a screen shot of my settings.
Put on your AirPods and connect them to the Mac.
Open the Audio-Midi setup, click "+" on the left side and choose "Aggregate Device".
There you will see different devices including your AirPods (two entries: one for the microphone, on for listening).
Activate the arrows that have a number for the output. In the drift correction arrows activate all already activated
(or only these you are using at the moment),only that for the AirPods has to remain empty. Set the sample rate to 48.0 kHz.
That's all. Hope that helps.
Frank
Logged

aliciaviola

  • Galactic Citizen
  • ****
  • Posts: 391
Re: Unable to play to AirPods Pro
« Reply #9 on: September 15, 2022, 04:01:59 am »

Here is the english Apple site to solve the problem:
https://support.apple.com/en-us/HT202000
Frank
Logged
Pages: [1]   Go Up