INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Linux Mint 21.1 Dependencies Missing  (Read 916 times)

hansbusch

  • Member
  • *
  • Posts: 2
Linux Mint 21.1 Dependencies Missing
« on: February 10, 2023, 02:51:45 am »

Hello I would like to install my Jriver27 on my Linux Mint 21.1 x64 Cinnamon. I followed the installation guide. However, I receive the following error message:

Code: [Select]
libpangox-1.0-0 (>= 0.0.2-5) not available.
Any idea where I can get this dependency? Thanks a lot.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7245
  • Long cold Winter...
Re: Linux Mint 21.1 Dependencies Missing
« Reply #1 on: February 10, 2023, 03:53:27 am »

I think this was fixed in a newer version of MC.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2023 Update (23H2) 64-bit + Ubuntu 23.10 Mantic Minotaur 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | Topping D50s DAC

hansbusch

  • Member
  • *
  • Posts: 2
Re: Linux Mint 21.1 Dependencies Missing
« Reply #2 on: February 10, 2023, 04:07:12 am »

So this means I can throw away the version I paid for and pay again for an update?
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7245
  • Long cold Winter...
Re: Linux Mint 21.1 Dependencies Missing
« Reply #3 on: February 10, 2023, 04:28:23 am »

You might give MC30 a try and see if it works. The hard truth is that Linux and macOS are less forgiving when it comes to backwards compatibility in regards to older Media Center releases unfortunately, and eventually they won't work anymore on newer Linux distros and macOS. Over time you'll encounter issues like this, either with dependencies being removed completely from a Linux distro or instances where newer Linux distros ship newer versions of dependencies which are incompatible with older Media Center versions.

This issue was fixed during the MC29 development cycle, as libpangox was removed in Debian's and Ubuntu's (which Mint is based on) repositories nearly a year ago. You can try forcing the package manager to ignore the missing dependency (e.g. sudo apt-get --ignore-missing install mediacenter27 in a terminal), I've never tried this and it may not even work anymore so your results may vary there.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2023 Update (23H2) 64-bit + Ubuntu 23.10 Mantic Minotaur 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | Topping D50s DAC
Pages: [1]   Go Up