INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Possible MacOS Problem with Coreaudio  (Read 794 times)

LilyAarseth

  • World Citizen
  • ***
  • Posts: 156
Possible MacOS Problem with Coreaudio
« on: August 13, 2022, 11:44:04 am »

I know this isn't a jriver app issue but but I thought I'd mention that people should be cautious about installing macos ventura beta 3, something seems off about coreaudio and when jriver tries to set exclusive mode it freezes up completely and only killing "coreaudiod" and media center 29 and then set it to not use exclusive and integer it will work properly. I started having the issue a few days ago on .66 and no change after updating to .86 so I'm positive it's something that has changed with coreaudio after my machine updated itself.

edit: as i was typing this i got an error message that it is unable to play 44.1 and then retried and it worked just fine, something definitely seems off and unstable about this version of macos in terms of audio driver.
Logged

AGAWA

  • World Citizen
  • ***
  • Posts: 239
Re: Possible MacOS Problem with Coreaudio
« Reply #1 on: August 14, 2022, 01:26:51 am »

no problem here; exclusive access on, integer off.
Logged

LilyAarseth

  • World Citizen
  • ***
  • Posts: 156
Re: Possible MacOS Problem with Coreaudio
« Reply #2 on: August 14, 2022, 03:40:19 pm »

I see, so many variables it's impossible ot know for sure what is to blame. Same amplifier, same firmware of the usb input of the amp, same cable, same usb port etc. only thing that changed that caused this frequent instability is the update to ventura beta 2 or 3 i'm unsure which as I haven't listened to music a lot the last few weeks when I updated the machine.

When both integer and exclusive is disabled, jriver still requests sample rate change, this seems to sometimes fail for no reason and trying again it plays fine, but sometimes the error persists and it works again if i do a manual change to the sample rate of macos within the audio midi setup utility. If jriver encounters an error when requesting exclusive it seems to crash coreaudio and it hangs until coreaudiod is killed and jriver is forced closed and restarted, or reboot of the machine.

I'm not blaming jriver for any of this since all points to something with coreaudio in the newer updates, but there is some kind of issue with the handshake or what it's called as a result of an api change or something apple did and if this is not just a quirk on my specific install/hardware could be fixed if someone else is experiencing it in the coming weeks/months when others move on to that os version.


After even more testing I can till reproduce the coreaudio crash even if there is no sample rate change and that it is both sample rat change with jriver and the exclusive mode that is causing issues. I tried playing music on spotify while changing between all the available sample rates in the audio midi setup utility and there were no issues at all.


tl;dr when jriver requests exclusive mode and/or a different sample rate than currently being used by macos it either fails to play (sample rate) or crashes coreaudio (exclusive mode) so all other audio in macos is not playing and safari and all sorts of other programs are freaking out. Even when it fails my amplifier briefly reports the sample rate that fails to play back so it's really strange.



another edit: I've tested another high quality dac and it's the same, so ruling out any hardware issues
Logged
Pages: [1]   Go Up