INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Problem Upgrading from V26 to V30 - Dependency Problem  (Read 1954 times)

RTV0070

  • Recent member
  • *
  • Posts: 7
Problem Upgrading from V26 to V30 - Dependency Problem
« on: May 10, 2023, 01:34:54 pm »

I currently have a Linux Mint 19.3 Running on my Nuc. It is currently running Media Server Version 26. I downloaded file name MediaCenter-30.0.93-amd64.deb from the link in this section of the forum. When I double click on the .deb file and select install, I get a red message saying:  "Error: Dependency is not satisfiable:libc6(>=2.28)"  I only have basic skills with Linux, so I don't know if I got the wrong package, or I'm doing something wrong. I did some searches but couldn't find anything like this posted already.

Thanks for any help.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5171
  • "Linux Merit Badge" Recipient
Re: Problem Upgrading from V26 to V30 - Dependency Problem
« Reply #1 on: May 10, 2023, 02:30:02 pm »

I currently have a Linux Mint 19.3 Running on my Nuc. It is currently running Media Server Version 26. I downloaded file name MediaCenter-30.0.93-amd64.deb from the link in this section of the forum. When I double click on the .deb file and select install, I get a red message saying:  "Error: Dependency is not satisfiable:libc6(>=2.28)"  I only have basic skills with Linux, so I don't know if I got the wrong package, or I'm doing something wrong. I did some searches but couldn't find anything like this posted already.

Thanks for any help.

It looks like you're running a very old release of Mint.  19.3 was launched in 2019, and Mint's support for that version either already ended or will end very soon (it's supported until "2023"). So I suspect based on that and the error message that your system libraries are too old to run the current version of Media Center.  You should probably upgrade your Mint version (not only because of MC) because your OS either is or will soon be out of support from Mint. 

It's also worth noting in passing that while JRiver MC works on most Linux distros it's only officially supported on Debian, so you run a greater risk of these kinds of issues on other distros.  That said, many people post on the forums who are running MC successfully on newer versions of Mint, so I suspect a newer version of Mint will probably fix your issue.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7357
  • The color of Spring...
Re: Problem Upgrading from V26 to V30 - Dependency Problem
« Reply #2 on: May 10, 2023, 04:47:51 pm »

Linux Mint 19's support ended in April 2023, so last month.

But yeah, Linux Mint 19.3 is too old to run MC30 unfortunately.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2023 Update (23H2) 64-bit + Ubuntu 23.10 Mantic Minotaur 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | Topping D50s DAC | Edifier R2000DB Bookshelf Speakers
Pages: [1]   Go Up