INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: IdPi has a glitch at the end of tracks  (Read 592 times)

fegelmej

  • Recent member
  • *
  • Posts: 37
IdPi has a glitch at the end of tracks
« on: December 14, 2023, 05:37:32 pm »

Hello, I've been running a IdPi for a couple of years, with the files living on a NAS.  Things have been fairly stable.  Recently, I've noticed that with 2 seconds remaining in a track there is a glitch of silence.  Not missed info, a gap that lasts a half second and then the music returns without skipping that half second.  Is this a crossover thing? In player options I am running gapless for album tracks and no crossover.  On other servers, using the same NAS database, I don't have this issue.  Would love thoughts and suggestions.

Cheers
 
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13361
Re: IdPi has a glitch at the end of tracks
« Reply #1 on: December 14, 2023, 05:40:41 pm »

Hello, I've been running a IdPi for a couple of years, with the files living on a NAS.  Things have been fairly stable.  Recently, I've noticed that with 2 seconds remaining in a track there is a glitch of silence.  Not missed info, a gap that lasts a half second and then the music returns without skipping that half second.  Is this a crossover thing? In player options I am running gapless for album tracks and no crossover.  On other servers, using the same NAS database, I don't have this issue.  Would love thoughts and suggestions.

Cheers
 
I guess the first question is:
What is your audio output device, the Id or something else connected on the network?
If the Id, an internal port or a connected DAC?

Second, how are you accessing the files from the DAC, as a file mount on the Id or as a DLNA server?

Logged

fegelmej

  • Recent member
  • *
  • Posts: 37
Re: IdPi has a glitch at the end of tracks
« Reply #2 on: December 15, 2023, 04:20:43 pm »

Thanks Bob,  I'm running a Benchmark DAC via USB.  I've imported a file mount on the Id.

Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13361
Re: IdPi has a glitch at the end of tracks
« Reply #3 on: December 18, 2023, 11:12:23 am »

Thanks Bob,  I'm running a Benchmark DAC via USB.  I've imported a file mount on the Id.
Well that's about the cleanest setup you can get.

Is the external file mount on a spinning disk? Kind of sounds like a wait for it to spin up the next track.

You might try messing with the buffering parameters. You can change the hardware buffering in the Id's Audio Settings. There are 2
buffer time
and
period time
400000 = .4 sec
100000 = .1 sec

You might try increasing them and see if that changes anything.

Another thing to check is the pre-buffering in audio settings. Perhaps increase that from 6 to 10 seconds.
Logged
Pages: [1]   Go Up