INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Episode Thumbnail Issue SiliconDust Guide Data [SOLVED MC v32]  (Read 991 times)

tzr916

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1342
Episode Thumbnail Issue SiliconDust Guide Data [SOLVED MC v32]
« on: December 20, 2023, 09:03:31 am »

Having an issue that has me stumped after changing to SiliconDust guide data...

My old guide data provider did not provide any episode thumbnails, so MC would simply capture a thumbnail from the designated time/position in the recorded video. This has worked for years.

I found that SiliconDust guide data provides episode thumbnails, which is actually kinda cool. Problem is, MC fails to display half of them, instead it just shows a non-built thumbnail icon. MC Reporter says 100% thumbnails built and Tools > Advanced > Build Missing Thumbnails => 0 thumbnails built. Restart MC and restarting PC doesn't help either.

The jpg properties all appear identical - 360x270 96dpi 24bit with file sizes less than 50kb. Windows can display the offending jpg's just fine, but not MC. If I move/delete the offending jpg out of the TV Logos directory and tell MC to rebuild thumbnail, then it captures a thumbnail from the designated time/position in the recorded video and correctly displays it. But, if I move the offending jpg back into the TV Logos directory, MC goes back to just showing a non-built thumbnail icon.

In the capture below, you can see out of the ten recordings from last night, six have the SiliconDust thumbnail and four just have the non-built thumbnail icon. And all the older recordings have the captured from video thumbnail.

Logged
JRiverMC v32 •Windows 10 Pro 64bit •Defender Exclusions •ṈŘ 3rd party AV
•ASUS TUF gaming WiFi z590 •Thermaltake Toughpower GX2 600W
•i7-11700k @ 3.6GHz~5GHz •32GB PC4-25600 DDR4
•OS on Crucial P5 Plus M.2 PCIe Gen4 •Tv Recordings on SATA 6TB WD Red Pro
•4 OTA & 6 CableCard SiliconDust Tuners
•nVidia RTX2060 •XBR65Z9D •AVRX3700H •Fluance 7.2.2 [FH]
•SMP1000DSPѫRSS315HE-22■DIYSG Cube-12
•SPA300Dѫ15-PRX8S4■YSTSW215

tzr916

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1342
Re: Episode Thumbnail Issue After Changing Guide Provider
« Reply #1 on: December 21, 2023, 08:31:55 am »

Second night of SiliconDust guide data download => tv shows that I had watched and deleted yesterday, leave the original episode.jpg in the TV Logos directory, and a duplicate episode.jpg(1) is being put into the TV Logos directory :( So my TV Logos directory is just going to grow and grow and grow... And the duplicate episode.jpg(1) still doesn't show a thumbnail in MC at all.

What can be done about this? Why don't these jpg's show a thumbnail in MC? Maybe there is some way I can just block these episode.jpg from SiliconDust?
Logged
JRiverMC v32 •Windows 10 Pro 64bit •Defender Exclusions •ṈŘ 3rd party AV
•ASUS TUF gaming WiFi z590 •Thermaltake Toughpower GX2 600W
•i7-11700k @ 3.6GHz~5GHz •32GB PC4-25600 DDR4
•OS on Crucial P5 Plus M.2 PCIe Gen4 •Tv Recordings on SATA 6TB WD Red Pro
•4 OTA & 6 CableCard SiliconDust Tuners
•nVidia RTX2060 •XBR65Z9D •AVRX3700H •Fluance 7.2.2 [FH]
•SMP1000DSPѫRSS315HE-22■DIYSG Cube-12
•SPA300Dѫ15-PRX8S4■YSTSW215

Yaobing

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10876
  • Dogs of the world unite!
Re: Episode Thumbnail Issue After Changing Guide Provider
« Reply #2 on: January 05, 2024, 09:50:20 am »

Matt and Hendrik recently fixed the jpg image issue.  Now all program logos that previously could not be displayed are now in MC32.

I also tried deleting some recordings.  The logo files are deleted too.  If you still see those images not deleted, in MC32 when it comes out, please let us know.
Logged
Yaobing Deng, JRiver Media Center
Pages: [1]   Go Up