INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: JRemote not connecting to Media Center over LAN [Solved]  (Read 1682 times)

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
JRemote not connecting to Media Center over LAN [Solved]
« on: November 23, 2023, 07:08:51 pm »

I have been using JRemote to play music for the Media Center on my LAN for years, without issues. Today, I could not connect from JRemote on my iPhone to the MC on my iMac. It has been a few weeks since I last used it, so figuring something changed (iPhone/Mac OS/MC/etc. update?). I have been trouble shooting for the past three hours without success and wanted to solicit ideas.

I have gone though the JRiverWiki - [url=http://wiki.jriver.com/index.php/Network_Access]Network Access[/url]. I have JRemote on two iPhones that I use to connect to MC on my iMac. They are all connected in my home over the WiFi. When I try to connect, my Response Status is OK. Wireless Service is enabled. The keyid is correct, and I have also tried generating a new key. MC is set with my Firewall to accept incoming connections. I contacted my Internet Provider who tested and found no issues. JRemote is trying to connect to an internal IP address over Port 52199 when it times out. Not sure it should be going through Port 52199 as I am only connecting from within my LAN. I have also tried connecting directly to my IP address, resulting in the same issue. The Playing Now/Playing From is set to my Main Library.  My Media Network is configured for Generic DLNA.

Any ideas would be appreciated.

 
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN
« Reply #1 on: November 23, 2023, 07:21:51 pm »

I also used Terminal to test my IP address and Port 52199.  The connection was successful.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN
« Reply #2 on: November 23, 2023, 07:42:00 pm »

Enclosed are the logs
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71735
  • Where did I put my teeth?
Re: JRemote not connecting to Media Center over LAN
« Reply #3 on: November 23, 2023, 08:05:46 pm »

Is port 1900 open for SSDP?
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN
« Reply #4 on: November 23, 2023, 08:06:59 pm »

I am having difficulty determining if ports 1900 and 52199 are open.  Using Terminal, some netcom input shows successful (-vnzu) or state connection refused (-zv).  Talked with two Apple Tier Two support to see how I can accurately check port status.  Neither said they could support and referred me back to JRiver.

Since I used JRemote last, I have updated my IOS, Mac OS to Sonoma, and JRiver to 31.0.83, so not sure where the issue is.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN (Fixed)
« Reply #5 on: November 25, 2023, 02:27:51 pm »

Today I was able to connect JRemote to MC when I had my iPhone plugged into my iMac to recharge.  I tried to do it over WiFi and was back to timing out.  I plugged it back in... and am timing out again.
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: JRemote not connecting to Media Center over LAN
« Reply #6 on: November 26, 2023, 05:11:30 pm »

My guess is that the Mac firewall has changed in some way.  Turn the firewall off for a few minutes to test it:

system settings > network > firewall > OFF

Stop MC and restart it.  Then test with JRemote again.  If that works, it's just a matter of getting the correct exceptions into the firewall.  If that does not work, there are other steps to take.

Brian.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN
« Reply #7 on: November 26, 2023, 06:32:14 pm »

I turned off the firewall for five minutes.  I closed and reopened MC as well as JRemote.  Still timing out.
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: JRemote not connecting to Media Center over LAN
« Reply #8 on: November 27, 2023, 08:09:25 am »

It's worth checking your network settings at this point.  Is the Mac on wifi, or ethernet, or both?  You should check the IP address of the Mac and the iPhone.  Make sure they are in the same network.

It sounds like something has changed and one or the other is on a different network.

Do you run anything else on the Mac that your iPhone/iPad access over the network?  Plex, Emby, etc?  Do those work?

Brian.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN
« Reply #9 on: November 27, 2023, 10:21:43 am »

The Mac is on the WiFi and it is on the same network as my and my wife's iPhones/JRemote.  My Mac's IP address is shown correctly in JRemote's server settings.  When I look at the server response log, it too shows the correct IP address.

JRemote's log shows found 2 connections.  The first is my Mac's IP address and second is 068-188-169-030.res.spectrum.com

Spectrum is my ISP.  I contacted them and they cannot see any issues from their end.  However, they are sending a new router, which should be here Wednesday.

No Plex or Emby, but I am able to do Airdrops over the network with no issues.

I have been using JRemote for years without issue.  On Thanksgiving, I tried to use it and it would not connect from any device.  Been trying to figure out what changed and how I can get it back.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: JRemote not connecting to Media Center over LAN
« Reply #10 on: November 27, 2023, 10:53:12 am »

You aren't using a VPN on the iOS device are you?
If that's on, you probably can't connect with JRemote on the LAN.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN
« Reply #11 on: November 27, 2023, 11:34:35 am »

No VPN either
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: JRemote not connecting to Media Center over LAN
« Reply #12 on: November 27, 2023, 12:01:07 pm »

No VPN either
Did it find your LAN address?
If you are on the LAN it doesn't need the spectrum address.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN
« Reply #13 on: November 27, 2023, 12:13:56 pm »

The new router came in.  Got it set up and everything is working again.  Looks like my router went bad.

"Incredibly happy" to have my music back!!!!

Thank you
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: JRemote not connecting to Media Center over LAN
« Reply #14 on: November 27, 2023, 01:27:25 pm »

The new router came in.  Got it set up and everything is working again.  Looks like my router went bad.

"Incredibly happy" to have my music back!!!!

Thank you
Good to hear you got it going.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN [Back again]
« Reply #15 on: November 27, 2023, 03:34:55 pm »

That was short lived.  Mailed the router back, returned home, tried to reconnect... and back to timing out.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #16 on: November 27, 2023, 03:57:11 pm »

Take a screen shot of the connect message and attach it here.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #17 on: November 27, 2023, 04:06:01 pm »

Here they are.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #18 on: November 27, 2023, 04:34:34 pm »

Talked to Spectrum, who refreshed the router.  Back to connecting.  Going to see if I stay connected.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #19 on: November 27, 2023, 05:27:15 pm »

If you are on the same LAN it's just trying to connect to 192.168.1.107 which should be your PC's IPV4 address from its own address which should also be on the 192.168.1.X network (check the iOS wireless network settings (i))
The router shouldn't even be in the picture.
Is your PC and JRemote connected to the same LAN?
Is the LAN the router LAN?
If it is, there's either an issue with the route or the router itself is filtering packets. LAN's are supposed to be transparent.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #20 on: November 28, 2023, 03:19:15 pm »

Today, again not able to connect.

The two iPhones with JRemote and my Mac are on the same LAN.  JRemote is trying to connect to my IP address, and then back thru Spectrum.  Each time Spectrum resets the router, I am good for an hour or two.  I will ask them about the packet filtering.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #21 on: November 28, 2023, 03:42:23 pm »

Today, again not able to connect.

The two iPhones with JRemote and my Mac are on the same LAN.  JRemote is trying to connect to my IP address, and then back thru Spectrum.  Each time Spectrum resets the router, I am good for an hour or two.  I will ask them about the packet filtering.
There's no reason at all for it to connect through spectrum if you are on the same LAN as the PC.
What device is providing the wifi for the phones?
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #22 on: November 28, 2023, 04:11:12 pm »

My Spectrum router is providing the Wi-Fi.  This afternoon, Spectrum's tech support said that there was no issue with their router and suggested that I should by my own to test it.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #23 on: November 28, 2023, 05:03:09 pm »

My Spectrum router is providing the Wi-Fi.  This afternoon, Spectrum's tech support said that there was no issue with their router and suggested that I should by my own to test it.
I suspect it's an issue with routing from the lan to the wifi or perhaps it has a firewall enabled on your inside network.
You could look at the config on the router or perhaps if you have another router laying around plug it into one of the spectrums lan ports and use that as the wifi for your phones and its ethernet lan for your PC instead of the spectrum lan and wifi.
You could daisy chain them using the wan port on the separate router to connect to a lan port on the spectrum to start with. If it solves your issue you might want to change it so the the lans are connected together instead. That's a bit more complicated to setup so maybe just test it as described above.

Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #24 on: December 02, 2023, 11:50:08 am »

Spectrum (ISP) said they were having issues with UPnP and recommended turning it off.  Turning it off gave a host of new issues.  The work around for now is to turn the iPhone wifi off and then back on when using JRemote.  Takes about three seconds and I can again access MC.

Thank you for the assistance.  I will look at a new router after the new year... or maybe go back to Windows.

I have seen some developers (gaming) ending support for the Intel based Macs as they will not be supporting the Apple M chips.  Will JRiver continue support the legacy Macs?
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: JRemote not connecting to Media Center over LAN [Solved]
« Reply #25 on: December 02, 2023, 09:23:22 pm »

Spectrum (ISP) said they were having issues with UPnP and recommended turning it off.  Turning it off gave a host of new issues.  The work around for now is to turn the iPhone wifi off and then back on when using JRemote.  Takes about three seconds and I can again access MC.

Thank you for the assistance.  I will look at a new router after the new year... or maybe go back to Windows.

I have seen some developers (gaming) ending support for the Intel based Macs as they will not be supporting the Apple M chips.  Will JRiver continue support the legacy Macs?

JRemote doesn't use UPnP. MC does, of course, with other UPnP devices on the network, like DLNA renderers and other instances of MC on different computers.

Our next change would be to remove support for versions <10.13. That is not a given yet.
We have no plans to abandon Intel support.
Logged

MajorCyco

  • Junior Woodchuck
  • **
  • Posts: 64
Re: JRemote not connecting to Media Center over LAN [Issue Closed]
« Reply #26 on: December 26, 2023, 04:20:31 pm »

I replaced my Spectrum router with a Synology WRX560.  Been using for a week now, with zero issues connecting to MC.  Just wanted to say thank you for the assistance.
Logged
Pages: [1]   Go Up