INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: 90GB JRiver log file  (Read 279 times)

thecrow

  • MC Beta Team
  • Galactic Citizen
  • *****
  • Posts: 444
90GB JRiver log file
« on: February 12, 2024, 02:58:28 pm »

Noticed a warning that my O/S boot drive is full.
Eventually tracked down the culprit to a hidden MC32 folder containing a massive 90GB Log.txt file that is completely filling my drive.
I've tried deleting it and emptying the trash, but it instantly recreates itself.

How do I get rid of this and stop MC doing this again?
Logged

zybex

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 2434
Re: 90GB JRiver log file
« Reply #1 on: February 12, 2024, 03:56:43 pm »

Disable logging in Help->Logging menu. It must have been enabled for a looooong time to create such a huge file!
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10772
Re: 90GB JRiver log file
« Reply #2 on: February 12, 2024, 05:44:37 pm »

You can also set a maximum log file size after which it starts cutting it off. I believe we set a default limit of 10MB at some point, too.
Logged
~ nevcairiel
~ Author of LAV Filters

thecrow

  • MC Beta Team
  • Galactic Citizen
  • *****
  • Posts: 444
Re: 90GB JRiver log file
« Reply #3 on: February 13, 2024, 05:18:13 am »

Thanks for the replies.

This is an install of MC32, so cannot have been that long ago, even if enabled on install.
As I didn't know where the logging menu was, I cannot have enabled this knowingly, nor altered the default limit to 100s of GBs.
How was MC able to recreate the 90GB file instantly after I deleted it and emptied the trash?

This was my server running 32.0.8, as a test I re-enabled logging and checked how the log.txt file grew, with MC just sitting there.
After 30 seconds it was 250MB, after 2 minutes 30 seconds it was 2GB.
Feeling this was not right I updated to the latest 32.0.16 and rechecked.
After 2 min 30secs it is now only 600k rather than 2GB, which seems more reasonable.

Don't know if it was the update or just the restart that changed its behaviour.

Anyway, it is gone now thanks.
Logged
Pages: [1]   Go Up