INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: MC32: WASAPI audio device issue.  (Read 283 times)

furgiuele

  • Recent member
  • *
  • Posts: 36
MC32: WASAPI audio device issue.
« on: February 16, 2024, 07:51:54 pm »

My PC is connected to my Trinnov A16 preamplifier via HDMI and in JRiver MC I have always set "Altitude (NVIDIA High Definition Audio) WASAPI" as the audio device. With MC32, if I exit Theater View mode the audio signal is completely distorted and I have to restart MC32 and use it only in Theater View. The problem is resolved if I set "Altitude (NVIDIA High Definition Audio) Direct Sound" as audio device. But I always thought the WASAPI driver was better. Can anyone give me some advice?
​Thanks.
Logged

htnut

  • Junior Woodchuck
  • **
  • Posts: 99
Re: MC32: WASAPI audio device issue.
« Reply #1 on: February 17, 2024, 12:50:02 am »

There are ongoing debates about Windows touching the sample rate under DirectSound. But using bitstreaming:on and DirectSound my amplifier does the decoding so it seems it is, in fact, getting a clean data stream. Try that and report if any issues.
Logged

furgiuele

  • Recent member
  • *
  • Posts: 36
Re: MC32: WASAPI audio device issue.
« Reply #2 on: February 17, 2024, 06:18:48 pm »

I have always used bitstreaming: on, which is essential for decoding Atmos, DTS-X, etc. signals in the pre. It works perfectly for me too with direct audio, but being the device used by Windows (also for system audio) it seems to have a negative impact. Instead with Wasapi, the device is for exclusive use by JRiver MC. However, I solved: the problem was that I had set the minimum buffer in the Wasapi audio device settings, so as not to have a delay with respect to the video. I reset 100ms and the defect disappeared. The problem remains that in some videos the audio is not synchronized and I have to do it myself...
Is there a way to have the audio automatically synchronized with the video, with the buffer set to 100ms?
Thanks.
Logged
Pages: [1]   Go Up