INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Autostart on boot  (Read 261 times)

David Sydney

  • Galactic Citizen
  • ****
  • Posts: 350
Autostart on boot
« on: March 02, 2024, 08:55:50 pm »

Started my PC this morning and found that MC32 starts on booting up windows. I notice that there is an entry now in the Task manager/startup list. Not sitting in the Start menu startup folder so it must be some kind of registry entry. Mildly annoying as I contain all start up apps to a bare minimum.

I cannot find the reason why because in MC under options, startup, then "Run on Windows Start Up" setting = 'Nothing' ? not 'Media Center'?

where else should I look for what is driving this?
Logged
Dave
------
Linux Manjaro 23 / Windows 10 Pro | i7 14700K Gigabyte Z790 UD AX | JRMark 10253 | Realtek Integrated HDAudio SPDIF | PC Sound - Yamaha TSS-15 5.1 DAC (will be sad when capacitors die!)| Real Sound - DLNA Network to Yamaha RX-V777 Receiver Living Room + Deck | DLNA to Paired Yamaha WiFi WX-010 MusicCast Speakers to Outside Areas

zybex

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 2434
Re: Autostart on boot
« Reply #1 on: March 03, 2024, 04:10:53 am »

Could be leftovers from a previous version after you upgraded? Try enabling the "Run at Windows Startup" option, clicking OK to apply it, then go there again and disable it.

If this doesn't work then you'll have to remove it manually. You can use Autoruns to remove it.
https://learn.microsoft.com/en-us/sysinternals/downloads/autoruns
Logged

markf2748

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 724
Re: Autostart on boot
« Reply #2 on: March 03, 2024, 11:19:18 am »

Something else to try:
In the Windows Services window look for "JRiver Media Center 32 Service".
In its Start Type column, be sure the setting is "Manual" (not "Automatic").
To change it: RMB on the entry > Properties > Start type (in popup) > Manual
If that does not help, you can try selecting "Disable", but I'm not sure where that will leave you in terms of MC performance, and it shouldn't be necessary anyway.

While you are there, if old versions are listed, either delete them or set to "Disable".

Some ways to find the Windows Services window:
1) Windows Taskbar search box, enter "Services".  Run as administrator.
2) RMB Windows Taskbar > Task Manager > Services Tab > RMB Media Center 32 > Open Services.

BTW, re registry:  I recently used regedit to search my registry for "media".  I must have found well over 50 entries referring to old uninstalled versions of MC, going back to version 28 right up to MC 31 and 32.  I took a chance and very carefully deleted every entry prior to MC 31.  So far, no ill effects noticeable.  That kind of extensive registry cleanup should not be necessary, and I don't recommend messing with the registry directly to solve your problem.
Logged
Pages: [1]   Go Up