INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Image Slideshow always showing the gray rectangle of the caption when is empty  (Read 182 times)

anilabangel

  • Member
  • *
  • Posts: 2

Hello, I recently upgraded from MC22 to MC32, and I've seen that the image slideshow caption doesn't behave the same of MC22.
I've always used this expression on the caption field, to show image caption tag but only when it changes:
if(IsEqual([Caption],Load(_old_Caption)),Clean(,0),[Caption]) Save([Caption],_old_Caption,0)

in MC22 when the Caption tag is the same of the previous image then nothing is shown in overlay on the image, and this is the behavior desired.
In MC32 instead (may be also in older releases) the gray box on bottom is always shown, the text is hidden when there is no change but the background box is always shown empty.
It disappears after some seconds if I stop the slideshow, but is always shown when the slideshow is playing (interval 5 seconds).

Is this a bug? Is there any way of achieving the same behavior it was in MC22?
Thanks
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42032
  • Shoes gone again!

You just have an extra space in your expression so it resolves to " " instead of "".

I think you want this:
if(IsEqual([Caption],Load(_old_Caption)),Clean(,0),[Caption])Save([Caption],_old_Caption,0)

Thanks.
Logged
Matt Ashland, JRiver Media Center

anilabangel

  • Member
  • *
  • Posts: 2

it works now, great, thank you!
Logged
Pages: [1]   Go Up