INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: [BUG] Browse/Rules does not return playlists  (Read 175 times)

mattkhan

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3966
[BUG] Browse/Rules does not return playlists
« on: April 14, 2024, 10:23:46 am »

my remote views includes a node for playlists however this is not returned via MCWS/v1/Browse/Rules

Browse/Rules is used in my homeassistant plugin to determine what media type/sub type exists under a given node (NB: this info is used by the HA UI to decide how to render a node), i.e. it expects Browse/Rules to be completely consistent with Browse/Children so it ignores items returned by the latter that can't be matched against the former

as a result, the HA plugin ignores playlists which is not good

I think it would be better to avoid hacks in the plugin (i.e. special case logic for playlists) so can this be fixed in MC ?
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41967
  • Shoes gone again!
Re: [BUG] Browse/Rules does not return playlists
« Reply #1 on: April 15, 2024, 10:36:12 am »

The Browse/Rules function only looks at the library views you have configured.

Adding a playlists view to the view info tree will not be returned.

It's coded this way because you can also say "Tree" for the type and in that case the library view structure is all that's available.
Logged
Matt Ashland, JRiver Media Center

mattkhan

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3966
Re: [BUG] Browse/Rules does not return playlists
« Reply #2 on: April 15, 2024, 12:40:51 pm »

it's confusing because Playlists is in both the main tree and can be in the remote tree too, it really looks like a node in the tree to me but I guess I have to hack some special case logic in.
Logged
Pages: [1]   Go Up