INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Marantz SA-KI Ruby/SA 12 WASAPI problem.  (Read 300 times)

Haim

  • Member
  • *
  • Posts: 3
Marantz SA-KI Ruby/SA 12 WASAPI problem.
« on: April 21, 2024, 02:10:57 am »

WASAPI don't work in JRiver 32 Media center. Kernel and ASIO work correctly. JRiver Media center 28 WASAPI works correctly.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71470
  • Where did I put my teeth?
Re: Marantz SA-KI Ruby/SA 12 WASAPI problem.
« Reply #1 on: April 21, 2024, 08:16:29 am »

I assume that WASAPI does work for lower bitrate files.  Can you test?
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7402
  • The color of Spring...
Re: Marantz SA-KI Ruby/SA 12 WASAPI problem.
« Reply #2 on: April 21, 2024, 08:26:44 am »

Looks like you're trying to output DSD via DoP. Am I correct to assume you have DSP Studio > Output Format > Output Encoding set to 2xDSD in DoP format so it converts everything?

You might need to post a screenshot of the audio path from MC28 and and one from MC32 and compare MC28's to MC32's audio path and compare the audio settings between each.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

Haim

  • Member
  • *
  • Posts: 3
Re: Marantz SA-KI Ruby/SA 12 WASAPI problem.
« Reply #3 on: April 27, 2024, 09:27:25 am »

Setups are same in both version. 28 version works correctly. But 32 version does not work.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7402
  • The color of Spring...
Re: Marantz SA-KI Ruby/SA 12 WASAPI problem.
« Reply #4 on: April 27, 2024, 09:47:41 am »

How are you connected to the Ruby? USB, I assume?
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

Haim

  • Member
  • *
  • Posts: 3
Re: Marantz SA-KI Ruby/SA 12 WASAPI problem.
« Reply #5 on: April 27, 2024, 10:19:30 am »

Connected by USB.
Logged

dtc

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3020
Re: Marantz SA-KI Ruby/SA 12 WASAPI problem.
« Reply #6 on: April 28, 2024, 01:19:53 pm »

Can you check Audio Path and be sure they show the same thing for both versions.
Logged

terrym@tassie

  • MC Beta Team
  • Galactic Citizen
  • *****
  • Posts: 474
Re: Marantz SA-KI Ruby/SA 12 WASAPI problem.
« Reply #7 on: April 28, 2024, 06:03:53 pm »

I am a bit confused why it is being recommended that the OP check 'Audio Path', this will only show valid information if a file is playing AFAIK, in this case playback is failing to start on MC32 (see screenshot in original post).

I would suggest that to ensure that the settings are identical between MC28 & MC32, restore a library backup from MC28 to MC32 but check 'Settings only'.

I am also assuming that MC28 and MC32 are running on the same system.

If playback still can't be started on MC32 after doing the library restore from MC28 then I would suggest the best approach would be to turn on logging in both MC28 and MC32 (Help>Logging>Enable logging), initiate playback of the same file on MC28 & MC32 and post the resulting logs.
Logged
" I like work: it fascinates me. I can sit and look at it for hours." -Jerome K. Jerome

dtc

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3020
Re: Marantz SA-KI Ruby/SA 12 WASAPI problem.
« Reply #8 on: April 28, 2024, 06:36:18 pm »

My mistake on Audio Path. I thought he was sometimes getting playback, but, you are correct he is not. My mistake. Looking at Audio Path on MC28 would at least confirm that what he thinks is playing is actually playing. Just another piece of information.
Logged
Pages: [1]   Go Up