INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Poor video quality using TV zone  (Read 260 times)

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 505
Poor video quality using TV zone
« on: April 21, 2024, 07:36:02 am »

All my computing and AV kit has a wired Ethernet connection to my local network. Both my primary Windows 11 workstation and an Intel NUC 8i3CYSM also have HDMI links to a Denon AV amp, which is connected to a 65" LG OLED television. For several years, I have been successfully using the Intel NUC as an HTPC to play rips of my Blu-ray collection on the TV (which acted as the Windows 11 display for the NUC). However, the NUC's HDMI output has stopped working and it is no longer usable.

Rather than fix or replace the NUC, I have decided to use my workstation PC as the HTPC. Windows is configured on this computer to use the TV as its third display, though I seldom use that option as my back is to the TV when working at the computer.

The most obvious and convenient way to exploit my workstation as an HTPC was to select my 'LG OLED65 TV' zone in MC 32 (a zone I have never used before), but the video quality was disappointingly poor. In contrast, if I start playing a video in MC, detach the display and then drag that display to my third display (the TV) then I obtain the video quality I was expecting.

Can anyone explain why my TV zone might be degrading the video?   
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient
Re: Poor video quality using TV zone
« Reply #1 on: April 21, 2024, 08:46:03 am »

Did you create the TV zone yourself or did it just magically appear?  If the latter it's probably the TV advertising itself as a DLNA client and you're not actually directly transmitting the video via HDMI, but rather using the network.  If that's the case, you can find the DLNA options for the device and change the video quality that JRiver sends, but you'll probably be better off playing to the TV directly via HDMI if that's the case.
Logged

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 505
Re: Poor video quality using TV zone
« Reply #2 on: April 21, 2024, 09:43:11 am »

Yes, that TV zone just appeared in MC without any action by me. How do I configure MC to use DLNA for this zone?

Another issue has just emerged with simply using the TV as a third monitor for my workstation. The Info button on my Denon AV amp tells me that it is only receiving a stereo signal when playing a Blu-ray rip with a DTS-HD MA soundtrack. This was not a problem when I used the Intel NUC as my HTPC, but MC was probably configured differently on that machine.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient
Re: Poor video quality using TV zone
« Reply #3 on: April 21, 2024, 09:59:34 am »

Yes, that TV zone just appeared in MC without any action by me. How do I configure MC to use DLNA for this zone?

Another issue has just emerged with simply using the TV as a third monitor for my workstation. The Info button on my Denon AV amp tells me that it is only receiving a stereo signal when playing a Blu-ray rip with a DTS-HD MA soundtrack. This was not a problem when I used the Intel NUC as my HTPC.

It's already using DLNA, which is creating the problem.  You can configure the DLNA server options for the zone by going into options-->Media Network --> Add or configure DLNA servers, but you'll almost certainly be better off not using that zone and instead just using the TV as a monitor.

For your second issue, have you checked the audio path during playback?  It's possible that JRiver has been configured to send a stereo signal instead of a multi-channel signal.  Looking at Audio Path while a Blu Ray is playing will tell you the answer to that question.  If JRiver is outputting stereo you just need to adjust your output format settings.  If JRiver is outputting multi-channel, but the receiver is receiving stereo than something in the middle is downmixing (likely the TV).
Logged

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 505
Re: Poor video quality using TV zone
« Reply #4 on: April 21, 2024, 10:36:02 am »

...... have you checked the audio path during playback?  It's possible that JRiver has been configured to send a stereo signal instead of a multi-channel signal.  Looking at Audio Path while a Blu Ray is playing will tell you the answer to that question.  If JRiver is outputting stereo you just need to adjust your output format settings.  If JRiver is outputting multi-channel, but the receiver is receiving stereo than something in the middle is downmixing (likely the TV).

The Audio Path in JRiver confirms that it is sending "48kHz 24bit 6ch Direct Sound (not a direct connection)" to my AV amp. This amp plays the audio via my surround sound system, so the TV sound settings don't appear to be relevant.
Logged

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 505
Re: Poor video quality using TV zone
« Reply #5 on: April 21, 2024, 11:19:15 am »

As previously mentioned, my AV amp's Info display tells me it is receiving stereo from JRiver. It also says it is a PCM signal, not DTS. Bitstreaming is turned off (as recommended) in JRiver's audio settings and DSP is not active.

It's all very puzzling for my aging brain...
Logged

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 505
Re: Poor video quality using TV zone
« Reply #6 on: April 21, 2024, 11:36:48 am »

Problem solved. Bitstreaming needs to be ON for the HDMI output to get multichannel. I already knew that setting was important but had incorrectly remembered what that setting should be. Grrrr.

It seems rather strange that JRiver recommends Bitstreaming should be turned off....
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient
Re: Poor video quality using TV zone
« Reply #7 on: April 22, 2024, 08:33:26 am »

Problem solved. Bitstreaming needs to be ON for the HDMI output to get multichannel. I already knew that setting was important but had incorrectly remembered what that setting should be. Grrrr.

It seems rather strange that JRiver recommends Bitstreaming should be turned off....

They recommend leaving it off because it's only relevant for very specific situations (people sending multichannel audio to a receiver via HDMI or SPDIF) and bitstreaming can cause lots of other issues for people who are not in that specific situation (as I recall it disables several volume control modes in JRiver, prevents certain DSP options from working, etc.).  It just so happens you're the person for whom bitstreaming is the right answer!
Logged

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 505
Re: Poor video quality using TV zone
« Reply #8 on: April 23, 2024, 04:17:50 am »

I just realised this morning that turning on bitstreaming to make multichannel audio work properly on my AV system made the same videos unplayable on my PC. However, that was soon fixed by creating a separate zone without bitstreaming for local playback.

JRiver Media Center always seems to have an answer to every problem :)  :) :)
Logged
Pages: [1]   Go Up