INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Multichannel PCM soundtracks for ripped Blu-rays only seen as stereo by AV amp  (Read 366 times)

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 509

All of my Blu-ray collection has been ripped using MakeMKV and I play them using MC32. Several of these rips are of classical music recordings with multichannel PCM soundtracks, but my Denon X8500H AV amp only sees them as stereo PCM signals and the 'Multichannel IN' sound mode is not available. However, when I play the original Blu-rays the Denon recognises the multichannel PCM and automatically invokes the 'Multichannel IN' sound mode.

Have I missed some obscure setting in MC32 that would fix this problem?

 
Logged

cncb

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 2966

Have you set MCs audio output to HDMI bitstreaming?
Logged
-Craig    MO 4Media remote and player:  Android/TV/Auto | iOS | Windows 10/UWP

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 509

Have you set MCs audio output to HDMI bitstreaming?

I was a little unsure about whether HDMI bitstreaming should be on or off, so I tried it both ways, but it made no difference. In both cases, the INFO button on my Denon told me it was receiving a stereo signal.
Logged

cncb

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 2966

Are you using WASAPI output instead of Direct Sound?
Logged
-Craig    MO 4Media remote and player:  Android/TV/Auto | iOS | Windows 10/UWP

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 509

Are you using WASAPI output instead of Direct Sound?

In both bitstreaming cases I was using Direct Sound.
Logged

terrym@tassie

  • MC Beta Team
  • Galactic Citizen
  • *****
  • Posts: 476

You may have more than one audio stream in your Makemkv ripped files, it not uncommon to have multiple audio streams.
To check, play the mkv and right click on the display then look at 'Streams', if a multi channel stream is available then switch to it, MC will remember this choice for future playback.
In mkv files multiple audio streams always have one set as 'default' and this the one that MC will playback as first choice.
Logged
" I like work: it fascinates me. I can sit and look at it for hours." -Jerome K. Jerome

cncb

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 2966

In both bitstreaming cases I was using Direct Sound.

I think you need to use WASAPI.
Logged
-Craig    MO 4Media remote and player:  Android/TV/Auto | iOS | Windows 10/UWP

haggis999

  • Citizen of the Universe
  • *****
  • Posts: 509

I think you need to use WASAPI.

Last night, I checked my phone at around 4:30am here in the UK (in common with other men of my age, a trip to the bathroom in the middle of the night is a regular occurrence!) and saw this post. I was keen to try out your WASAPI recommendation, so went downstairs immediately to check it out and was delighted to find that my AV amp was now confirming the input of a multichannel PCM input  :)

I was not so delighted to find that I could not recreate that experience this morning. Obviously, I must have changed something, but so far have failed to find out what that might be. Grrrrr  :(

EDIT:  Having now woken up my brain with a cup of espresso, I fixed the problem by selecting the DENON-AVRHD (NVIDIA High Definition Audio) [WASAPI] audio setting instead of Default Audio Device [WASAPI]. My recollection of what worked at 4:30am this morning was that the Default Audio Device [WASAPI] setting was the only WASAPI setting that worked, but I must have been mistaken.

Logged
Pages: [1]   Go Up