INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2   Go Down

Author Topic: Library Server 1.0.21  (Read 23240 times)

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Library Server 1.0.21
« on: March 14, 2005, 01:13:16 pm »

Media Center 11 uses a new server that replaces Media Server in Media Center 10.  You can use it to share the library of one PC to another PC, even across the Internet.

At this time, this is how it works.

In MC, under the tree, under plug-ins, you'll find the Library Manager plug-in.  Set the options here and "enable" it on the server machine.

You can also convert lossless formats to MP3 or WMA or other lossy formats that can be streamed over lower bandwidth collections (home to work, for example).  This is controlled in MC's Tools/Options/Library section of the client machine.

There is now a Media Server mode of Media Center. This runs a reduced size Media Center containing the servlets (Library Server, TiVo Server, and UPnP Server).

Remember that both the client PC and the server must be running the same build.

This version fixes the problems with authentication. It is available at http://www.jriver.com/~gateley/server_library1021.mjp

Some issues are still open:
CUE tracks not working
VOB files not working
APL files not working
Some minor issues with the slider

Previous thread on Library Server is here:

http://yabb.jriver.com/interact/index.php?topic=24158.0

JohnS

  • Regular Member
  • Recent member
  • *
  • Posts: 31
Re: Library Server 1.0.21
« Reply #1 on: March 15, 2005, 08:43:58 am »

Authentication still not working for me.

http://yabb.jriver.com/interact/index.php?topic=26503.0
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #2 on: March 15, 2005, 10:07:50 am »

Hi John,

The bug you mentioned looks exactly like the one I fixed. Double-check the versions of library server on both sides - should be 1.0.21.

j

bbrip

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 441
  • Change this by choosing profile
Re: Library Server 1.0.21
« Reply #3 on: March 15, 2005, 04:48:25 pm »

I get message "Failed to install package" when I try to install this new version.

Any advise?

Thanks
Logged

zxsix

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1753
Re: Library Server 1.0.21
« Reply #4 on: March 15, 2005, 04:51:43 pm »

FWIW, installed fine on Win2k server.
Logged

alexgit

  • Regular Member
  • Junior Woodchuck
  • **
  • Posts: 99
  • Change this by choosing profile
Re: Library Server 1.0.21
« Reply #5 on: March 16, 2005, 01:00:09 am »

Unicode in internatinal characters still does not work.
Also server media center crashed (with silent exit) when I tried.
Logged

JohnS

  • Regular Member
  • Recent member
  • *
  • Posts: 31
Re: Library Server 1.0.21
« Reply #6 on: March 16, 2005, 11:45:25 am »

Hi John,

The bug you mentioned looks exactly like the one I fixed. Double-check the versions of library server on both sides - should be 1.0.21.


They're both 1.0.21 in the Plugin screen..

I've done a total reinstall of MC11 on the server PC.

Here's what's happening:
1. Enable Authentication on server
2. Connect from client
3. Get password prompt on client
4. After entering user name and password, get this response from server:

Failed to connect to a server.
Reason: Unknown error.
URL:http://192.168.117.28:8080/GetLibrary

5. If I try to connect to the server again, I then get (after the password dialog):

Failed to connect to a server.
Reason: The handle is in the wrong state for the requested opertaion.
URL:http://192.168.117.28:8080/GetLibrary

I continue to get the above error message until I restart the server's MC11,  and then the process 1 - 5 process outlined above "repeats".

This occurs when I try 2 PC's on the same LAN as well as with my home-to-work VPN connection.


Here is the System Info from the server:
Media Center Registered 11.0.214 -- C:\Program Files\J River\Media Center 11\

Microsoft Windows XP 5.1 Service Pack 2 (Build 2600)
AMD Athlon 1210 MHz MMX / Memory: Total - 1048 MB, Free - 586 MB

Internet Explorer: 6.0.2900.2180 / ComCtl32.dll: 5.82 (xpsp_sp2_rtm.040803-2158) / Shlwapi.dll: 6.00.2900.2180 (xpsp_sp2_rtm.040803-2158) / Shell32.dll: 6.00.2900.2180 (xpsp_sp2_rtm.040803-2158) / wnaspi32.dll: 4.57 (1008) , ASPI for Win32 (95/NT) DLL, Copyright 1989-1997 Adaptec, Inc. / Aspi32.sys: 4.57 (1008)

Ripping /   Drive E:   Mode:Normal  Type:Auto  Speed:Max
  Drive G:   Mode:Normal  Type:Auto  Speed:Max
  Digital playback: Yes /  Use YADB: Yes /  Get cover art: No /  Calc replay gain: Yes /  Copy volume: 32767
  Eject after ripping: Yes /  Play sound after ripping: No 

Burning /  Drive E: LITE-ON  DVDRW SOHW-832S    Addr: 0:0:0  Speed:40  MaxSpeed:40  BurnProof:Yes
  Test mode: No /  Eject after writing: Yes /  Direct decoding: Yes /  Write CD-Text: Yes
  Use playback settings: No /  Normalization: None


Here is the system info from the work client:
Media Center Registered 11.0.214 -- C:\Program Files\J River\Media Center 11\

Microsoft Windows XP 5.1 Service Pack 2 (Build 2600)
Intel Pentium III 929 MHz MMX / Memory: Total - 523 MB, Free - 68 MB

Internet Explorer: 6.0.2900.2180 / ComCtl32.dll: 5.82 (xpsp_sp2_rtm.040803-2158) / Shlwapi.dll: 6.00.2900.2573 (xpsp_sp2_gdr.041130-1729) / Shell32.dll: 6.00.2900.2578 (xpsp_sp2_gdr.041130-1729) / wnaspi32.dll: N/A
Ripping /   Drive E: LITEON  CD-ROM LTN526S    Mode:Normal  Type:Auto  Speed:Max
  Digital playback: Yes /  Use YADB: Yes /  Get cover art: No /  Calc replay gain: Yes /  Copy volume: 32767
  Eject after ripping: Yes /  Play sound after ripping: No 

Burning /  No burners found.
  Test mode: No /  Eject after writing: Yes /  Direct decoding: Yes /  Write CD-Text: Yes
  Use playback settings: No /  Normalization: None

Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #7 on: March 16, 2005, 12:23:19 pm »

What's the Server Log say? Is it seeing the connection attempts at all?

j

JohnS

  • Regular Member
  • Recent member
  • *
  • Posts: 31
Re: Library Server 1.0.21
« Reply #8 on: March 16, 2005, 02:30:35 pm »

No messages in the Server Log other than:
Starting..
Running on Port 8080..

A "thing" I didn't notice before, when I attempt to connect for the first time I am prompted for my User Name and Password twice.

I enter it the first time and then dialog pop's up again.. then I get  the Unknow error dialog from MC11.

Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #9 on: March 16, 2005, 02:31:56 pm »

Are you using a proxy server? Do you have password authentication enabled on the proxy server?

j

JohnS

  • Regular Member
  • Recent member
  • *
  • Posts: 31
Re: Library Server 1.0.21
« Reply #10 on: March 16, 2005, 02:37:58 pm »

No.. I have a "straight-thru" VPN..

Also, after I get the error on the server MC11, I shut it down and I noticed now that I'm seeing the following dialog:
"Media Core has encountered a problem and needs to close. We are sorry for the inconvenience."

I get this dialog 4 time in a row after exiting MC11 after "testing" the User Authentication..

I just tried changing the port from 8080 to 81 (just for grins..)  no difference.
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #11 on: March 16, 2005, 03:26:32 pm »

I've added some debugging info to the log, we'll see if that shows anything. Try it at home with both machines on the LAN, to take the VPN out of the picture.

Get the next build, coming out soon...

j

JohnS

  • Regular Member
  • Recent member
  • *
  • Posts: 31
Re: Library Server 1.0.21
« Reply #12 on: March 17, 2005, 09:35:16 am »

Not sure if you're gonna like this, but just installed 216 (on both server and client) and "it just works" now.

I see the additional logging info in the Server Log window and I only get one "Login" dialog box on the client..  .. and this _is_ over the VPN link (I'm at work now).

So, either you changed something knowingly ("A good thing(tm)") or you didn't.. ("A bad thing(tm)").. :)
Logged

JohnS

  • Regular Member
  • Recent member
  • *
  • Posts: 31
Re: Library Server 1.0.21
« Reply #13 on: March 17, 2005, 09:40:34 am »

I see the additional logging info in the Server Log window and I only get one "Login" dialog box on the client..  .. and this _is_ over the VPN link (I'm at work now).


Followup: I forgot to mention that I do see two "Informing client they must authenticate" lines in the Server Log..

The exact sequence of events is:
1. Start MC11 on server
2. Start MC11 on client
3. Load "remote" library, Server Log shows "Informing client they must authenticate"
4. Login dialog pops up on client. Enter username and password, click OK.
5. Server Log shows another "Informing client they must authenticate" and then shows "Received request for library".  I _did not_ get a second login dialog on the client.

HTH.
Logged

zxsix

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1753
OT: which VPN???
« Reply #14 on: March 17, 2005, 09:49:24 am »

Can you give me some info on what VPN you are using?  I assume the VPN server is on your home server.  Just wondering what you are using.
Logged

JohnS

  • Regular Member
  • Recent member
  • *
  • Posts: 31
Re: OT: which VPN???
« Reply #15 on: March 17, 2005, 12:30:17 pm »

Can you give me some info on what VPN you are using?  I assume the VPN server is on your home server.  Just wondering what you are using.

Ok, you asked for it.. ;)

I'm runing 2 Gentoo linux firewalls connected by an OpenVPN tunnel. Each firewall is using Shorewall to provide Network Address Translation to allow me to "tunnel" thru the company firewall to my home machine. I've got my Windows box at work configured with special routes to do the following:
MC11 on Work PC -> My Work Firewall/NAT -> Company Firewall -> Internent -> Home Firewall -> MC11 on Home Windows PC.

Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #16 on: March 17, 2005, 01:10:51 pm »

So, either you changed something knowingly ("A good thing(tm)") or you didn't.. ("A bad thing(tm)").. :)

Nope - no changes other than the logging. Strange. I'm guessing that somehow the install failed with the other one, because the error message looks exactly like the bug that I fixed.

Let me know if it reappears...

j

Qythyx

  • Galactic Citizen
  • ****
  • Posts: 390
Re: Library Server 1.0.21
« Reply #17 on: March 17, 2005, 10:42:04 pm »

Library Server is working great for me. I do have a few comment:

1. Are there any ways to tune the buffering? If I know I have a bursty net connection I'd like to increase the buffer size.

2. When I was first trying to get it working I loaded my remote library and created a smart playlist. This was fine. I then reloaded the remote library to get updates to some changes made to the source media and the playlist I'd created was gone so I had to create it again.

3. Is there an easy way to update the remote library? For example, if I rip more media at home and add it to my library, how can I make my client aware of this?

4. Someone mentioned earlier it would be nice to be able to re-encode the media on demand at a given bitrate. I know this would burn the CPU cycles, but it'd be a very nice feature.

5. Is there a Pocket PC version of the client? If not, is the protocol for this published so someone could create one?


Thanks,

--Qythyx
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #18 on: March 17, 2005, 10:47:35 pm »

Hi Qythyx,

1 - yes, check under playback options.

2,3 - only changes made on the server will be permanent. This is often asked for, and we are getting closer, but it's not easy.

4 - yes, check the library options ON THE CLIENT.

5 - no, sorry.

Thanks,

j

Qythyx

  • Galactic Citizen
  • ****
  • Posts: 390
Re: Library Server 1.0.21
« Reply #19 on: March 17, 2005, 11:08:14 pm »

Wow, quick reply, thanks.

Very nice that you already support most of the things I mentioned. MC really rocks.

On #4, will it re-encode media to a higher bitrate? For example, if the source is at 64kbps, but I have it set to 128kbps, will it re-encode? If it will, it'd be nice to have an option to tell it not to. Also, it'd be nice to have an option to stream the media at the highest quility possible according to the network conditions. I realize that's a lot easier to say than to implement.

On #5, was that "no" to both parts of the question? Is there any chance of writing a Pocket PC client that can be a stream client?


Thanks,

--Qythyx
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #20 on: March 17, 2005, 11:18:45 pm »

4 revised: this is under development. At the moment, I think it does re-encode, though it probably shouldn't. We're working on this.

5 revised: The Library Server protocol is proprietary, and not amenable to pocket PC's (the entire DB is downloaded as the first step).

However, you might be able to find code to make the pocket PC a UPnP player, then it might work with UPnP server.

Sorry, no more quick responses until tomorrow :)

j

Qythyx

  • Galactic Citizen
  • ****
  • Posts: 390
Re: Library Server 1.0.21
« Reply #21 on: March 17, 2005, 11:58:09 pm »

Thanks again...

Ok, I understand about the Pocket PC stuff. I can't seem to find any existing UPNP software for Pocket PS except for a new application in beta by Nero. There's no trial version currently, so I can't test it, but I'll keep my eyes only.

Thanks,

--Qythyx
Logged

Catul

  • Regular Member
  • Recent member
  • *
  • Posts: 25
  • Change this by choosing profile
Re: Library Server 1.0.21
« Reply #22 on: March 18, 2005, 09:41:28 am »

The Library Server protocol is proprietary, and not amenable to pocket PC's (the entire DB is downloaded as the first step).

Given that many Pocket PC's are now either WiFi or EV-DO capable, which gives them pretty darn good internet capabilities, downloading the entire DB as the first step might not be such a bad option.  Please, do consider allowing a PPC access to the Library Server - in any way possible.

I currently use MC11 as a client on my office PC to listen to my music which is served up by MC11 at home; would be awesome to be able to do the same (even in a very limited fashion) from my PPC device as well.

It's a growing market that would really set MC apart from other software!!!
Logged

glennvander

  • Regular Member
  • Member
  • *
  • Posts: 2
  • Change this by choosing profile
Re: Library Server 1.0.21
« Reply #23 on: March 18, 2005, 10:00:30 am »

I am still trying to get used to this new Library Server. Thanks for adding the seperate executable to start media server, but do you have a way yet to start this service on Windows Start up like MC10 has. I could not find any way to get that to work. I even tried creating a service for the new executable with FireDeamon but it would not start properly.

Any advice?
Logged

Qythyx

  • Galactic Citizen
  • ****
  • Posts: 390
Re: Library Server 1.0.21
« Reply #24 on: March 22, 2005, 12:18:01 am »

I'd like to report/confirm that some non-ASCII characters prevent a song from being played. I have a few Japanese CDs and they are displayed fine, but won't play across the Library Server. Note that they do play fine locally, just not via the library.

Also, I'd like to request a feature to handle multiple-users. For example, I'd like to be able to make it such that a certain client-user can not edit the library. Ideally that user could still make their own playlists, and maybe even have their own unique ratings, play count, etc.

Thanks,

--Qythyx
Logged

drosoph

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 661
  • TiVo-aholic
Re: Library Server 1.0.21
« Reply #25 on: March 24, 2005, 09:47:43 pm »

There is now a Media Server mode of Media Center. This runs a reduced size Media Center containing the servlets (Library Server, TiVo Server, and UPnP Server).
How do I get to Media Server mode ... I can't seem to find this ...

drosoph

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 661
  • TiVo-aholic
Re: Library Server 1.0.21
« Reply #26 on: March 24, 2005, 09:55:54 pm »

I'm pleading with ya on this one!

I have a library of just under 100K files.  Its a handy little MP3 server ... I promote the use of MC & TiVo to my fellow friends :)

But, my library is about 28MEGS to download when someone wants to play a song. 

Now, if you put in an options tab into the Library Server to push CERTAIN fields (like removing my BIOS, LYRICS, MD5 hashes, and other huge files) I could GREATY reduce the library size :)

PLEASE !?!?

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Library Server 1.0.21
« Reply #27 on: March 29, 2005, 09:43:54 am »

From the "We'd like to release MC11....so.... bad bugs?" thread:
I have 2 problems with build 225

first problem: library server won't start:
03/29/05 16:06:07 - Starting...
03/29/05 16:06:07 - Starting Auto Detect beacon
03/29/05 16:06:07 - Failed to start sharing
(no further information)
then when stopping server again, MC chrashes.
Also, no way of choosing what library to share (maby removed?) in options.
...
Win2k server, files on a network drive

An interesting finding. I haven't realised before that that the option for selecting the library is missing. It seems to me that Library Server can share only a library named "Default".

As a test I renamed my "Default" library to "XYZ" and restarted MC. After that Library Server started normally but the client was not able to connect. Then I renamed another library named "Test" to "Default". After that Library Server shared that small test library.

Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

zxsix

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1753
Re: Library Server 1.0.21
« Reply #28 on: March 29, 2005, 10:06:54 am »

On the server machine, you go to the plugins under the tree.  In there you specify which port the server will listen on and which of your libraries you want to use as the shared one for the clients.
Logged

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Library Server 1.0.21
« Reply #29 on: March 29, 2005, 10:12:05 am »

On the server machine, you go to the plugins under the tree.  In there you specify which port the server will listen on
Yes, I know.

Quote
and which of your libraries you want to use as the shared one for the clients.
No, there's no way to do it.

What version do you have?
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #30 on: March 29, 2005, 10:15:20 am »

Library server shares the library currently used in Media Center. There is no way to use 1 library in Media Center and a different library for LIbrary Server anymore.

j

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Library Server 1.0.21
« Reply #31 on: March 29, 2005, 10:17:03 am »

Library server shares the library currently used in Media Center.

No it doesn't. It shares a library named "Default". Did you read my post?
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Library Server 1.0.21
« Reply #32 on: March 29, 2005, 10:23:46 am »

If there is no library named "Default" this happens:

Quote
03/29/05 19:21:02 - Starting...
03/29/05 19:21:02 - Starting Auto Detect beacon
03/29/05 19:21:02 - Running on Port 4798
03/29/05 19:21:09 - Received request for library
03/29/05 19:21:09 - Failed to open library


If I first activate the "Test" library and start the server after that it still shares the "Default" library. It's quite possible to share one library and use another library.
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

Robert Taylor

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 646
  • Living in a Smokeless Zone...
Re: Library Server 1.0.21
« Reply #33 on: March 29, 2005, 10:29:39 am »

Qythyx,

I have sent you a personal message about the PocketPC / uPNP stuff you may find interesting...
Logged
Cheers
Rob

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Library Server 1.0.21
« Reply #34 on: March 29, 2005, 10:54:01 am »

In my opinion two important options are missing:

1. An option for selecting the shared library.

2. An option for selecting the default startup library. I have suggested it earlier:

Assign the server address in Library Manager to a new library. MC will start with it if it was used the last time.

Actually, I would like to see that optional. Quite often I forget to change back to the local library before closing MC. I don't always have the server running. It would be good to have an option for the default startup library.

Mr. Gateley's answer was this:

Nice idea Alex.

j


Please.
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Library Server 1.0.21
« Reply #35 on: April 01, 2005, 08:24:10 am »

It is better now. MC11.0.228 shares the current library. If the user on the server needs to use another library locally the active library can be changed after the client has connected.

The converter options are still a bit strange. It allows selecting also unsupported formats like Monkey's Audio. Windows Media Lossless shows up on the client as 128 kbps. There are some other things too.

I would like to know exactly how the converter options are intended to work. Otherwise it will be difficult to report about the possible bugs.

That information will be soon needed for the documentation anyway, so now would be a good time to write it down.
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #36 on: April 01, 2005, 10:41:35 am »

Changing the library after sharing should not be done. You will lose your playcount updates if you do.

Don't know why WMA lossless is showing up weird, I'll look at it.

Why is APE an unsupported format?

The client tells the server "give me this file in this format", and the server converts it if needed.

j

Alex B

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 10121
  • The Cosmic Bird
Re: Library Server 1.0.21
« Reply #37 on: April 01, 2005, 12:30:04 pm »

Changing the library after sharing should not be done. You will lose your playcount updates if you do.
I see. So the clients can change something in the shared library. Does the playcount in the server's local library increase every time when a client plays a track? I suppose the counting must happen on the server side. Otherwise it could go wrong and erratically change that information if the network connection is bad.

Quote
Don't know why WMA lossless is showing up weird, I'll look at it.
It also allows uncompressed wave. When playing tracks with that option the client display shows something like this: "Cannot play visualizations of this type... etc" However, it still shows the track image besides that text. That option is also too slow on my 100 MB LAN. Track changes take tens of seconds. I guess it converts the whole track before sending it.

Quote
Why is APE an unsupported format?
I thought so because the client was unable to play anything when the option was selected.

Quote
The client tells the server "give me this file in this format", and the server converts it if needed.
I would like to know more about that too. Are there any rules currently? Does it convert inside the same format? There used to be an option for that.

It seems to me that it converts everything to the selected format, but if it does not, the users will probably ask this kind of questions:

- Most of my MP3s are near 320 kbps. If it transcodes inside the same format and I select 128 kbps MP3 does it upconvert an occasional low quality 96 kbps MP3? The resulting quality for that file would be less than the original 96 kbps.
- What happens if I select WMA 128 kbps instead?
- What happens if a playlist consists of several file formats and very different bitrates?

It would be easier to check that everything works as intended without unnecessary questions if the information was provided. A demo version of the Help File instructions would be nice. I suppose the changes are about done for the version 11 and now it's time to get rid of the last bugs.

Thanks.
Logged
The Cosmic Bird - a triple merger of galaxies: http://eso.org/public/news/eso0755

lalittle

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3964
Re: Library Server 1.0.21
« Reply #38 on: April 22, 2005, 10:58:36 pm »

There is now a Media Server mode of Media Center. This runs a reduced size Media Center containing the servlets (Library Server, TiVo Server, and UPnP Server).

If you have a system that you sometimes use Media Center on, but you want to always be able to access this system's MC library from another system, how should you set it up?  Is it best to always keep the "full" Media Center running on the main system, or should you make it so only the "Media Server mode" is running when you aren't using MC?  If you're running "Media Server mode," can you toggle toggle to "normal" mode?

Also -- how do you make it so the system boots up ready to share it's MC library with another system?  Do you just add MC to the Windows "startup" folder?

Thanks,

Larry
Logged

Branxx

  • Regular Member
  • Recent member
  • *
  • Posts: 47
Re: Library Server 1.0.21
« Reply #39 on: May 06, 2005, 01:50:04 pm »

Should the format conversion when using library server be a property of particular library rather than a general setting for every library server as is now.

I have set-up two library servers: one on local network where I don;t need any format conversion, and another on a remote server where conversion for a lower bitrate is neccesary.

At present, if I select conversion for a lower bitrate it affect both libraries and lowers the quality of the music coming from the local network.
Logged

John Gateley

  • Citizen of the Universe
  • *****
  • Posts: 4957
  • Nice haircut
Re: Library Server 1.0.21
« Reply #40 on: May 09, 2005, 04:43:08 pm »

Interesting. I changed this recently so that the options were on the client instead of the server, but it looks like more is needed.

One server can handle many clients, so putting the conversion choice on the client lets each client choose what they need.

But I hadn't thought about 1 client accessing multiple servers.

I'll think about this...

j

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71750
  • Where did I put my teeth?
Re: Library Server 1.0.21
« Reply #41 on: May 09, 2005, 05:48:02 pm »

Is it best to always keep the "full" Media Center running on the main system, or should you make it so only the "Media Server mode" is running when you aren't using MC?  If you're running "Media Server mode," can you toggle toggle to "normal" mode?

Also -- how do you make it so the system boots up ready to share it's MC library with another system?  Do you just add MC to the Windows "startup" folder?
Just configure your servers in MC, then run Media Server.  You can then exit MC.

Adding MC to the startup folder would probably do what you want.
Logged

drosoph

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 661
  • TiVo-aholic
Re: Library Server 1.0.21
« Reply #42 on: May 09, 2005, 08:27:08 pm »

OK, it comes down to this ... I would LOVE to share my library of over 125,000 songs (all organized, cataloged, tagged, and sorted thanks to the folks at MC & King's plugins), but I cannot easily share my library because it takes FOREVER for someone to download the library from my PC!  The library ends up being >30MB because I cannot limit any of the fields, or data, being sent.   And, the distant end cannot cache the library .. therefore, a crash, a reboot, or even just a close/start causes a redownload of the entire library!!!

What, if any, is the solution?

jriver.drosoph.com:9997 for a 30 Meg library if you get bored ;)

lalittle

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3964
Re: Library Server 1.0.21
« Reply #43 on: May 10, 2005, 03:20:59 am »

Just configure your servers in MC, then run Media Server.  You can then exit MC.

Adding MC to the startup folder would probably do what you want.

Wait -- I thought that there WAS no Media Server any more.  The situation you just described is confusing me.  You first say that I should run Media Server and exit MC, but then you say to that to get the functionality I want, I should add MC to the startup folder.  The first part implies that I don't need MC running, while the second part implies that I DO run MC to have the functionality I desire.  Could you please explain in more detail so I can get a handle on how this works?

Does the "Server" part of MC11 run seperately from MC or not?  I fully understand the MC10 workflow for sharing songs on another system, but I'm quite confused about how MC11 works if I want to do the same thing.  At the moment (with MC10) I have Media Server set up to start when the system starts.  I can open and close MC on the server without effecting the Media Server, and I can access the songs on the server from the client at any time as long as the server has been booted up.  How do I get this functionality with MC11 -- i.e. so I can simply boot up the server, and the client will automatically have access to the server's MC11 library?


Thanks for any clarificaiton on this,

Larry
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71750
  • Where did I put my teeth?
Re: Library Server 1.0.21
« Reply #44 on: May 10, 2005, 06:50:24 am »

When you run Media Server now, it runs part of MC in a minimal mode that takes very little memory.  There is no Media Server program.

We realize that this is not ideal, and we'd like to change it in a future version, but the current method allows the server to update playcounts on th fly and it allows us to run multiple types of servers cleanly.
Logged

Branxx

  • Regular Member
  • Recent member
  • *
  • Posts: 47
Re: Library Server 1.0.21
« Reply #45 on: May 10, 2005, 02:03:41 pm »

For those who want Media Server v11 to run as Windows NT Service, this can be done. I include the registery entries for creating the service. It uses Microsoft Utility srvany.exe as a wrapper to run Media Server. Save the file in %SystemRoot%\System32.

Quote

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\J River Media Server 11]
"Type"=dword:00000010
"Start"=dword:00000002
"ErrorControl"=dword:00000001
"ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
  74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
  00,72,00,76,00,61,00,6e,00,79,00,2e,00,65,00,78,00,65,00,00,00
"DisplayName"="J River Media Server 11"
"ObjectName"=".\\Administrator"
"Description"="This starts J River Media Server on system's boot and allows remote clients to connect to the media library."

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\J River Media Server 11\Enum]
"0"="Root\\LEGACY_J_RIVER_MEDIA_SERVER\\0000"
"Count"=dword:00000001
"NextInstance"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\J River Media Server 11\Parameters]
"Application"="C:\\WINDOWS\\system32\\mjextman.exe /MediaServer"


The ImagePath reads "%SystemRoot%\System32\srvany.exe".

Copy and paste the quoted registery entries into a separate text file with the .reg extensionand, then run it. The entries will be added to the registry and after reboot the "J River Media Server 11" would appear in the list of local services.

Note that the account and the username for this service should be the same as the one used to configure MC11 library.

Make sure the service is stopped any time an upgrade is applied.
Logged

Branxx

  • Regular Member
  • Recent member
  • *
  • Posts: 47
Re: Library Server 1.0.21
« Reply #46 on: May 14, 2005, 01:19:13 pm »

Update: recent version of MC11 build 266 have moved the location of mjextman.exe file, so the last line in the registery entries should read:
Quote

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\J River Media Server 11\Parameters]
"Application"="C:\Program Files\J River\Media Center 11\mjextman.exe /MediaServer"
Logged

daltonrooney

  • Regular Member
  • Recent member
  • *
  • Posts: 6
  • I gots to do it AGAIN!
Re: Library Server 1.0.21
« Reply #47 on: June 04, 2005, 09:45:37 am »


Copy and paste the quoted registery entries into a separate text file with the .reg extensionand, then run it. The entries will be added to the registry and after reboot the "J River Media Server 11" would appear in the list of local services.


My reg file kept causing errors until l I realized I had to paste in

"Windows Registry Editor Version 5.00"

at the top of the text file for regedit to recognize it.  (at least in XP...)

Thanks very much for this information - really helpful!

Dalton

lalittle

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3964
Re: Library Server 1.0.21
« Reply #48 on: June 04, 2005, 05:24:34 pm »

Just configure your servers in MC, then run Media Server.  You can then exit MC.

Adding MC to the startup folder would probably do what you want.

Sorry for the continued confustion, but I thought that you needed MC to be running for the server to work, which was the point of having MC in the startup folder.  You said "You can then exit MC," so I'm confused again.  Assuming that "exiting" the program is the same as "closing" the program, won't shutting down MC stop the server as well, or is MC set up to let the server program keep running after MC itself is closed.

Thanks for clarification,

Larry
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71750
  • Where did I put my teeth?
Re: Library Server 1.0.21
« Reply #49 on: June 04, 2005, 05:56:30 pm »

Set up Library Server the way you want it.   It's under "plug-ins" in the tree.

Start it.

Close MC.  The server will still be running and it's called "Media Server" at that point.  It's just a small sub-set of MC.

Logged
Pages: [1] 2   Go Up