INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: "Do not play silence" does not work well with "gapped"  (Read 8206 times)

Tolga

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 438
"Do not play silence" does not work well with "gapped"
« on: October 06, 2010, 02:39:17 pm »

Problem:
I really want to use "Do not play silence" option while tango DJing to achieve a standard gap between songs, but I can't use this setting as it is now. A simple improvement could fix my problem and improve general sound handling of MC in this setting.

Example:
When I turn both options on, "do not play silence" and "2 secs gapped", I usually get a small abrubt click or a sudden cut-off at the end of the song when MC moves suddenly from the song to the gap. This often cuts off part of the last note or the background noise at the end of the song causes a click.

Solution Proposal:
I think instead of abrubt switch to a gap, MC should fade out the  volume one it reaches the cut-off point. The fade out could continue for the duration of the specified gap (or say half of the gap duration). This would create a smoother ending after cut-off point while maintaining a standard gap.

Geekout:
Note that, theoretically, they may be a similar issue for the cutoffs at the beginning of the songs, but that is not hearable in practice.
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41788
  • Shoes gone again!
Re: "Do not play silence" does not work well with "gapped"
« Reply #1 on: October 08, 2010, 04:40:06 pm »

If a track has a sudden cut-off, gapped fade will honor the sudden cut-off.

v15 added a new mode "Gapped Fade" that does a fade out before the gap.  But on a natural track boundary, "Gapped Fade" is gapless.  The gap is only used when manually switching tracks.

I think you're requesting another switch track modes that's similar to Gapped Fade, but always adds the gap.

I'm worried about switch track modes overload, so I'm not sure on this one.  Any second or third opinions?
Logged
Matt Ashland, JRiver Media Center

darrenjweiss

  • Recent member
  • *
  • Posts: 13
Re: "Do not play silence" does not work well with "gapped"
« Reply #2 on: October 08, 2010, 06:21:35 pm »

I'd like to see this as well...I use MC to run my radio show, and I'd love to have the gap always.
Logged

leezer3

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1563
Re: "Do not play silence" does not work well with "gapped"
« Reply #3 on: October 08, 2010, 08:05:04 pm »

First rule of the programmer-
No such thing as feature overload, just not enough options   ;)

Seriously though, I'd agree that this would be a worthwhile addition.

-Leezer-
Logged

Tolga

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 438
Re: "Do not play silence" does not work well with "gapped"
« Reply #4 on: October 09, 2010, 05:05:37 pm »

Matt,

my proposal is indeed  different than gapped with fading. I agree that gapped fading solves similar issues when fading of songs is ok, but fading is not ok for many circumstances.

I think my proposal is better than the current state of "play no silent" + "gapped", under any condition. Best case, the end of song silence MC cuts, let's call it file silence, is very close to real silence, so there is no change in behavior if MC transitions from end of file silence to real silence. However, if there is something MC is cutting off incorrect, my proposal, fading from "end of file silence" to real silence, would improve the result. For example this happens in songs that already have a fade in them at the end. Also, if there is a little bit low background noise, MC is cutting, there will be a transition from "file silence" to real silence, pretty much not hearable but it would eliminate sudden pops going from "file silence" to real silence abruptly. I don't see any circumstances where this behavior is not prefered for "play not silence" + "gapped" setting, so I will use it without a new switch as default.

Note that my proposal is something  that should be active only when "play no silent" + "gapped" are active at the same time.
Logged

ndias

  • Member
  • *
  • Posts: 2
Re: "Do not play silence" does not work well with "gapped"
« Reply #5 on: November 03, 2011, 09:31:38 pm »

Chiming in:

I'm in the same boat as the original poster, although I am using JRMC14 for DJing swing music. For my purposes, I would like to have a fixed gap of silence (3-5 seconds long) between each track playing in a playlist, but if either tracks include recorded silence at the beginning or end, I don't want that to add to the fixed gap. As such, I've used the "do not play silence" option as well as the "gapped - 3s" options, but lately:

I've been noticing the abrupt ending/transitions that the original poster mentioned. It seems that the algorithm that detects and cuts of the silence is a little to aggressive, and cuts off a few seconds of track suddenly. When amplified over a loudspeaker, it's very noticeable and interrupts the flow when I'm DJing.

I downloaded the trial version of JRMC16 to see if there were any "fixes" for this, but behavior seems the same.

I know there may not be that many people clamoring for this, but I would love to see an option that has a less aggressive cutoff, or that fades out to the gapped silence as the original poster suggested.

AND will happily pay the upgrade cost if the feature makes it in....have otherwise been happily using JRMC14 for years.

Or, is there a way to add a plug-in? or write one myself?


Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41788
  • Shoes gone again!
Re: "Do not play silence" does not work well with "gapped"
« Reply #6 on: November 07, 2011, 03:48:04 pm »

Could you provide a sample file where you think the silence trimming is too aggressive?  I'm matt at jriver dot com.

Thanks.
Logged
Matt Ashland, JRiver Media Center

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41788
  • Shoes gone again!
Re: "Do not play silence" does not work well with "gapped"
« Reply #7 on: November 29, 2011, 08:47:00 am »

Tolga sent me a sample.  It's a quiet classical track with a long fade at the end.

Trimming of silence trims a little bit of the fade at the end.  This is because silence trimming must handle the fact that there will never be true silence in a track due to the noise floor.

The silence trimming option was originally added to make cross-fades better.  Without it, you can get fades between basically silent portions of each track.

If you're using a gap between tracks, I would think you could just disable silence trimming.  Does that work?
Logged
Matt Ashland, JRiver Media Center

Tolga

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 438
Re: "Do not play silence" does not work well with "gapped"
« Reply #8 on: November 29, 2011, 02:04:45 pm »

Disabling silence trimming works, but I want to get standard gaps between songs. My original proposal would get that effect, as soon as the low volume cutoff is reach, instead of stopping the original song, I would mix it with silence+new song.

So I would mix the following two streams, starting at t1, which is the low voice point MC selects, in this case, incorrectly a little early.

----------- First Song --------|t1|--low volume fade out part ---|--------actual silence & background noice ------|
                                        |t1| ----- user selected fixed gap (e.g. 4 sec) -----|------------Second Song ------------------|

When MC finds the right cutoff point, we get exactly 4 sec silent. If MC cuts of a little prematurely, than we get a little smaller gap, but either way the gaps are pretty standard across the board. This would help me a lot in Tango DJing where I want to have a fixed gap between two songs (without premature cut clearly).

Real story: I was dancing in Buenos Aires last week. The DJ cut off the last note of one of my favorite songs, I got really pissed off at him. The last not is like the most important one in tango :)
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41788
  • Shoes gone again!
Re: "Do not play silence" does not work well with "gapped"
« Reply #9 on: November 30, 2011, 10:11:10 am »

In a coming build of MC 17:
Changed: When using 'Do not play silence' in conjunction with gapped track switching, silence suppression first eats the gap before eating any of the track (so a long low volume fadeout won't end abruptly).
Logged
Matt Ashland, JRiver Media Center

Tolga

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 438
Re: "Do not play silence" does not work well with "gapped"
« Reply #10 on: November 30, 2011, 07:09:46 pm »

Great. I am looking forward to test that.
Logged

ndias

  • Member
  • *
  • Posts: 2
Re: "Do not play silence" does not work well with "gapped"
« Reply #11 on: December 08, 2011, 03:37:42 pm »

Wow...just checked back here on this issue and saw the comment that this feature adjustment might make it into MC17. Cool. Downloaded the latest MC17 trial version and tested it out on a track where I was experience this problem (Bobby Darin - Beyond the Sea).

With these settings:

x Switch Tracks: Standard (gapped) - 3s
x Do not play silence (leading & trailing)

MC14: there's a glitch on transition
MC17: No glitch (woo-hoo!)

Once I've verified this on a few more tracks I will be excitedly upgrading to the new version. Well worth it for the feature *as well as* the great response time and support...I wasn't expecting a fix so quickly. Thank you!

Nathan
Logged

Tolga

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 438
Re: "Do not play silence" does not work well with "gapped"
« Reply #12 on: December 08, 2011, 04:00:21 pm »

I agree. This is a fantastic improvement for me and reason for me to upgrade to MC17 to live events  once  it gets out of beta and I have enough experience to trust its stability.

I will share this thread on Tango-DJ's board too.
Logged
Pages: [1]   Go Up