INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: How can I change the path to my music library?  (Read 21251 times)

Dennis Graves

  • Junior Woodchuck
  • **
  • Posts: 56
How can I change the path to my music library?
« on: October 01, 2011, 07:38:55 pm »

When I try to play something, I will get an error message that the library path is not right.
The external drive that stores the music for J River on my music server computer was originally "D:".  It is now has to be "E:" (for reasons beyond the scope of this question). I changed the import paths to E:.  When I import the files, which have the proper path of E:\ Music for Server\...., I see an x at the left side of the list for each of the 100+ listings.  On these listings, the path (right most column) is correctly shown as E: ...
But under Tools, Options, File Location, Audio, the path keeps reverting to D:\ and I cannot get it to stay with E:\ or E:\ (D:). (The program sometimes shows E:\ (D:).) When I use the browse function in the window that sets the path, I click on "E:\ (D:), Music for Server" but that won't "stick" in the Audio path window.  If I manually enter E:\ it does not stick either.   
The location/root pane does show "E:".
 
HOW DO I GET THE "E:" TO STICK SO THE PATH WILL BE CORRECT AND I CAN PLAY SOMETHING?
Logged

Listener

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1084
Re: How can I change the path to my music library?
« Reply #1 on: October 02, 2011, 12:57:44 am »

I think I understand what you have done.  Your assumptions are reasonable but they don't correspond to the way MC works.  Some Questions and answers may provide a conceptual basis for understanding your problem.

Q1: How does MC know where to store files when you rip a CD?

The Tools/Options/File Location dialog specifies a base path and rules for folder and file names.

Q2: How does MC know where to search for files to import?

After you choose the Tools/Import command, the sequence of steps gives you a chance to specify a path to search for files to import.  this process works a bit differently for one time imports and background imports.

Q3: When you tell MC to play a file, how does  MC know where to find the file?

The library database contains a field named "Filename" that gives the location of each file.  This field is normally set when you rip a CD or import files.

---
Note that ripping CDs, importing files and playback or other actions on music files use different information about file location.

--- back to your problem
> When I try to play something, I will get an error message that the library path is not right.

A quick test:

1. Be sure that in the view you are using, the "Filename" field is displayed.  (Right-click on the column headings above the list of files and scroll down in the list of fields until you see "Filename".  If it is not checked, click on it.

2. Choose a file that is on the removable drive and try to play it.  If you get the same error message as before,

3. Scroll horizontally until you can see the "Filename" column in the file list for the file you just terieed to play.   Does the filename begin with D: or E:?

If the filename begins with D:, you probably still have database entries for the files you imported on drive D:.

The Disk Location view under audio is a handy way to see what where MC thinks files in the library are located.  Use this view to see whether the library has files on drive D: and/or e:.

You said that you imported the files from E:.  Did you delete the files with the D:... filenames before you imported them from Drive e:?  If not, you might delete those lines now.

When you delete files, MC will display a dialog asking if you want to remove the files from the library or to do want to delete them as well.  You want to choose the first option "Remove from media library".

Here is a Wiki entry about moving files:

http://wiki.jriver.com/index.php/Moving_Files

> But under Tools, Options, File Location, Audio, the path keeps reverting to D:\
> and I cannot get it to stay with E:\ or E:\ (D:). ...

I did not fully understand what you said.  Three settings specify where music files will be placed when you rip a CD. 

1) The first setting under "Audio" specifies a base path such as "E:\" or "e:\music".

2) The folder rule specifies the folder in which files will be placed relative to the base path.  Don't duplicate the base path in the folder rule.  The folder rule normally uses tag values to build the folder name.

3) The Filename rule specifies the way file names will be constructed using tag values.  Don't duplicate the base path or the folder rule in the filename rule.

Bill



Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71013
  • where the buffalo roam
Re: How can I change the path to my music library?
« Reply #2 on: October 02, 2011, 07:47:55 am »

Thanks, Bill.  Great job.
Logged

Dennis Graves

  • Junior Woodchuck
  • **
  • Posts: 56
Re: How can I change the path to my music library?
« Reply #3 on: October 02, 2011, 10:49:04 am »

Bill, thanks for your analysis.  Unfortunately, though, I don't see that it solves the problem. 
The main view with the column showing the file path indeed shows the path to be E:\music for server\....  As noted in my original posting, the essential problem is that tools, options, file location, dialog box won't allow the path to change from D:\ to E:\ Thus the base path is wrong and using the dialog box to browse to the correct path or manually enter the correct path does not change the base path.
The folder rule and filename rule sections of that dialog box are defaults and do not conform to how my files are named.  I ripped the files in dbPowerAmp and specified a filename that allowed sorting the files in Windows Explorer in a manner that is necessary for a classical music collection (composer, genre, piece, movement number).
In response to your other questions:
 1) I did delete the D: location files before changing the path in auto import and re-importing the files with the E:\ path
2)  I have not duplicated the base path or folder rule in the filename rule since I have specified no folder rule or filename rule at all.

What is puzzling is that I did at one point have this working right.  But, the next time I opened Media Center 15 I got the Xs at the left of the pieces and could not get this to work at all.  Haven't been able to play anything.

Talking with a fellow who is well known in Bay Area audio circles (runs a major audio store) and is a techie, he theorizes that my basic problem may be that I ripped in dbPowerAmp and have been using JRiver to play.  At this point, I have about 130 pieces, and would like to start over.  But, I need to at least be able to save the several hundred dollars worth of downloaded files and be able to use them with whatever player I set up.  I am thinking of trying the Sonata system, which Sonata says uses your JRiver basic system but greatly simplifies it and allows organizing for classical listeners. 
Any further suggestions?
Thanks.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71013
  • where the buffalo roam
Re: How can I change the path to my music library?
« Reply #4 on: October 02, 2011, 11:33:06 am »

DBPoweramp is fine.  No conflict there.

This article on our wiki will give you some tools to use.
http://wiki.jriver.com/index.php/Moving_Files
Logged

Listener

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1084
Re: How can I change the path to my music library?
« Reply #5 on: October 02, 2011, 12:03:17 pm »

Jim, I provided the link to the Wiki article in my earlier post.

Bill, thanks for your analysis.  Unfortunately, though, I don't see that it solves the problem.  
...

Any further suggestions?
Thanks.

Your original post began

"When I try to play something, I will get an error message that the library path is not right."

I tried to address that problem and in the process I explained how MC uses file location information for ripping CDs, importing files and playing files.  

You reported that

"The main view with the column showing the file path indeed shows the path to be E:\music for server\...."

If you try to play such a file now, does MC play it successfully or do you get an error message?  if not, I have a step-by-step test below.

"As noted in my original posting, the essential problem is that tools, options, file location, dialog box won't allow the path to change from D:\ to E:\ Thus the base path is wrong and using the dialog box to browse to the correct path or manually enter the correct path does not change the base path. "

You seem stuck on this observation.  Being unable to change the base path from d: to e: is a problem but it isn't related to MC's not playing the files you imported.

I explained that those settings are not used when you import files and that once files have been added to the MC library.  You seem unable to consider the idea that your analysis doesn't match the way MC works.

"Talking with a fellow who is well known in Bay Area audio circles (runs a major audio store) and is a techie, he theorizes that my basic problem may be that I ripped in dbPowerAmp and have been using JRiver to play."

I have ripped CDs with EAC and dBpowerAmp and imported them into MC without problems.  I explained how MC uses file location information for importing files in my first post.  I have also ripped CDs using MC.  I also explained how MC uses file location information when it rips CDs.  

"At this point, I have about 130 pieces, and would like to start over. But, I need to at least be able to save the several hundred dollars worth of downloaded files and be able to use them with whatever player I set up."

As long as you do not delete the music files in MC or using some other program, nothing is lost.

"What is puzzling is that I did at one point have this working right.  But, the next time I opened Media Center 15 I got the Xs at the left of the pieces and could not get this to work at all.  Haven't been able to play anything."

1. Check to be sure that you can see the files on drive E: in Windows Explorer.

2. In MC, use the File/Open Media File command to play one of those files on E:.  This will show whether MC can find and open a file on drive E:.

3. Remove all the music files on E: from the MC library and re-import them. (Just remove them from the library. Don't delete them.)

4. Select one of those files and play it.  If MC is still unable to play those files, then you should post again about that specific problem.  

"I am thinking of trying the Sonata system, which Sonata says uses your JRiver basic system but greatly simplifies it and allows organizing for classical listeners."

Sonata may provide better metadata for tagging classical music files but MC has very good facilities for tagging and viewing classical music.  I picked MC in preference to other software five + years ago because of that capability.

Bill
Logged

Dennis Graves

  • Junior Woodchuck
  • **
  • Posts: 56
Re: How can I change the path to my music library?
« Reply #6 on: October 02, 2011, 01:19:24 pm »

Bill,
I am happy to report success!
I used the clear library function to remove everything. (Which I had done before.)
I then imported everything. (Which I had done before.)
When I closed MC15, there was a long period in which the program was apparently retagging or doing something with all the files on my external drive (where I store the music).  When I reopened MC15, I could again play music.  I noticed that the Filename listing (right column) had changed every file from E: to D:.  Although the external drive is denominated E:, it is apparently read as E:\ (D:), so that the filename change to D: allows the playing.
Although it now works, I wonder what will happen when I download or rip new music, which will be in the external drive denominated "E:".  I hope that will not be a problem.  I don't mean to be stuck on a non-existent problem, but as you can tell I don't understand much about how MC15 works and so I don't know what might and might not be a problem (just as I did not understand what caused the problem before).

I will say that I think I now know what caused the problem I posted a few days ago: every one of my extensive files of pictures being imported when I did a music import in MC15.  The problem appears to be that MC15 defaults to a check on the Import Images box.   I may not have the problem as long as I can remember to always check the import settings and uncheck the images box before importing, but it seems to me that you would want to change that default setting. Also, it seems to me that there needs to be some way that the program can distinguish between images that relate to music (eg, cover art) and images that are completely unrelated (like my 100+ GB files of photographs).   

Thanks for your assistance.

Dennis
Logged
Pages: [1]   Go Up