INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Logitech Elite - Made me almost insane... ooops too late..  (Read 10372 times)

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291
Logitech Elite - Made me almost insane... ooops too late..
« on: August 23, 2016, 08:48:13 am »

My experience with Harmony Elite Setup (Remote (was) stuck on Harmony logo Screen)


After fighting with a firmware update for 4 hours and getting the remote stuck in no-mans land and finally working out what the **** was going on I thought I'd post my experience incase it helps others.

I love your remotes Logitech, this is an upgrade from an Ultimate to Elite for me... but for god sake sort out your firmware updates and recovery processes!

Firstly the good... the out of box setup and transfer of my old settings using the IOS app was flawless.  I had it up and running in less than 15 mins using my old profiles on the new hub and elite remote.  Great!!!. .... But that's where things started going wrong... The remote would freeze and reboot... and eventually after the third time I decided to check for updates.

Well that's where the real fun began... ok so you have to connect everything to a PC to update firmware.  OK got it.. have done a few time before with the ultimate remote so I know what to expect.... except... after trying on 3 different PCs It was still failing the update between 30 and 50%. Tried different USB cables.  another dozen google searches and Logitech forum browsing and nothing I turned up was getting me any where.

 So eventually after maybe 20 attempts.. yes I'm persistent... I reset the remote by holding menu and off buttons for 20 seconds. OK now what... well still it wouldn't update and now it wasn't detected anymore when plugged into the computer. This was really going down hill fast...   So now it was stuck either in recovery safe mode with the arrow circle above a little remote icon or on the harmony screen.. which of course wasn't detected by the PC software either.....
 So what next?  Pull the battery out, which involves 2 different size jewelers screwdrivers to get the tiny screws out and another tiny flat blade to pop the cover off just to get the battery out...

 Yeah I'm starting to fume and spout all sorts of expletives now... and this is only 2 hours in to a 4 hour ordeal... so I stopped and had dinner and then got to work again....

 So now I've got the remote booting back to the harmony screen and it's just stuck there doing nothing,,, no indication of what its doing or what I need to do...  OK so I'll try plugging it in to the PC again... oooppss nope still not detected...  OK I'll try the Hub and remote recovery, as directed by the lovely brief online troubleshooting guide.... ahhhhh but it gets through resetting the hub and wait for it... nope it still doesn't detect the remote even in recovery mode or with the harmony logo screen up... hmmmmmmm stuck in an infinite loop... what to do next???

 Have way too much ice-scream (yes that's intentionally misspelt) and try calm down... :P   After all I just spend $550au on this sucker and it's now a useless paper weight.

 Seriously though I did eat way too much ice-cream and after 4 hours I decided to get the old IOS harmony app fired up to see what it can make of the situation...  So I delete my old hub and the new hub, and then proceeded to setup the new hub again, ok so far.. I'm feeling calmer and the hub is now setup again.... I feel like GOD!! All bow before me... I actually achieved something, I felt like I was on a role again.. OK so the IOS App now tells me to put the remote on the cradle to re pair it with the hub.. ok makes sense..

 So I do as the IOS App tells me and I place the remote in the charging cradle... low and behold the ****** of a thing connects and starts to download my cloud settings...

 WELL FFS the **** things working again... why couldn't the dumb**** PC software tell me the remote needed to be re paired with the hub?????

 After all this faffing around the **** things also updated to the latest firmware, somewhere along the way of trying to get the firmware in it must have got far enough to complete even though it failed at 50%.

 So moral of the story, never trust a PC... no seriously if you get stuck on a harmony screen it means the remote has lost it mummy and its gone in hiding until you reunite it with it's mummy using the IOS app.... (re pair it with the hub by putting in the cradle and running the new hub setup on the IOS app - dumb PC too dumb to work that out for you!)

 Then and only then can you attempt the cycle of the firmware update again.. hopefully not to be stuck in an infinite loop.  I was lucky I escaped with my sanity and a working remote with the latest firmware... but Logitech fair suck of the lifesaver... for GOD sake sort out your troubleshooting guide on the PC and fix up your firmware timeouts! jeeshh...

 Yes I still love you Logitech Elite - but you better ****** well not break 2 days after warranty or your gonna have a meeting between the concrete and my car tyre!
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: Logitech Elite - Made me almost insane... ooops too late..
« Reply #1 on: August 23, 2016, 09:06:56 am »

Glad to hear you finally got it working!  That kind of experience is a nightmare.  I've heard a number of "trouble stories" about various Harmony family remotes that don't make me want one.  Though I have to say that the Elite is a very nice looking remote, with well shaped buttons (to locate them without looking), and a nice looking (though small) screen.

Next time I go shopping for a remote, I think it's going to be a big adventure.  The world has changed and is changing rapidly right now in the home integration (IoT) space.

Brian.
Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291
Re: Logitech Elite - Made me almost insane... ooops too late..
« Reply #2 on: August 23, 2016, 09:22:05 am »

Yeah this remote supports so many IoT devices now... I'll have to start buying some! ;)

PS. Its a fair bit faster than the old Ultimate and button layout is a huge improvement. Touch screen is usable and pretty responsive and the whole thing just feels good in your hand.  (also has 6 dedicated IoT hard buttons for lighting, turning things on/off and up/down)
Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291
Re: Logitech Elite - Made me almost insane... ooops too late..
« Reply #3 on: August 23, 2016, 09:53:27 am »

IoT support today - (more coming)

Phillips Hue lighting
Samsung Smart Things
August Locks
Ecobee
Hunter Douglas automated window shades
Honeywell
IFTTT
Insteon light switches and sensors
LIFX
Lutron Caseta wireless lighting
Lutron Serena shades
Nest Thermostats
Nest Smoke alarms and detectors
Peq lighting
Rheem water heaters

With a home hub extender it also does
ZigBee
Z-wave plus
GE, Osram and Sylvania lighting
Kwikset, Yale and Schlage locks
Enerwave, Nortek and Quirky switches
Aeon Labs powerboards
Aeon Labs door and window and water sensors
Ecolink motion detector
Nyce Sensors


It detects Ethernet TVs and PS4s,  Sonos and a bunch of other network IP devices.

It's almost too much!!!!!!!!!




Logged

Wombat

  • Member
  • *
  • Posts: 1
Re: Logitech Elite - Made me almost insane... ooops too late..
« Reply #4 on: March 17, 2017, 09:27:55 am »

Hi Hilton,

interesting to see you got this remote working with MC. I'm trying to get this done for a friend, but so far no luck. It's a Logitech Harmony Elite in combination with a FLIRC receiver in a Win10 setup. So far I had no success in getting it to work perfectly, tried all sorts of things, but I have to admit I'm not an MC guru... :-(

Would you be willing to share some tips to help me in the right direction?

Would be grateful for any help you can provide.

Grts
Wombat
Logged
Pages: [1]   Go Up