INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Cover art removal not working  (Read 2983 times)

crisp

  • World Citizen
  • ***
  • Posts: 104
Cover art removal not working
« on: April 13, 2013, 02:19:45 pm »

I've set JRiver to not import cover art, yet it continues to import it.

Also, I've removed all existing cover art from files, yet they keep reappearing.

Is this a bug?
Logged

JohnT

  • Citizen of the Universe
  • *****
  • Posts: 4627
Re: Cover art removal not working
« Reply #1 on: April 15, 2013, 08:34:55 am »

How did you set JRiver to not import cover art?
Logged
John Thompson, JRiver Media Center

crisp

  • World Citizen
  • ***
  • Posts: 104
Re: Cover art removal not working
« Reply #2 on: April 16, 2013, 05:50:15 pm »

Sorry, I can't remember! Maybe I meant I set XLD not to embed cover art. I'm still learning from scratch, so please bear with me.

However, for each album I did right click on the cover art image in tag, then the icon in the top left corner, then "remove cover art". It worked, then when I reopened MC the art was all back.

Is there a way to eliminate all cover art and stop it from loading with each new rip?
Logged

JohnT

  • Citizen of the Universe
  • *****
  • Posts: 4627
Re: Cover art removal not working
« Reply #3 on: April 17, 2013, 07:55:49 am »

Since the cover art is embedded in the file, Media Center will show it if it's there.  There's no option to have Media Center automatically modify all of your audio files by removing images from their tags.  The "Remove cover art" option in Media Center works on a file by file basis, not album, but you can select multiple files and use that option to remove the cover art from them.  However it seems like the simplest solution is to tell XLD to not embed the art in the first place if that's what you're looking for.  Out of curiosity, why do you want to remove the cover art?
Logged
John Thompson, JRiver Media Center

crisp

  • World Citizen
  • ***
  • Posts: 104
Re: Cover art removal not working
« Reply #4 on: April 17, 2013, 11:58:51 am »

Thanks John, I'll give this a try when I get home tonight. I was removing the art with a whole album selected, not individual files, which might be why it keeps showing. Or maybe XLD is telling MC to show it even though I thought I blocked it on XLD.

Re your question, I'm starting off by ripping my collection of Mosaic jazz boxed sets (mosaicrecords.com) and the cover art generated by CD databases is rarely correct or in poor resolution and very hard to find elsewhere.

I've also decided that finding the right art is just one more task in what will be a very big job, so I'm cutting the workload by eliminating it -- or at least trying to (I have a mania for tidyness)!
Logged

JohnT

  • Citizen of the Universe
  • *****
  • Posts: 4627
Re: Cover art removal not working
« Reply #5 on: April 17, 2013, 12:40:41 pm »

Whenever the audio file contains an embedded cover art image, MC will show it.  So if the files are created by XLD, XLD must be embedding these cover art images in the files.
Logged
John Thompson, JRiver Media Center

crisp

  • World Citizen
  • ***
  • Posts: 104
Re: Cover art removal not working
« Reply #6 on: April 17, 2013, 05:05:43 pm »

Thanks. In XLD Preferences I have "Embed cover art images into files" unchecked, so I'm at a loss, but obviously that isn't a JRiver issue.
Logged

JohnT

  • Citizen of the Universe
  • *****
  • Posts: 4627
Re: Cover art removal not working
« Reply #7 on: April 18, 2013, 08:31:40 am »

One other thing I should have mentioned - go to Tools / Options / File Location
under "Cover Art" select "Clean cover art folder..."


Actually, that may only clear files not referenced by Media Center.  Try deleting everything in this folder (replace xxxxxx with your user name):
/Users/xxxxxx/Library/Application Support/J River/Media Center 18/Cover Art/Albums
Logged
John Thompson, JRiver Media Center

crisp

  • World Citizen
  • ***
  • Posts: 104
Re: Cover art removal not working
« Reply #8 on: April 19, 2013, 06:06:56 am »

Hi John

Can you give me a bit more guidance please? I tried to find that folder* in Tools / Options / File Location as in the struck-through part of your post, but nothing happened.

(I also tried following the struck-through directions for the heck of it but when I relaunched the cover art reappeared.)

*ie, /Users/xxxxxx/Library/Application Support/J River/Media Center 18/Cover Art/Albums

Thanks again.
Logged
Pages: [1]   Go Up