INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Number Plays and Last Played  (Read 1842 times)

jato1569

  • Recent member
  • *
  • Posts: 24
Number Plays and Last Played
« on: June 05, 2013, 04:21:26 pm »

When I listen to my music in my library through a client accessing my home server, I noticed that the number of plays and the last played information are updated on the client as I play music, but not on the server. Furthermore once I close the client and reopen it, all information related to my last session are reset to the ones in the server.
Is there a particular setting to have these fields updated?
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42027
  • Shoes gone again!
Re: Number Plays and Last Played
« Reply #1 on: June 05, 2013, 04:23:43 pm »

You need to enable sync to allow changes to flow from client to server.

On the server, enable authentication in Options > Media Network.  For security, a server only accepts changes from authenticated clients.

On the client, make sure this is enabled:
Options > Media Network > Client Options > Auto sync with server
Logged
Matt Ashland, JRiver Media Center

jato1569

  • Recent member
  • *
  • Posts: 24
Re: Number Plays and Last Played
« Reply #2 on: June 05, 2013, 04:31:15 pm »

Matt,
thank you for the quick reply. I checked and I have authentication set in my server with username and password. On the client I also have auto sync with server enabled.
Is there anything else I am missing?

I don't have the same issue playing tracks through JRemote accessing the same server.
Logged

jato1569

  • Recent member
  • *
  • Posts: 24
Re: Number Plays and Last Played
« Reply #3 on: June 05, 2013, 07:06:30 pm »

I also tried to play remotely using WebGizmo and connecting to the same Library Server. Number Plays field and Last Played are correctly updated.
Same tracks played through the client library does not change any of the two above mentioned fields.

Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42027
  • Shoes gone again!
Re: Number Plays and Last Played
« Reply #4 on: June 05, 2013, 07:20:09 pm »

thank you for the quick reply. I checked and I have authentication set in my server with username and password. On the client I also have auto sync with server enabled.
Is there anything else I am missing?

That should be it.

If you change an artist or track name on the client, does that eventually get to the server (it can take a few minutes)?

What if you manually pick File > Library > Sync with Library Server (or similar, I'm going from memory)?

We'll also test.
Logged
Matt Ashland, JRiver Media Center

jato1569

  • Recent member
  • *
  • Posts: 24
Re: Number Plays and Last Played
« Reply #5 on: June 05, 2013, 09:29:04 pm »

I tried the following:

Played a track on the client library
Number Plays and Last Played did not change on Server Library
Tried to Sync Changes with Library Server from File menu, but no changes on the Server Library.
Modified the comment field of same track on the Client Library.
Waited few minutes, but the change did not happen on the Server Library.
Try to manually sync through the file menu, but still no changes.
Played same track with WebGizmo and last played and number plays fields changed accordingly
Logged

jato1569

  • Recent member
  • *
  • Posts: 24
Re: Number Plays and Last Played
« Reply #6 on: June 06, 2013, 02:46:38 pm »

Here are some additional details that could be useful in determining the reason for the behavior observed.
Using MC for MAC I connected as a client to my Windows Media Center Server Library.
When I play tracks in my client, the number plays and last played are updated correctly in the Windows Server Library.
It looks like the problem is not in the MAC MC client library, but rather on the MAC server library.
Did anybody else experience similar issues?
Logged

jato1569

  • Recent member
  • *
  • Posts: 24
Re: Number Plays and Last Played
« Reply #7 on: June 07, 2013, 12:03:47 pm »

Matt,
have you been able to duplicate the inability to sync client with server?
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 42027
  • Shoes gone again!
Re: Number Plays and Last Played
« Reply #8 on: June 07, 2013, 04:37:40 pm »

John reproduced it and is working on it.  Hopefully he'll get it fixed next week.

Thanks.
Logged
Matt Ashland, JRiver Media Center

jato1569

  • Recent member
  • *
  • Posts: 24
Re: Number Plays and Last Played
« Reply #9 on: June 11, 2013, 04:28:12 pm »

Just downloaded newest revision 195 and the sync between client and server is now working.
Thank you.
Logged
Pages: [1]   Go Up