INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Import Problem #2  (Read 1770 times)

edtyre

  • Recent member
  • *
  • Posts: 16
Import Problem #2
« on: July 11, 2013, 09:57:02 am »

I have hundreds of tagged flac files that won't import in MC.

They play fine in Cog. When i convert them to ALAC they import fine
with tags intact. While MC is trying to import them it hangs, then finally displays
the dialog box with 0 files imported.

Thanks for any help. I'll dropbox a file for you to check out.
Logged

JohnT

  • Citizen of the Universe
  • *****
  • Posts: 4627
Re: Import Problem #2
« Reply #1 on: July 11, 2013, 10:36:31 am »

I received the file from you, thanks.  Unfortunately, I can't reproduce the problem here, it imports and plays fine on my system (OSX 10.7, MC build 207).  Can you try these steps and report what happens:

1. from the main menu:  File / Play Media File...
2. select file "NY2009-04-13d1t02.flac"

If it fails and the file is on a network drive, try copying the file to your local drive and retry the same steps.
Logged
John Thompson, JRiver Media Center

MrC

  • Citizen of the Universe
  • *****
  • Posts: 10462
  • Your life is short. Give me your money.
Re: Import Problem #2
« Reply #2 on: July 11, 2013, 01:12:39 pm »

Two thoughts to add:

   - Do the paths to the FLAC's contain a semicolon (or possibly some other non special chars) in them?
   - Do the converted files live in a folder which doesn't have a semicolon (or other special char)?

There seems to be a bug with some file paths, so I'm wondering if this might be the same issues.
Logged
The opinions I express represent my own folly.

JohnT

  • Citizen of the Universe
  • *****
  • Posts: 4627
Re: Import Problem #2
« Reply #3 on: July 11, 2013, 01:21:52 pm »

Two thoughts to add:

   - Do the paths to the FLAC's contain a semicolon (or possibly some other non special chars) in them?
   - Do the converted files live in a folder which doesn't have a semicolon (or other special char)?

There seems to be a bug with some file paths, so I'm wondering if this might be the same issues.
I think you're probably right - I'm working on the path bug right now.
Logged
John Thompson, JRiver Media Center

edtyre

  • Recent member
  • *
  • Posts: 16
Re: Import Problem #2
« Reply #4 on: July 11, 2013, 02:28:39 pm »

I have 10.8.4 with build 207

Played the file with >> File / Play Media File  and it plays fine.

I think i found the problem. It's in the file path, i checked the all the folders that won't work
and they all have multiple spaces in them, like this

NY2009-06-06 Antwerpen RR Master

When i remove the spaces in the folder name the files import.
During the time MC is trying to import the bad folders, it hangs for about two minutes
goes to the background when you click anywhere, then the dialog box finally comes to the front
showing zero files imported.

But....when i try to add folders like this
Buffalo Springfield Bridge Benefit 2010-10-23

these have spaces and there is no problem??

One more thing to add....all the bad folders were prepared on a Dutch language PC.
Logged
Pages: [1]   Go Up