INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Mint Setup for JRiver Media Center  (Read 22988 times)

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13533
Mint Setup for JRiver Media Center
« on: October 18, 2013, 05:16:40 pm »

Installed the latest Mint, 15.0 32 bit on an old Core2 quad box with a Audigy card.
It works fine.
I installed lame, libcurl3 xfonts-75dpi and xfonts-100dpi

Welcome to Linux Mint 15 Olivia (GNU/Linux 3.8.0-19-generic i686)

The only gotcha was the Audigy card default port didn't support sample rates other than the even numbered ones, i.e.
16k 32k 48k 96k etc. Used DSP studio to handle that.



Logged

drmimosa

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 688
Re: Mint Setup for JRiver Media Center
« Reply #1 on: October 30, 2013, 11:02:37 am »

It works great!

I'm a Linux novice, my prior experience limited to setting up a home file server using ubuntu server. This has been my only linux media player installation that involved ZERO frustrations or problems.

The installation used the current Linux Mint 32 bit Cinnamon version and MC 19.65 on an old 2007 MSI Wind netbook. Auto import found 1200 flac albums on a media partition. Two USB audio devices pulled up without any problems and the ALSA output sounds great. Play doctor up and running. Windows had slowed to a crawl on this machine, so I am very happy it has found new life as a Linux Jukebox.

Thanks for your work and development. This opens up a lot of hardware options for JRiver installations!
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13533
Re: Mint Setup for JRiver Media Center
« Reply #2 on: October 30, 2013, 05:08:05 pm »

Thanks for the report!
Logged

michaelg14

  • Recent member
  • *
  • Posts: 9
Re: Mint Setup for JRiver Media Center
« Reply #3 on: November 07, 2013, 04:09:47 pm »

Mint 15 64 bit, MC 19.0.70-1 give me the xfonts 75 dependency error.  I then installed 19.0.70 and it went in.  Tried to load files from a directory that wasn't /home/music and was not able to select it.  Browse for files didn't work.

I will keep trying.

Logged

Mike Noe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 792
Re: Mint Setup for JRiver Media Center
« Reply #4 on: November 07, 2013, 04:47:45 pm »

Try entering the path by typing it directly.
Logged
openSUSE TW/Plasma5 x86_64 | Win10Pro/RX560
S.M.S.L USB-DAC => Transcendent GG Pre (kit) => Transcendent mono OTLs (kit)
(heavily modded) Hammer Dynamics Super-12s (kit)
(optionally) VonSchweikert VR8s

michaelg14

  • Recent member
  • *
  • Posts: 9
Re: Mint Setup for JRiver Media Center
« Reply #5 on: November 07, 2013, 05:27:12 pm »

That seems to work once I got used to watching every character as I typed it.  MC doesn't take input very well yet.  In any case it is now importing music files.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13533
Re: Mint Setup for JRiver Media Center
« Reply #6 on: November 07, 2013, 07:49:52 pm »

Browse is on the todo list, thanks for the report.
Logged

Wybe

  • World Citizen
  • ***
  • Posts: 129
Re: Mint Setup for JRiver Media Center
« Reply #7 on: November 19, 2013, 01:48:22 pm »

Should it already be possible to output audio to a PS Audio PerfectWave DAC via the network? I've installed Linux Mint and JRiver on a mini PC and added the above mentioned dependancies with the Mint Software manager. I've selected under Network The 24-bit Audiophile DAC. The PerfectWave DAC shows up under Playing Now on the left side. However, when I select a song to output to the PWD the software freezes. I have to reboot.
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Mint Setup for JRiver Media Center
« Reply #8 on: December 19, 2013, 09:24:30 am »

I have a Mint 16 installation 64-bit Cinnamon. Dependencies and MC19 installed fine, but the font does not seem to be working. I have xfonts-100dpi and xfonts-75dpi installed.

Does anyone have an idea what I can try to fix that?
Logged

Robert Joe

  • Junior Woodchuck
  • **
  • Posts: 51
Re: Mint Setup for JRiver Media Center
« Reply #9 on: December 19, 2013, 01:54:50 pm »

I have a Mint 16 installation 64-bit Cinnamon. Dependencies and MC19 installed fine, but the font does not seem to be working. I have xfonts-100dpi and xfonts-75dpi installed.

Does anyone have an idea what I can try to fix that?

I installed those and it improved the font appearance. It is still not as good as other Linux apps but it is better.

I also have Microsoft Fonts - not sure if it is related to your problem. But you could try:

sudo apt-get install ttf-mscorefonts-installer
    Hit tab to highlight yes/ok for agreement

Then logout or reboot.
Logged

audiolover

  • Junior Woodchuck
  • **
  • Posts: 93
Re: Mint Setup for JRiver Media Center
« Reply #10 on: December 21, 2013, 12:22:17 am »

I did not find the option to only start the server on startup?
Logged

Mike Noe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 792
Re: Mint Setup for JRiver Media Center
« Reply #11 on: December 21, 2013, 07:16:00 am »

You can use your desktop's autostart:
Code: [Select]
[Desktop Entry]
Comment[en_US]=Play and organize your music collection
Comment=Play and organize your music collection
Exec=mediacenter19 /mediaserver
GenericName[en_US]=JRiver MediaCenter 19
GenericName=JRiver MediaCenter 19
Icon=/usr/lib/jriver/Media Center 19/Data/Default Art/Application.ico
Keywords=Audio;Song;MP3;CD;Podcast;MTP;iPod;Playlist;Last.fm;UPnP;DLNA;Radio;
MimeType=audio/x-vorbis+ogg;audio/x-scpls;audio/x-mpegurl;audio/mpeg;audio/mpeg;audio/mpeg;audio/flac;application/ogg;application/ogg;
Name[en_US]=MediaCenter
Name=MediaCenter
.
.

or from the terminal with the "/mediaserver" switch
Logged
openSUSE TW/Plasma5 x86_64 | Win10Pro/RX560
S.M.S.L USB-DAC => Transcendent GG Pre (kit) => Transcendent mono OTLs (kit)
(heavily modded) Hammer Dynamics Super-12s (kit)
(optionally) VonSchweikert VR8s

audiolover

  • Junior Woodchuck
  • **
  • Posts: 93
Re: Mint Setup for JRiver Media Center
« Reply #12 on: December 21, 2013, 08:28:27 am »

This will start Media center but I want only the server.
Logged

Mike Noe

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 792
Re: Mint Setup for JRiver Media Center
« Reply #13 on: December 21, 2013, 05:57:07 pm »

Not here. 

(openSUSE 13.1/KDE 4.12.0)
Logged
openSUSE TW/Plasma5 x86_64 | Win10Pro/RX560
S.M.S.L USB-DAC => Transcendent GG Pre (kit) => Transcendent mono OTLs (kit)
(heavily modded) Hammer Dynamics Super-12s (kit)
(optionally) VonSchweikert VR8s

tiguan

  • Recent member
  • *
  • Posts: 17
Re: Mint Setup for JRiver Media Center
« Reply #14 on: March 21, 2014, 07:53:50 am »

Before asking my question, I believe AP-Linux is developed over Mint.
At a new partition I installed AP-Linux want to install JRiver in it. I searched the topics and could not get anything with AP-Linux.

As a beginner Linux user, may I get step by step instructions smilar the How to: topics for debian, ubuntu .

Thanks in advance.
Logged

tiguan

  • Recent member
  • *
  • Posts: 17
Re: Mint Setup for JRiver Media Center
« Reply #15 on: March 21, 2014, 09:06:04 am »

After my previous message I tried to install JRiver at XFCE mode I installed and saw at the menu JRiver. Restart and opened as Fluxbox (AP-Linux) again but JRiver is not there.

Then I opened a terminal
Installed with the below commands and did not received any failure message but can not see still at the menu bar. Either under sound nor in general part.


wget http://files.jriver.com/mediacenter/channels/v19/latest/MediaCenter-19.0.122.deb

sudo dpkg -i MediaCenter-19.0.122.deb
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Mint Setup for JRiver Media Center
« Reply #16 on: March 21, 2014, 10:43:12 am »

Try to start it in a terminal:

Just type: mediacenter19

If it doesn't work (it should but in case), try it with a full path:

/usr/bin/mediacenter19

Or if for some weird reason it wasn't installed in /usr/bin, to find out where it is, type: which mediacenter19
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13533
Re: Mint Setup for JRiver Media Center
« Reply #17 on: March 21, 2014, 10:56:38 am »

Also, on my XFCE it shows up under Multimedia. You can drag it to the desktop or bar from there.
Logged

tiguan

  • Recent member
  • *
  • Posts: 17
Re:
« Reply #18 on: March 21, 2014, 11:19:13 am »

Thanks I will try tonight and update you with the last situation
Logged

tiguan

  • Recent member
  • *
  • Posts: 17
Re:
« Reply #19 on: March 21, 2014, 03:37:32 pm »

I could not bring any shortcut for mediacenter at Ap Linux but it worked when I write at terminal window and program opens.
But gives this message
"Ignoring Xlib error:error code 3 request code3
Details: Badwindow ( invalid window parameter)
Ignoring Xlib error: error code 8 request code 42
Details: Badmatch ( invalid parameter attributes) "
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13533
Re:
« Reply #20 on: March 21, 2014, 05:48:14 pm »

I could not bring any shortcut for mediacenter at Ap Linux but it worked when I write at terminal window and program opens.
But gives this message
"Ignoring Xlib error:error code 3 request code3
Details: Badwindow ( invalid window parameter)
Ignoring Xlib error: error code 8 request code 42
Details: Badmatch ( invalid parameter attributes) "
Those can be safely ignored they have no effect on on the running of MC.
Logged

tiguan

  • Recent member
  • *
  • Posts: 17
Re: Mint Setup for JRiver Media Center
« Reply #21 on: March 22, 2014, 03:53:23 am »

Ok thanks. Now mediacenter 19 works. Output is m2tech hiface2.
No sound to m2tech sound comes deep from netbook :) now I am working on it. Needs some setting adjustment I guess.
We can use jack and mediacenter together do not?
Logged

tiguan

  • Recent member
  • *
  • Posts: 17
Re:
« Reply #22 on: March 22, 2014, 04:16:02 am »

I checked from cd player to dac and it works so no problem with dac or cabling or any other. Mediacenter works as well. Then I checked from sound menu hiface2 is choosen and yes it is ok. Then from hardware window tested left and right speaker no sound I am sure now my problem is between mint (ap- linux) and hiface2 I will try to learn why they fight each other. :)
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13533
Re: Mint Setup for JRiver Media Center
« Reply #23 on: March 22, 2014, 11:06:02 am »

We don't interact with Jack at all.
I have tested MC with a system using jack and it worked.
Now you need to make sure MC is using the internal volume control (right click the speaker icon on the volume slider and choose internal).
Also, make sure the system PCM mixer is turned up. You may have more than one system mixer control to deal with.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7411
  • The color of Spring...
Re: Mint Setup for JRiver Media Center
« Reply #24 on: March 22, 2014, 11:09:14 am »

Now you need to make sure MC is using the internal volume control (right click the speaker icon on the volume slider and choose internal).

Actually, wouldn't it be best to default MC for Linux to use internal volume until if/when system volume works?

Jack in MC? Yes pretty please.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

tiguan

  • Recent member
  • *
  • Posts: 17
Re: Mint Setup for JRiver Media Center
« Reply #25 on: March 23, 2014, 12:53:43 pm »

Finally I solved the problem by assigning soundcard manual at alsa.conf.

Now I can get music.

But now the problem is different.
44khz albums plays without a problem.
96khz and over stops and starts itself. It do not play fluent.

alsa setting is at default.
when I switch from default to "front: CARD = M20" which is directly M2tech problem icreases.
Jack is not active at AP-Linux.

Just J river settings are used. What should I do to have fluent music what will be the best setting ?

Logged

tiguan

  • Recent member
  • *
  • Posts: 17
Re: Mint Setup for JRiver Media Center
« Reply #26 on: March 23, 2014, 03:51:36 pm »

I removed pulseaudio and installed from zero again ALSA problem solved. The most difficult album I have was Bueno Vista Social Club 24 bit 192 k hz huge files played without problem.
Logged

B H de C

  • Recent member
  • *
  • Posts: 22
Re: Mint Setup for JRiver Media Center
« Reply #27 on: March 23, 2014, 05:09:10 pm »

I removed pulseaudio and installed from zero again ALSA problem solved. The most difficult album I have was Bueno Vista Social Club 24 bit 192 k hz huge files played without problem.

Glad to hear. What do you mean by:  installed from zero again ALSA?
I am having issue and looking for new ideas.
Thanks.
Logged

tiguan

  • Recent member
  • *
  • Posts: 17
Re: Ynt: Re: Mint Setup for JRiver Media Center
« Reply #28 on: March 24, 2014, 10:36:29 am »

Glad to hear. What do you mean by:  installed from zero again ALSA?
I am having issue and looking for new ideas.
Thanks.

Hi. I did exactly what is told in here
Hope it will be helpful for you.

http://linuxg.net/how-to-properly-replace-pulseaudio-with-alsa-on-crunchbag-linux-and-debian-squeeze/
Logged
Pages: [1]   Go Up