INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Installing MediaCenter i386 build on 64 bit platforms (Mint 16)  (Read 10220 times)

Johnny Stork

  • Junior Woodchuck
  • **
  • Posts: 93
  • Johnny Stork
Installing MediaCenter i386 build on 64 bit platforms (Mint 16)
« on: October 25, 2013, 06:47:58 am »

I have modified this post to reflect some of the changes to the requirements for MC on 64bit Mint platforms. Unless I have missed something, and please comment if I have, it looks like this is what is needed after a fresh Linux Mint 16 installation, to get the current MC (MediaCenter-19.0.94.deb) installed

sudo apt-get install lame libcurl3 xfonts-75dpi xfonts-100dpi libx11-6:i386 lib32stdc++6 libmpcdec6:i386 musepack-tools musepack-tools:i386

Then download and install the deb from http://files.jriver.com/mediacenter/channels/v19/latest/MediaCenter-19.0.94.deb

I am still having trouble getting local sound from two different Mint installs, but at home I only use it as a client to the server so all is good. :)
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Installing on 64 bit platforms
« Reply #1 on: October 25, 2013, 10:18:29 am »

In general on 64 bit platforms with multiarch support you need:
The base 32 bit libraries (on debian libc6:i386).
C++ libraries (on debian libstdc++6:i386)
The base X11 libraries (on debian libx11-6:i386)
and a 32 bit libcurl with SSL support (on debian libcurl3:i386)

As always, the two fixed xfonts should be installed.
xfonts-75dpi xfonts-100dpi

As well as lame.

Edit: 1/2/2014
Added requirements for builds >= 19.0.94
libcryptopp (on debian libcrypto++9:i386)
musepack-tools (on debian musepack-tools:amd64 or musepack-tools:i386)
lame (on debian lame:amd64 or lame:i386)

The dependencies for lame and musepack-tools will probably be changed to "recommended" instead of "required" for future builds. These are just for encoding.
Logged

mrpro

  • Recent member
  • *
  • Posts: 19
Re: Installing on 64 bit platforms
« Reply #2 on: December 07, 2013, 05:04:26 pm »

Thanks for these two excellent posts. After reading these and a couple others, I was able to install JRiver on Ubuntu Linux Studio 13.04 64 bit rather painlessly.
I'm sure it would have been more challenging otherwise.
I'm really impressed by how far along it is in development already.

Working fine using my remote Samba server as source for my library import.

Please keep up the good work.
Logged

Lamenting Demon

  • Member
  • *
  • Posts: 1
Re: Installing on 64 bit platforms (Mint 16)
« Reply #3 on: December 31, 2013, 07:43:15 pm »

I have modified this post to reflect some of the changes to the requirements for MC on 64bit Mint platforms. Unless I have missed something, and please comment if I have, it looks like this is what is needed after a fresh Linux Mint 16 installation, to get the current MC (MediaCenter-19.0.94.deb) installed

sudo apt-get install lame libcurl3 xfonts-75dpi xfonts-100dpi libx11-6:i386 lib32stdc++6 libmpcdec6:i386 musepack-tools musepack-tools:i386

Then download and install the deb from http://files.jriver.com/mediacenter/channels/v19/latest/MediaCenter-19.0.94.deb

I am still having trouble getting local sound from two different Mint installs, but at home I only use it as a client to the server so all is good. :)

Mine keeps spitting the following error:

Quote
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 musepack-tools : Depends: libmpcdec6 (>= 1:0.1~r435) but it is not going to be installed
                  Conflicts: musepack-tools:i386 but 2:0.1~r459-1ubuntu1 is to be installed
 musepack-tools:i386 : Depends: libcue1:i386 but it is not going to be installed
                       Conflicts: musepack-tools but 2:0.1~r459-1ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

I'm completely new to linux and have only been solving problems based on forum advice.  I tried downloading the libmpcdec and libcue1 but I can't figure out how to get them into the right spot. any help?
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Installing on 64 bit platforms (Mint 16)
« Reply #4 on: January 01, 2014, 03:32:56 am »

Mine keeps spitting the following error:

I'm completely new to linux and have only been solving problems based on forum advice.  I tried downloading the libmpcdec and libcue1 but I can't figure out how to get them into the right spot. any help?

I'm not sure why both the 64-bit and 32-bit versions are suggested to be installed. Basically for libraries (name starts with lib*) you need 32-bit versions for mediacenter. Anything else can be 64-bit.

Try removing mediacenter first if you have it installed:
sudo apt-get remove mediacenter19

Then remove musepack 32-bit:
sudo apt-get remove musepack-tools:i386

Fix remaining dependency issues:
sudo apt-get install -f

If the above still gives errors, post the errors before continuing.

Remove remaining residue of packages:
sudo apt-get autoremove

Install mediacenter again.

Ps. You shouldn't be downloading libraries or applications manually from the net. Almost everything you need can be had with aptitude. Most debian-based distributions will have a GUI too, like Synaptic. I prefer the terminal though :P. Here's something to get you started with apt.
Logged

audiolover

  • Junior Woodchuck
  • **
  • Posts: 93
Re: Installing on 64 bit platforms (Mint 16)
« Reply #5 on: January 05, 2014, 11:59:08 pm »

http://yabb.jriver.com/interact/index.php?topic=86459.0

@ mrpro:

You use a samba server, maybe you can help me as I am struggling to get it working.
I started a topic with my problem on the above link.
I think the problem lies on the cliŽnt side but cannot figure it out.

Logged

grizzlebizzle

  • Recent member
  • *
  • Posts: 12
Re: Installing on 64 bit platforms (Mint 16)
« Reply #6 on: May 15, 2014, 06:38:01 pm »

I'm also wanting to install on Mint 16... same problem as above. I tried installing the required musepack-tools:i386 dependency it was complaining about (libmpcdec6:i386) but it wants to blow away a bunch of 64 bit stuff from my machine to install which I am not going to do because who knows what that will break... probably plenty. Apparently there is some issue where they can't coexist? A 64 bit build might be nice and would reduce the number of issues installing on a 64-bit OS.

> sudo apt-get install libmpcdec6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  gstreamer0.10-plugins-bad k3b k3b-i18n kaffeine language-pack-kde-en libk3b6 libk3b6-extracodecs
  libmpcdec6 libxine1 libxine1-misc-plugins libxine1-plugins mint-meta-codecs mint-meta-codecs-kde
  mint-meta-kde phonon-backend-vlc vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse

The following NEW packages will be installed:
  libmpcdec6:i386
0 upgraded, 1 newly installed, 19 to remove and 33 not upgraded.
Need to get 34.8 kB of archives.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Installing on 64 bit platforms (Mint 16)
« Reply #7 on: May 15, 2014, 06:46:33 pm »

I'm also wanting to install on Mint 16... same problem as above. I tried installing the required musepack-tools:i386 dependency it was complaining about (libmpcdec6:i386) but it wants to blow away a bunch of 64 bit stuff from my machine to install which I am not going to do because who knows what that will break... probably plenty. Apparently there is some issue where they can't coexist? A 64 bit build might be nice and would reduce the number of issues installing on a 64-bit OS.

> sudo apt-get install libmpcdec6:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages will be REMOVED:
  gstreamer0.10-plugins-bad k3b k3b-i18n kaffeine language-pack-kde-en libk3b6 libk3b6-extracodecs
  libmpcdec6 libxine1 libxine1-misc-plugins libxine1-plugins mint-meta-codecs mint-meta-codecs-kde
  mint-meta-kde phonon-backend-vlc vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse

The following NEW packages will be installed:
  libmpcdec6:i386
0 upgraded, 1 newly installed, 19 to remove and 33 not upgraded.
Need to get 34.8 kB of archives.

You shouldn't need the libmpcdec6:i386 if you are installing a current build.

dpkg -I MediaCenter-19.0.134.deb
 ...l             
 Package: mediacenter19
 Version: 19.0.134
 Section: sound
 Priority: optional
 Architecture: i386
 Installed-Size: 100773
 Homepage: http://www.jriver.com/
 Depends: libc6 (>= 2.13), libasound2 (>= 1.0.25), libuuid1 (>= 2.20.1), libx11-6 (>= 2:1.5.0), libxcb1 (>= 1.8.1), libxau6 (>= 1:1.0.7), libxdmcp6 (>= 1:1.1.1), libstdc++6 (>= 4.7.2)
 Recommends: xfonts-75dpi, xfonts-100dpi, vorbis-tools (>= 1.4.0) | vorbis-tools:amd64 (>= 1.4.0), lame (>= 3.99) | lame:amd64 (>= 3.99), musepack-tools (>= 2:0.1) | musepack-tools:amd64 (>= 2:0.1)
 
As you can see, the recommends (which are optional) will accept either 32 or 64 bit packages of musepack-tools which is only needed for the command line encoder.
Logged

Robert Joe

  • Junior Woodchuck
  • **
  • Posts: 51
Re: Installing on 64 bit platforms (Mint 16)
« Reply #8 on: May 16, 2014, 07:50:06 pm »

I ran into this problem with Linux Mint 16. When I installed JRiver it removed VLC and its dependencies. When I re-installed VLC it removed JRiver. This is the solution:

Move the MediaCenter .deb file to a tmp directory and then run

# apt-get download libcue1 libmpcdec6 musepack-tools vlc vlc-nox

You will now see all these packages in the tmp directory

libcue1_1.4.0-1_amd64.deb
libmpcdec6_0.1~r459-1ubuntu1_amd64.deb
MediaCenter-19.0.94.deb
musepack-tools_0.1~r459-1ubuntu1_amd64.deb
vlc_2.0.8-1_amd64.deb
vlc-nox_2.0.8-1_amd64.deb

Now install them all

# dpkg -i *
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Installing on 64 bit platforms (Mint 16)
« Reply #9 on: May 17, 2014, 12:28:31 am »

Why are you installing build 94? Isn't that timed out?

The latest has a few dependency changes (read less) you may want to try that as the old version (if it hasn't already) time out soon.
Logged

Robert Joe

  • Junior Woodchuck
  • **
  • Posts: 51
Re: Installing on 64 bit platforms (Mint 16)
« Reply #10 on: May 17, 2014, 01:34:16 am »

Build 94 is just the example in my notes. I am running the latest.
Logged

grizzlebizzle

  • Recent member
  • *
  • Posts: 12
Re: Installing on 64 bit platforms (Mint 16)
« Reply #11 on: July 01, 2014, 04:09:11 pm »

Just an update... on Mint 17 64-bit and the latest MC build I didn't have to do anything in terms of installing 32-bit prerequisities (and having it want to uninstall 64-bit stuff). Installing the deb just worked. That is great.
Logged
Pages: [1]   Go Up