INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Not working with Debian  (Read 4578 times)

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Not working with Debian
« on: November 22, 2013, 09:17:43 am »

I have Debian on two computers and have followed the install instructions carefully but MC does not work - at all.  There is a thumbnail selection in the media section but clicking it produces nothing.  Very frustrating......
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Not working with Debian
« Reply #1 on: November 22, 2013, 11:05:51 am »

Please respond with details like debian release, architecture and audio hardware. For example:
wheezy, i386 (or x64)
To find out if your audio hardware is being seen by MC look under Options->Audio. There should be ALSA and a device pulldown list.
Are there entries in the pulldown list?
Did you try some different ones?
Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #2 on: November 23, 2013, 06:57:40 am »

I am using Debian 'Wheezy' AMD 64 install.  I followed all instructions regarding the installation if i386 files which all did install.  MC shows up as a selection in the multimedia devices for Linux but clicking MC does nothing.  The program does not load on either of my computers.  I should add that I also have MC on my PC and also on my MAC although I don't use it on the Mac because of the crippling of plugins.  A shame because it would easily be my program of choice for Mac if it would support plugins. 

Victor
Logged

BryanC

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 2558
Re: Not working with Debian
« Reply #3 on: November 23, 2013, 11:01:53 am »

I am using Debian 'Wheezy' AMD 64 install.  I followed all instructions regarding the installation if i386 files which all did install.  MC shows up as a selection in the multimedia devices for Linux but clicking MC does nothing.  The program does not load on either of my computers.  I should add that I also have MC on my PC and also on my MAC although I don't use it on the Mac because of the crippling of plugins.  A shame because it would easily be my program of choice for Mac if it would support plugins. 

Victor

So dpkg doesn't produce any warnings or errors during install?
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7408
  • The color of Spring...
Re: Not working with Debian
« Reply #4 on: November 23, 2013, 11:31:54 am »

Try running Media Center via Terminal to see if there's any issues.

mediacenter19

Also, when installing I use sudo dpkg -i plus the location of the .deb file.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #5 on: November 23, 2013, 12:23:53 pm »

DPKG does not show any warnings during install.  I originally installed with GDebi package installer with no success and then subsequently installed through terminal with DPKG which overwrote the files.  MC does not open.  If I type mediacenter19 into terminal I get an error message that says 'error while loading shared library: libX11.so.6: cannot open shared object file:  No such file or directory'.  This all reminds me of the old Dos days.   
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Not working with Debian
« Reply #6 on: November 23, 2013, 12:57:32 pm »

From a terminal, run "sudo apt-get -f install"

You're missing some packages, more information here.
Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #7 on: November 23, 2013, 01:18:09 pm »

I installed all of the packages linked from the last post and MC actually loaded :o  Out of pure ignorance why couldn't a 64 bit version of MC been implemented? 

Now I have to see if MC can see any of my stuff. 

Victor
Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #8 on: November 23, 2013, 01:41:45 pm »

MC cannot access files on my network..... all of my media files are on my Synology.  It cannot find my PS Audio Dac - USB connected.  Lots more work to do......

Victor
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Not working with Debian
« Reply #9 on: November 23, 2013, 01:59:12 pm »

How do you access these files? I don't think MC can directly access files and folders on a share.

I think you should mount your Synology NAS share(s).
Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #10 on: November 24, 2013, 06:36:35 am »

Linux can see them through the network.  MC doesn't know my network exists.  I haven't tried to mount my Synology in Linux but its a moot point since MC cannot see my DAC. 

Victor
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Not working with Debian
« Reply #11 on: November 24, 2013, 07:59:31 am »

Many applications aren't aware of network shares that aren't mounted. For instance, without mounting them they aren't accessible from a terminal. I believe its only the file manager that's actually able to access shares like that but I might be mistaken.

You say your device isn't working in MC, but is it working for other applications? If so, it might simpy be a case of selecting the correct output device in MC.

Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #12 on: November 24, 2013, 12:30:22 pm »

I'm sure I can resolve the network issue by mounting but for the moment just copied a few albums to my 'home/music' folder.  MC sees them immediately after importing but not my Dac which is seen on the PC platform using MC 19 (USB connected).  Linux MC does see all of my internal cards - one of which is a Claro but is not used for any audio.  Under Alsa there are no device choices. 

Victor
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Not working with Debian
« Reply #13 on: November 25, 2013, 09:44:25 am »

Do you have libasound2:i386 installed? It's necessary for MC to see the alsa devices.
Does your DAC have a linux driver?
http://files.jriver.com/mediacenter/hw/alsacap Download this, make it executable and run it in a terminal to see if you can find the DAC.

Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #14 on: November 27, 2013, 10:48:15 am »

I do feel really ignorant regarding all of this.  I have downloaded the file but it appears to be an executable - at least that is how it is displayed in 'files'.  I cannot execute it in terminal since it does not think it is a valid file. 

Victor
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Not working with Debian
« Reply #15 on: November 27, 2013, 10:56:55 am »

If your talking about the dep package you download from these forums, this file doesn't need to be executable.

You need to install it from a terminal using the following command (make sure you're in the correct folder):

# dpkg --install MediaCenter-19.0.82.deb
Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #16 on: November 27, 2013, 12:12:01 pm »

No...... I'm talking about the Alsacap file.  I have MC installed along with all support files but can't find my Dac (USB).  I have the capability to connect this Dac (PWD II) various ways but the only connection that the Dac sees so far is USB - iow the Dac says that it is connected but MC doesn't see it. 

Victor
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Not working with Debian
« Reply #17 on: November 27, 2013, 12:15:15 pm »

Sorry I missed that post above it.

Open a terminal, cd to the folder the alsacap is in. Then type (without the #):

Quote
# chmod +x alsacap

To run it:
Quote
# ./alsacap

No root needed.
Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #18 on: November 28, 2013, 08:43:19 am »

Alsacap does find my USB connected Dac.  I originally installed libasound2: i386 along with all of the other recommended files.  MC does not see my Dac. 
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Not working with Debian
« Reply #19 on: November 28, 2013, 08:50:54 am »

Can you post the output of alsacap and aplay -L, and a screenshot of the devices under Playback Options/Device Settings?
Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #20 on: November 29, 2013, 08:26:39 am »

I have attached four files.  Hope I did this properly. 

Victor
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: Not working with Debian
« Reply #21 on: November 29, 2013, 11:42:35 am »

Yup that works, thanks.

In MC you need to select front:CARD=P20,DEV=0. Aplay -L listed that as well.

In Alsacap, its card 2, ID 'P20', name 'USB Audio'.
Logged

vjbelle

  • Junior Woodchuck
  • **
  • Posts: 73
Re: Not working with Debian
« Reply #22 on: November 29, 2013, 12:38:33 pm »

That did it..... over that hurdle ;)

Thanks....
Logged

mrpro

  • Recent member
  • *
  • Posts: 19
Re: Not working with Debian
« Reply #23 on: December 07, 2013, 04:40:01 pm »


Many applications aren't aware of network shares that aren't mounted. For instance, without mounting them they aren't accessible from a terminal. I believe its only the file manager that's actually able to access shares like that but I might be mistaken.


Yes, if you want JRiver and other apps to access the network share, you must mount it.
I've seen questions on mounting network shares here and in other posts; it can be tricky, and if you do it wrong it may mount, but you won't have rights to it.

Although I am not a Linux guru, I have used it for a number of years, and perhaps I can help out a little:
(Linux gurus, please feel free to jump in.) I have successfully imported all the files on my 4TB Samba share to my JRiver library by the following:
I routinely mount network shares from both my Windows Server 2008 and my Linux samba server in various Linux distros.
After much experimentation, I have settled on the following as the least painlful way to do this:

1st you will need a folder to mount the share to:
sudo mkdir /dirname   creates a folder on the file system root

Next you need to give yourself rights to it:
chown username /dirname -R            Makes you the owner instead of root
sudo chmod 0777 /dirname -R            Gives everybody full rights; if you don't want that, 0755 will give you full rights and others read and execute only   

You need to do that part only once.

Now that you have a place to mount the share, you need to use the cifs-utils to mount it.
Most newer Linux distros have this installed, but if not:
sudo apt-get install cifs-utils    should do it; or use your package manager.

The syntax is a little hairy, but this works to mount shares on my Windows Server 2008 and my Samba server:
sudo mount.cifs //prad810.prociak.lan/t /t -o user=prociak.lan/myron,uid=1000

That is:
sudo mount.cifs //servername.domainname/sharename /dirname -o user=servername/username,uid=1000
Or, if not in a domain just:
sudo mount.cifs //computername/sharename /dirname -o user=computername/username,uid=1000

You should be asked for a password twice, once for the remote computer and once for the local Linux machine.

This should give you the same rights that you have when logging on to the remote computer directly.
The uid number does matter, but if you are the first or only user on the Linux box it will probably be 1000 or 1001
To verify, open the user manager for your distro and check it.

So, the user=username is the name of the user on the remote computer, and the uid=1000 is the identifyer for you
on the Linux box; it determines who has rights to the share once mounted. Don't forget the comma.

Note: If for some reason the remote computer is not found, substitute the ip address for computername as in:
sudo mount.cifs //192.168.1.101/sharename /dirname -o user=username,uid=1000

Sorry if this sounds confusing, but once you get the syntax right, just copy it to a text file.
Then, next time you need it, just copy-paste it into the terminal app.

Logged
Pages: [1]   Go Up