INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: High CPU Usage  (Read 4674 times)

Robert Joe

  • Junior Woodchuck
  • **
  • Posts: 51
High CPU Usage
« on: December 02, 2013, 10:41:29 am »

Is anyone seeing abnormally high CPU usage. I don't see this with other Linux music players on my system.

JRiver is using about 16% CPU - see %id is 81%. When I hit Stop Playing, the CPU usage does not go down until I select another view.

I7-4771, running Linux Mint 16 Cinnamon (Kernel 3.11.0-12-generic). I am only testing with a 9 album library test.

Let me know if you need any logs or want me to run a debug version for you.




Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41990
  • Shoes gone again!
Re: High CPU Usage
« Reply #1 on: December 02, 2013, 10:44:05 am »

Interesting.

I wonder if it could be analyzing audio as part of auto-import?  Does it settle down after a while?  Do only some views cause the CPU usage?
Logged
Matt Ashland, JRiver Media Center

Robert Joe

  • Junior Woodchuck
  • **
  • Posts: 51
Re: High CPU Usage
« Reply #2 on: December 02, 2013, 10:51:50 am »

It's only 9 albums and I have had it running for at least 6 hours of play time. I am leaving for work right now. What I will do is keep it on play all day and report back tonight.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13533
Re: High CPU Usage
« Reply #3 on: December 02, 2013, 12:40:37 pm »

Try right-clicking on where the spectrum analyser would be (above the playback position slider) and disabling the spectrum analyser to see home much difference that makes on your machine.
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: High CPU Usage
« Reply #4 on: December 02, 2013, 02:35:14 pm »

Wow I had noticed relatively high cpu usage (~35%) on an i7 2600K. I just disabled that spectrum analyzer and it drops by 50-60%.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13533
Re: High CPU Usage
« Reply #5 on: December 02, 2013, 05:47:22 pm »

Wow I had noticed relatively high cpu usage (~35%) on an i7 2600K. I just disabled that spectrum analyzer and it drops by 50-60%.
Many drawing changes coming in the build 19.0.85 posting momentarily.
Logged

Robert Joe

  • Junior Woodchuck
  • **
  • Posts: 51
Re: High CPU Usage
« Reply #6 on: December 02, 2013, 09:45:42 pm »

I disabled the Spectrum Analyzer and that fixed it :)
With JRiver playing I am now 97+ % IDLE. At most it is using 1% CPU.

I will also keep it running overnight and report back. With the Spectrum Analyzer on, it never made it through last night or today. It crashed some time.
Logged

Robert Joe

  • Junior Woodchuck
  • **
  • Posts: 51
Re: High CPU Usage
« Reply #7 on: December 02, 2013, 09:47:56 pm »

Also, the Specturm Analyzer was not working when enabled anyway - it was in a frozen state. Personally, I never use it - it is turned off on my Windows machines.
Logged

Robert Joe

  • Junior Woodchuck
  • **
  • Posts: 51
Re: High CPU Usage
« Reply #8 on: December 02, 2013, 10:07:23 pm »

I just installed MediaCenter-19.0.85.
Spectrum Analyzer works and when on, a 5 second sar sample shows 96.86% IDLE.
Spectrum Analyzer off, a 5 second sar sample shows 98.63% IDLE.

Good job Bob!
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7411
  • The color of Spring...
Re: High CPU Usage
« Reply #9 on: December 03, 2013, 10:05:46 am »

Yes, very good job indeed! :D
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

geier22

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 418
Re: High CPU Usage
« Reply #10 on: December 04, 2013, 05:57:50 pm »

When a song is played, the CPU usage with spectrum analyzers is 3-4% without 1-2%.
When I resizing the window, the CPU usage jumps to 14 to 15%. After the action it takes about another 20 - 30 seconds with the very high CPU usage. If the mouse touches in this time window, the window jumps with flickering somewhere on the monitor, or makes any undesired actions. It has improved nothing.

Copy - Paste is not possible. It seems as if this happens only within Media Center without the clipboard. Example:
I mark the artist in the list and copy it (it does not matter whether right-click or Ctrl+C) -> My clipboard is empty. But I can paste the copied item within Media Center anywhere. It's the same om inverse case.

MediaCenter 19.0..85-1.on OpenSUSE 13.1 x64
Logged
Debian Testing x64 (multiarch) Xfce
TEAC UD-H01 - Yamaha A-S1000 /
Midrange- Studiomonitore by FN
AsRock Z390 Extreme4- Intel Core i9 9900/ 32 GB Ram

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13533
Re: High CPU Usage
« Reply #11 on: December 04, 2013, 06:24:10 pm »

...
Copy - Paste is not possible. It seems as if this happens only within Media Center without the clipboard. Example:
I mark the artist in the list and copy it (it does not matter whether right-click or Ctrl+C) -> My clipboard is empty. But I can paste the copied item within Media Center anywhere. It's the same om inverse case.

MediaCenter 19.0..85-1.on OpenSUSE 13.1 x64
http://yabb.jriver.com/interact/index.php?topic=85544.msg584427#msg584427
Logged
Pages: [1]   Go Up