INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Problem with Downsampling  (Read 2857 times)

rmazzi

  • Recent member
  • *
  • Posts: 5
Problem with Downsampling
« on: January 03, 2014, 02:22:35 pm »

I am about half way into the trial period with JRiver media center for Mac, with the build posted at the top of the forum.  I have loaded JRiver on an older intel based iMAC (c. 2007) with Mountain Lion.  I have a USB connection to an Emotiva XDA-2 DAC.  The 96KHz FLAC files downsample to 48KHz.  I reset the options and DSD.  If i fiddle enough i can get it to not down sample, but i haven't found the right sequence to get it to work properly.  I am about to punt on JRiver and/or the DAC and/or the Mac implementation.  Any ideas on the problem?
Logged

bplexico

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 295
Re: Problem with Downsampling
« Reply #1 on: January 03, 2014, 03:12:17 pm »

What settings do you have under the following:

Tools->Audio->DSP & Output Format

Under the Sample Rate section do you have Output set to "No Change" for all inputs (save perhaps Greater than 192,000Hz)?

I see your DAC should be able to handle up to 24/192 via the USB input.

Logged
Mac Mini (16Gb memory, 2.3GHz i7, SSD), Synology NAS, MSB Analog DAC, Tubes, Cables, DeVore O/96s

rmazzi

  • Recent member
  • *
  • Posts: 5
Re: Problem with Downsampling
« Reply #2 on: January 08, 2014, 08:19:06 pm »

Sorry for the delay, been away for a while.  I set the sampling to 96 Mhz and 192 Mhz for 192 Mhz files (which i don't have any of).  i also tried setting it the no change option.  I have click around a bunch, restarted the DAC, iMAC, MC19 in every combination i can think of.  Occasionally, i can get an error message that sez my selected output doesn't match the device.  After that it stops down sampling.  I can't seem to recreate this reliably.
Logged

bplexico

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 295
Re: Problem with Downsampling
« Reply #3 on: January 09, 2014, 12:41:35 pm »

Try this with your DAC connected to your Mac, and MC not running:

Apple Menu -> System Preferences->Sound

Under the output Tab make sure you have selected your DAC.

Under the Sound Effects TAB, choose internal speakers.

Quit System Preferences

Next go to your Applications folder:

Open the Utilities Folder

Launch Audio Midi Setup

For Built in Output ensure your DAC is selected and set the format to the highest sample rate supported by your DAC, which I believe should be 192000 Hz.

Close Audio Midi Setup

Lastly do this:

Launch MC

Go to Tools->Options->Audio

Under Audio Device ensure your DAC is selected

Then under Device Settings try enabling Integer Mode and Open Device with Exclusive Access if these are not already enabled.

Click OK.

And then one final thing:

Tools->Options->Audio

DSP & Output Format

Under sample rate just set all values to "No change"

Click OK.

Now see if you still have the issue. Also I just have to ask, so don't be offended, are you certain the 96Khz FLAC files are 96Khz/ If you highlight one of these tracks what Bitrate is shown?

Only other thing I can think of is trying a different USB cable, just to eliminate all possibilities, or try plugging your USB cable into a different UCB port on the iMac.

Barr



Logged
Mac Mini (16Gb memory, 2.3GHz i7, SSD), Synology NAS, MSB Analog DAC, Tubes, Cables, DeVore O/96s

rmazzi

  • Recent member
  • *
  • Posts: 5
Re: Problem with Downsampling
« Reply #4 on: January 09, 2014, 07:59:14 pm »

Followed this script, but did not enable integer mode since i am running 10.8 and not 10.9.  It works!  The DAC displays the Khz rate and it shows 96 as expected and sounds like a 96 Khz file.  I think the Audio Midi utility was the key since this is where i can set the default value.  Thanks for the assist!
Logged

bplexico

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 295
Re: Problem with Downsampling
« Reply #5 on: January 09, 2014, 10:16:17 pm »

Hey! Glad to hear it worked out, now you can relax and enjoy the music.

Barr
Logged
Mac Mini (16Gb memory, 2.3GHz i7, SSD), Synology NAS, MSB Analog DAC, Tubes, Cables, DeVore O/96s
Pages: [1]   Go Up