INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Problem Importing Music Files to MC for MAC  (Read 1102 times)

xtaljo

  • Recent member
  • *
  • Posts: 5
Problem Importing Music Files to MC for MAC
« on: January 16, 2014, 09:54:46 am »

I am have a problem importing my music (FLAC and MP3) files from a portable HD (originally set up using a Windows laptop) into my new MacBook Air running MC for Mac 19.0.100.

I tried File - Library - Import - Clicked 'Import single folder' - Selected the music folder on the portable HD - Clicked 'Finish'.

The art work appears and the the left hand side of the screen says' Library now has 799 files'.  But the tracks only play if the portable HD remains plugged into the USB port.  If it is Ejected and unplugged then no tracks play and I get the following error msg.:

'Something wrong with playback.  File could not be found.  Check that the filename in the library matches the one on the disc.'

I tried changing the name of the Main Library in MC to 'Music' (the name used on theexternal HD) but it still did not work.

I like MC very much and hope I can solve this problem with some help so I can continue to use it on my new MAC.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13576
Re: Problem Importing Music Files to MC for MAC
« Reply #1 on: January 16, 2014, 10:22:41 am »

MC leaves the files in place, it doesn't copy them onto your computer. That is why you can't play them when you disconnect the drive.
iTunes by default copies the files into the Music/iTunes folder.
If you want to play the files with the drive disconnected just copy them into your Music folder, clear the previous files from your library and re-import (probably have to uncheck the option to ignore previous deleted files).
Logged

xtaljo

  • Recent member
  • *
  • Posts: 5
Re: Problem Importing Music Files to MC for MAC
« Reply #2 on: January 16, 2014, 02:33:42 pm »

Many thanks. That worked perfectly.
Logged
Pages: [1]   Go Up