INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: sample rate oddness with TC Impact Twin  (Read 6230 times)

FantasticoGrande

  • Recent member
  • *
  • Posts: 6
sample rate oddness with TC Impact Twin
« on: January 30, 2014, 11:35:04 pm »

I am having issues with songs and my DAC (TC Impact Twin).

When I switch to songs with different sample rates, play back is screwy. Slow speeds or too fast speeds.
Clearly a sample rate mismatch deal.
BUT, if I hit play, then stop real quick, then play again, then everything plays back fine.
When I check the DAC it acknowledges the change in bit rate, it just seems like there is that screwy delay/replay step to actually kick in the change.

Is there a way around this? Seems like it could be a bunch of things (mac settings, jriver settings, dac settings) or maybe it is just the way it is.
Any help or thoughts would be most welcome.

Here is my system. Intel Mac Pro, TC Impact Twin connected via firewire, latest version of Media Center.
Logged

geoffmartin

  • Member
  • *
  • Posts: 1
Re: sample rate oddness with TC Impact Twin
« Reply #1 on: May 15, 2014, 10:51:03 am »

I'm having exactly the same problem. However, no issues with a Fiio E17 on the same Mac.

-geoff
Logged

FantasticoGrande

  • Recent member
  • *
  • Posts: 6
Re: sample rate oddness with TC Impact Twin
« Reply #2 on: May 24, 2014, 02:23:15 am »

As long as I start and stop and start the album again everything works just fine.
Not handy for mixed bit rate playlists, but it works otherwise.
Logged

MartinG

  • Junior Woodchuck
  • **
  • Posts: 58
Re: sample rate oddness with TC Impact Twin
« Reply #3 on: May 25, 2014, 02:16:34 am »

I had the same problem in previous versions. It is not totally resolved but it's better now. Do you have the most recent version 131?
Logged

FantasticoGrande

  • Recent member
  • *
  • Posts: 6
Re: sample rate oddness with TC Impact Twin
« Reply #4 on: May 26, 2014, 10:40:49 pm »

Yup I have 131. I always keep up to date, but I still have to start and stop and start again for any change in bitrate.
I even tried changing latency settings on the TC Impact, but that made no difference.
Logged

jdubs

  • Junior Woodchuck
  • **
  • Posts: 86
Re: sample rate oddness with TC Impact Twin
« Reply #5 on: August 18, 2015, 10:46:13 am »

Yup I have 131. I always keep up to date, but I still have to start and stop and start again for any change in bitrate.
I even tried changing latency settings on the TC Impact, but that made no difference.

Hey guys, is this still an issue with the TC Impact Twin?

-Jim
Logged

jetski

  • Member
  • *
  • Posts: 3
Re: sample rate oddness with TC Impact Twin
« Reply #6 on: March 31, 2016, 12:43:48 pm »

Over 18 months later and this still seems to be a problem. Stop and start resolves it, but it is quite annoying. Does anyone have any more information regarding this?

Thanks,
Logged

Arindelle

  • Citizen of the Universe
  • *****
  • Posts: 2772
Re: sample rate oddness with TC Impact Twin
« Reply #7 on: April 01, 2016, 06:45:53 am »

I'm just fishing here,  but this an interface not a dedicated dac right?  I just googled it and I see it handles a choice of inputs. Maybe it is the Firewire connection. Try another like the optical Input .. you have spdif and coax. Possibly there could be a driver issue with Firewire? Maybe you have a DAW installed and there are some issues using the same output. Not sure what your Mac offers for digital outputs but it should have one of the three.
Logged

jetski

  • Member
  • *
  • Posts: 3
Re: sample rate oddness with TC Impact Twin
« Reply #8 on: April 01, 2016, 08:13:40 am »

I connect from a Mac mini via firewire for jriver media and via coax from a squeezebox classic. It does seem that jriver feed is the one that plays wrongly until stopped and restarted, then all is well. It is then fine, until a change of bitrate, usually switching to hi-res.

If I have a long enough lead, I could try the coax/optical route, or even a "better" quality firewire cable (don't have another long enough at the moment). I wonder if anyone else has tried this?

Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: sample rate oddness with TC Impact Twin
« Reply #9 on: April 01, 2016, 08:19:02 am »

This is posted in the MC19 forum.  MC19 is rather old now in the MC world.  Have you tried this with MC21 yet?

You can find the latest build of MC21 at the top of the MC21 forum here:

http://yabb.jriver.com/interact/index.php?board=45.0

Brian.
Logged
Pages: [1]   Go Up