INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Problems with playing songs with a sampling frequency greater than 48 kHz  (Read 2572 times)

geier22

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 419

I do not know if this problem is related to the ALSA driver for my sound card, or if this is a problem of MC. Maybe settings are wrong in the options, but I do not know what.

When I set:  Options -->Audio --> Advanced --> Auto configure output settings on Playback error : No

Mc does not play songs over 48 kHz.Error message: : See picture Playback-Problem

I set:   Options -->Audio --> Advanced --> Auto configure output settings on Playback error : Yes

with DSP Studio settings: Less than 44,1 kHz  --> 48 kHz
                                                            44,1 kHz  --> 48 kHz
                                                             all other ---> no Change

when I'm playing the 192/24 Song, MC changes the DSP Studio settings immediately. Everything is set to 48 kHz except 44.1 kHz.

Audiopath says:  48 kHz 32 bit 2 ch using ALSA (direct connection)

A song in the "Playing Now List" with 44.1 kHz now  skipped automatically to the next "playable" song.

when Double-Klick to his song, MC detekt ab Playback Problem:

Playback could not be started on the output "ALSA" using the Format 44.1. kHz 2 ch

A continuous playing of songs is only possible with the setting "everything on 48 kHz"

I have two installations of MC in Win7 and Win7 in Virtualbox (with ALSA as Host-Audio driver).

In both there are no problems with high-resolution songs, and no resampling.

MC 19.0.115 / OpenSuse 31.1
Logged
Debian Testing x64 (multiarch) Xfce
TEAC UD-H01 - Yamaha A-S1000 /
Midrange- Studiomonitore by FN
AsRock Z390 Extreme4- Intel Core i9 9900/ 32 GB Ram

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: Problems with playing songs with a sampling frequency greater than 48 kHz
« Reply #1 on: February 10, 2014, 06:16:42 pm »

You can't use the sysdefault: devices if you are looking to use different sample rates. The sysdefault: devices only support the sysdefault: sample rate (usually 48k).
You want the next device down in the list (front: ....).
Logged

geier22

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 419
Re: Problems with playing songs with a sampling frequency greater than 48 kHz
« Reply #2 on: February 11, 2014, 12:29:04 am »

Ok - Thanks for the tip. I have tried all devices without "surround". The only device that is working properly is the
"Front: Card = Audiophhile 192, DEV = 0".
This Description I find a little bit strange. But no matter - it works.

THX bob :D
Logged
Debian Testing x64 (multiarch) Xfce
TEAC UD-H01 - Yamaha A-S1000 /
Midrange- Studiomonitore by FN
AsRock Z390 Extreme4- Intel Core i9 9900/ 32 GB Ram

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13613
Re: Problems with playing songs with a sampling frequency greater than 48 kHz
« Reply #3 on: February 11, 2014, 09:04:54 am »

Ok - Thanks for the tip. I have tried all devices without "surround". The only device that is working properly is the
"Front: Card = Audiophhile 192, DEV = 0".
This Description I find a little bit strange. But no matter - it works.

THX bob :D
Glad it worked!
ALSA device naming is a little chaotic, however what you see is what the system is giving us.

Logged
Pages: [1]   Go Up