INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Access denied to download new build  (Read 2117 times)

newbluesman

  • Recent member
  • *
  • Posts: 38
Access denied to download new build
« on: June 30, 2014, 07:41:33 am »

Hi.  I downloaded and installed 129 back in May and have been using it since then without difficulty.  On seeing that registration was now possible with 143, I decided to update and use the key I bought on May 7.  But when I ran "wget http://files.jriver.com/mediacenter/channels/v19/latest/MediaCenter-19.0.14X.deb" for 141, 143 and 144 I got a message that I was denied access, so I couldn't download any of them.

Do I have to remove 129 before downloading the latest build? Did I not use the correct command for Ubuntu 14? Or am I supposed to get the new builds a different way?  Thanks!

David
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10724
Re: Access denied to download new build
« Reply #1 on: June 30, 2014, 07:43:36 am »

You'll get a access denied message when you use a wrong address.
Use the address directly from the release post, they work just fine.
Logged
~ nevcairiel
~ Author of LAV Filters

aoqw76

  • Galactic Citizen
  • ****
  • Posts: 257
Re: Access denied to download new build
« Reply #2 on: June 30, 2014, 05:27:01 pm »

I run a script to install a new version, just to speed things up a bit. The "wget" bit is exactly as you have it, albeit using a passed parameter. Save this in a script e.g called "upgrademc", make it executable, then you can run it like this> upgrademc 146

Code: [Select]
#!/bin/bash
fname="MediaCenter-19.0.$1.deb"
download="http://files.jriver.com/mediacenter/channels/v19/latest/$fname"
cd ~/Downloads
rm -rv MediaCenter*$1*
wget -U Mozilla/5.0 $download
if [ -f $fname ]
then
pkill mediacenter
sudo dpkg -i $fname
nohup /usr/bin/mediacenter19 &
else
echo "download of" $fname "failed"
fi
Logged
xubuntu lts 14.04 32 bit, running mc22.0.36 as anything later doesn't work properly over vnc. using linux mc22 as media server to windows mc22 last version / jremote on ipad.
I am the owner / sole admin for www.cyrusunofficial.co.uk ("fan" site for Cyrus Audio hifi)

newbluesman

  • Recent member
  • *
  • Posts: 38
update accomplished
« Reply #3 on: July 01, 2014, 08:10:39 am »

Thanks, aoqw76! But I solved it the easy way and used the correct build number - I simply hadn't noticed that we're up to 146 and was trying to update to 144.  When that didn't work, I went the wrong way and tried earlier builds.

Now all I have to do is get the registration to work and I'm all set. I entered my key as instructed in the dialogue box and got a response that it wasn't recognized. So I'll try running the commands referenced in another thread:

cd /etc/ssl/certs
ln -s /etc/pki/ca-trust/extracted/pem/tls-ca-bundle.pem ca-certificates.crt

I'll pursue the mjr route if that doesn't work - there was an mjr file attached to the email I received with my registration key and info.

David
Logged
Pages: [1]   Go Up