INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Licence not working  (Read 1869 times)

cjemerson

  • Member
  • *
  • Posts: 3
Licence not working
« on: August 09, 2014, 05:53:25 am »

I've been using MC19 on Linux Mint for some time but the 'Trial' timed out today. I did the good thing, supported development by buying a licence, but it simply wont take it - now MC won't run at all. I've uninstalled, reinstalled but still nothing. I'm running Mint 17 KDE. Any help please as now I have no music. Back to the stone age Logitech Media Server web interface I guess.
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71486
  • Where did I put my teeth?
Re: Licence not working
« Reply #1 on: August 09, 2014, 06:42:19 am »

Thanks for your purchase.  You may need to install the latest build from the top of this forum.  It supports an MC20 license, which is what you probably have.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5177
  • "Linux Merit Badge" Recipient
Re: Licence not working
« Reply #2 on: August 10, 2014, 12:59:35 am »

I've been using MC19 on Linux Mint for some time but the 'Trial' timed out today. I did the good thing, supported development by buying a licence, but it simply wont take it - now MC won't run at all. I've uninstalled, reinstalled but still nothing. I'm running Mint 17 KDE. Any help please as now I have no music. Back to the stone age Logitech Media Server web interface I guess.

If you still can't register with the latest version, you may need to do some additional configuration to register using the JRiver GUI interface: http://yabb.jriver.com/interact/index.php?topic=89893.0

There is also a command-line option that does not require any additional config if you have an .mjr file that isn't stale (JRiver sends you one during registration). Just run the following command in the directory where the .mjr file is, and replace the X's and Y's with the correct numbers from your specific .mjr file:

Code: [Select]
mediacenter19 /RestoreFromFile MediaCenterXXLinux-YYYYYY.mjr
See this thread for more info: http://yabb.jriver.com/interact/index.php?topic=89884.0
Logged

cjemerson

  • Member
  • *
  • Posts: 3
Re: Licence not working
« Reply #3 on: August 10, 2014, 06:17:17 am »

Thanks. The file i was sent when registering was 'Media Center20 Linux-261765.bin', not a .mjr file. I tried renaming it but  when running the command suggested I get 'mediacenter19 command not known'. Suggestions would be welcomed - thanks.
Logged

cjemerson

  • Member
  • *
  • Posts: 3
Re: Licence not working
« Reply #4 on: August 10, 2014, 07:01:32 am »

Ok... I uninstalled again, reinstalled and ran the command on the bin file i was sent - this time I got a message that the licence key had been restored. When opening the application I got an icon in the panel but couldn't actually open Mediacenter.

I uninstalled version 19.0.160 and  reinstalled version 19.0.146, which had been working (until the trial ended). This time the app opened correctly and recognised that it is a registered version.

Thanks for the suggestions.
Logged
Pages: [1]   Go Up