INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Install libgtk2.0-0:i386 on Wheezy 64bit  (Read 4262 times)

mcollier

  • World Citizen
  • ***
  • Posts: 100
Install libgtk2.0-0:i386 on Wheezy 64bit
« on: August 17, 2014, 09:56:56 am »

I am finding that getting libgtk2.0-0:i386 installed on my Wheezy 64bit system is non-trivial.

Here's what I'm seeing:
Code: [Select]
root@debian:/home/user# apt-get install libgtk2.0-0:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.4.0) but it is not going to be installed
                    Recommends: hicolor-icon-theme:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

If I try to manually install libcups2:i386 here's what I get:
Code: [Select]
root@debian:/home/user# apt-get install libcups2:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  hp-ppd hyphen-en-us libasound2:i386 libfs6 libstdc++6:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386
  task-desktop x11-apps x11-session-utils x11-xfs-utils xinit xorg
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcj-4.7-base gcj-4.7-jre gcj-4.7-jre-headless gcj-4.7-jre-lib gcj-jre gcj-jre-headless icedtea-7-jre-jamvm libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libcomerr2:i386 libcups2 libdbus-1-3:i386 libgcj-common libgcj13 libgcj13-awt
  libgcrypt11:i386 libgnutls26:i386 libgpg-error0:i386 libgssapi-krb5-2:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386
  libkrb5support0:i386 libp11-kit0:i386 libtasn1-3:i386 openjdk-7-jre openjdk-7-jre-headless zlib1g:i386
Suggested packages:
  fastjar gcj-4.7-jdk gcj-jdk libgcj13-dbg rng-tools:i386 krb5-doc:i386 krb5-user:i386 icedtea-7-plugin sun-java6-fonts
  fonts-ipafont-gothic fonts-ipafont-mincho ttf-wqy-microhei ttf-wqy-zenhei ttf-indic-fonts
The following packages will be REMOVED:
  aisleriot alacarte ant ant-optional baobab bluez-cups brasero caribou caribou-antler cheese chromium cups cups-bsd cups-client
  cups-filters cups-pk-helper cups-ppdc dconf-tools default-jre default-jre-headless empathy eog evince evolution
  evolution-data-server evolution-plugins evolution-webcal file-roller gcalctool gcr gdebi gdm3 gedit gedit-plugins ghostscript
  ghostscript-cups gimp gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-clutter-gst-1.0 gir1.2-evince-3.0 gir1.2-gcr-3 gir1.2-gkbd-3.0
  gir1.2-gnomebluetooth-1.0 gir1.2-goa-1.0 gir1.2-gtk-3.0 gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0 gir1.2-gucharmap-2.90
  gir1.2-javascriptcoregtk-3.0 gir1.2-mutter-3.0 gir1.2-panelapplet-4.0 gir1.2-peas-1.0 gir1.2-rb-3.0 gir1.2-totem-1.0
  gir1.2-vte-2.90 gir1.2-webkit-3.0 gir1.2-wnck-3.0 gkbd-capplet glchess glines gnect gnibbles gnobots2 gnome gnome-applets
  gnome-bluetooth gnome-color-manager gnome-contacts gnome-control-center gnome-core gnome-dictionary gnome-disk-utility
  gnome-documents gnome-font-viewer gnome-games gnome-icon-theme gnome-icon-theme-extras gnome-icon-theme-symbolic gnome-keyring
  gnome-media gnome-nettool gnome-online-accounts gnome-orca gnome-packagekit gnome-panel gnome-power-manager gnome-screensaver
  gnome-screenshot gnome-session gnome-session-bin gnome-session-fallback gnome-settings-daemon gnome-shell gnome-shell-extensions
  gnome-sudoku gnome-sushi gnome-system-log gnome-system-monitor gnome-terminal gnome-themes-standard gnome-tweak-tool
  gnome-user-guide gnome-user-share gnomine gnotravex gnotski gtali gtk2-engines gucharmap hamster-applet hplip iagno
  icedtea-6-jre-cacao icedtea-6-jre-jamvm icedtea-netx libavahi-ui-gtk3-0 libbonoboui2-0 libbrasero-media3-1 libcanberra-gtk-module
  libcanberra-gtk0 libcanberra-gtk3-0 libcanberra-gtk3-module libcaribou-gtk3-module libcaribou0 libchamplain-0.12-0
  libchamplain-gtk-0.12-0 libcheese-gtk21 libcheese3 libclutter-1.0-0 libclutter-gst-1.0-0 libclutter-gtk-1.0-0
  libclutter-imcontext-0.1-0 libclutter-imcontext-0.1-bin libcluttergesture-0.0.2-0 libcupscgi1 libcupsdriver1 libcupsfilters1
  libcupsimage2 libcupsmime1 libcupsppdc1 libedata-book-1.2-13 libedataserverui-3.0-1 libepc-ui-1.0-3 libescpr1 libevdocument3-4
  libevolution libevview3-3 libfolks-eds25 libgail-3-0 libgail-common libgail18 libgcr-3-1 libgdict-1.0-6 libgdu-gtk0 libgimp2.0
  libglade2-0 libgnome-bluetooth10 libgnome-desktop-3-2 libgnome-media-profiles-3.0-0 libgnomecanvas2-0 libgnomekbd7 libgnomeui-0
  libgoa-1.0-0 libgs9 libgtk-3-0 libgtk-3-bin libgtk-vnc-2.0-0 libgtk2.0-bin libgtkhtml-4.0-0 libgtkhtml-4.0-common
  libgtkhtml-editor-4.0-0 libgtkmm-3.0-1 libgtksourceview-3.0-0 libgucharmap-2-90-7 libgweather-3-0 libmetacity-private0a libmutter0
  libmx-1.0-2 libnautilus-extension1a libnm-gtk0 libpanel-applet-4-0 libpeas-1.0-0 librhythmbox-core6 libsane-hpaio libseed-gtk3-0
  libspectre1 libtotem0 libunique-3.0-0 libvte-2.90-9 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwnck-3-0 libyelp0 lightsoff mahjongg
  metacity mousetweaks nautilus nautilus-sendto nautilus-sendto-empathy network-manager-gnome notification-daemon openjdk-6-jre
  openjdk-6-jre-headless openjdk-6-jre-lib policykit-1-gnome printer-driver-c2050 printer-driver-c2esp printer-driver-escpr
  printer-driver-foo2zjs printer-driver-gutenprint printer-driver-hpcups printer-driver-pnm2ppa printer-driver-postscript-hp
  printer-driver-ptouch printer-driver-sag-gdi printer-driver-splix pstoedit python-aptdaemon.gtk3widgets python-gnome2 python-gtk2
  python-notify python-pyatspi python-pyatspi2 python-wnck quadrapassel rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugins
  rygel-preferences seahorse shotwell simple-scan software-properties-gtk sound-juicer swell-foop task-gnome-desktop
  task-print-server totem totem-plugins tracker-gui transmission-gtk vinagre vino xdg-user-dirs-gtk yelp zenity
The following NEW packages will be installed:
  gcj-4.7-base gcj-4.7-jre gcj-4.7-jre-headless gcj-4.7-jre-lib gcj-jre gcj-jre-headless icedtea-7-jre-jamvm libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libcomerr2:i386 libcups2:i386 libdbus-1-3:i386 libgcj-common libgcj13 libgcj13-awt
  libgcrypt11:i386 libgnutls26:i386 libgpg-error0:i386 libgssapi-krb5-2:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386
  libkrb5support0:i386 libp11-kit0:i386 libtasn1-3:i386 openjdk-7-jre openjdk-7-jre-headless zlib1g:i386
The following packages will be upgraded:
  libcups2
1 upgraded, 29 newly installed, 248 to remove and 58 not upgraded.
Need to get 70.1 MB of archives.
After this operation, 528 MB disk space will be freed.
Do you want to continue [Y/n]?

I don't think this is what I want to do. Any suggestions?
Logged

mattkhan

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3970
Re: Install libgtk2.0-0:i386 on Wheezy 64bit
« Reply #1 on: August 17, 2014, 03:24:05 pm »

The error message (E: Unable to correct problems, you have held broken packages) suggests your system is currently in the midst of a failed upgrade. Are you? aptitude often gives better error messages so perhaps see what aptitude install says will give you a pointer.

To see held packages you can use

dpkg --get-selections | grep hold
Logged

mcollier

  • World Citizen
  • ***
  • Posts: 100
Re: Install libgtk2.0-0:i386 on Wheezy 64bit
« Reply #2 on: August 17, 2014, 03:55:27 pm »

Thanks for the suggestion.  I am not in the middle of a failed upgrade.

dpkg --get-selections | grep hold

produces no results.

I had previously run 'apt-get clean' to address that issue as well.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5177
  • "Linux Merit Badge" Recipient
Re: Install libgtk2.0-0:i386 on Wheezy 64bit
« Reply #3 on: August 17, 2014, 05:00:07 pm »

It looks like the conflicting packages to be removed in your second quote are almost exclusively from the gnome group/metapackage or are from gnome's family of dependencies.  Are you running a backport or custom build of a more modern version of Gnome (i.e. >3.4)?  Or maybe some other backports?  That can sometimes create these kinds of issues when the backport has newer dependencies which conflict with the "stable" dependencies.  If that's not the issue, I assume you've tried the obvious things like updating your package lists using "upgrade" or "dist-upgrade"?  

FWIW, I just did an install of Debian Jessie/testing 64-bit on my server last week, and I had no problems installing the dependencies for both gnome and mc.   I'm not suggesting a re-install as a solution for you necessarily, but rather to note that with fully updated package lists and dependencies I was able to install the referenced lib, and everything was able to coexist with no problems on a 64-bit Debian build (albeit not Wheezy).

Maybe somebody who is running Wheezy with Gnome can weigh in?
Logged
Pages: [1]   Go Up