INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: JRiver Media Center 20.0.50 for Debian  (Read 5535 times)

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13524
JRiver Media Center 20.0.50 for Debian
« on: December 19, 2014, 02:23:13 pm »

http://files.jriver.com/mediacenter/channels/v20/latest/MediaCenter-20.0.50.deb

20.0.50 (12/19/2014)

1. Fixed: Mouse pointer changes on hover over actions work now (like resize, change split, etc).

20.0.49 (12/16/2014)

1. Changed: Upgraded to cURL library 7.39
2. Fixed: Numeric keypad characters that were being ignored.
3. Fixed: GUI, disabling input in background windows.
4. Changed: GUI, greatly increased speed in operations inside of MC's windows. Fixes playlist lists, reduces CPU usage.
5. Fixed: Convert format when changing the destination path.

20.0.46 (12/05/2014) (Changes from the main branch)

20.0.43 (11/25/2014) (Changes from the main branch)

1. Fixed: Clearing "Now playing" from a remote will not pop up a confirmation box now.

20.0.42 (11/21/2014) (Changes from the main branch)

1. Fixed: DLNA: MC as renderer, when receiving a SetNextAVtransportURI, MC was allowing the playlist to grow beyond 2 items which is incorrect. This caused playlist sync issues.
2. Fixed: DLNA: MC as controller, fix bug in event send when changing playlist position 1.
3. Fixed: DLNA: MC as controller timing issue, make sure the first track is playing (for at least 5 seconds) before doing the SetNextAVTransportURI function.
4. Fixed: DLNA: MC as controller, when playlist position current +1 changes send a new SetNextAVTransportURI to devices that support it.
5. Fixed: The change from 20.0.31 (Back out library server hiding when the library is empty introduced in 19.0.71) missed the library server visibility (it was showing the DLNA servers).

20.0.33 (11/10/2014)

1. NEW: Support for thumbnail grabbing from video files.
2. Changed: Matrix height correction when using gnu unifont (it's got a bug in it's size specification).
3. Changed: For SSL network operations, use TLSv1 instead of SSLv3.
4. NEW: Support for Shorten and Opus audio playback using the new JR playback engine (using FFmpeg).

20.0.31-1 (11/1/2014)

1. There was something off about that last upload build (version number was wrong for one). Replaced with 20.0.31-1

20.0.31 (10/31/2014)

1. Happy Halloween  ;) Just changes from the main branch.

20.0.27 (10/24/2014)

1. Fixed: Filesystem character problems in Rename, Move and Copy files.
2. Changed: Added hinting to window creation to try to get the window manager to move and resize windows in larger increments.
3. Fixed: CPU usage, especially during the drawing of the Spectrum Analyzer during playback, bug introduced in 20.0.22

20.0.25 (10/16/2014)

1. Changed: More UI changes. Extra desktop hinting on window, title bar and icon creation. Suspend desktop hinting when moving or resizing the root window. Attempt to fix initial window placement issue. Needs testing.

20.0.23 (10/13/2014)

1. Changed: More UI changes. Needs testing.

20.0.22 (10/9/2014)

1. Fixed: Video Playback crashed on stop when playing from a library server.
2. NEW: If using the system volume control and there is no mixer for the PCM device, we'll fall back to using the Master mixer for the device.
3. Changed: UI fixes. Startup position and position of popup windows should be stable now. This includes the controls in fullscreen video mode.

20.0.20 (10/2/2014)

1. Fixed: https protocol broken in 20.0.18
2. Changed: Switched to gnutls from openssl for https support because of a bug in the openssl static libs that prevented some websites certificates from being verified (i.e. twitter)

20.0.18 (9/26/2014)

1. Fixed: JRWorker segfaulting occasionally prevented some file types from being recognized.
2. Fixed: MediaCenter also occasionally segfaulted on exit.

20.0.17 (9/19/2014)

1. NEW: Implemented the file "locate" function.
2. Fixed: Menu items that open a URL in a browser.
3. Fixed: Disabled menu items unsupported on linux.
4. Fixed: Default for managing links changed to external browser.
5. Changed: possibly more ability to play Internet streams. Needs testing.

20.0.16 (9/16/2014)

1. Fixed: Series and Season cover art downloaded to the wrong folders.
2. NEW: Video playback supports playing from a library server.
3. Fixed: Last.fm scrobbling.

20.0.15 (9/12/2014)

1. Fixed: Fullscreen video playback is functional.
2. Changed: The video renderer uses VSYNC if available in the graphics driver.

20.0.13 (9/8/2014)

1. Fixed: Corrected the latency calculation for the ALSA output.
2. NEW: Video support.
Logged

tlcmd

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 261
  • nothing more to say...
License Installation Problem, help, please!!
« Reply #1 on: December 21, 2014, 04:15:47 pm »

I have just downloaded and installed MC 20.0.50 onto my Linux Mint Debian Edition. The previous versions of MC 19 and MC20 for Linux worked fine. After installing MC20.0.50, when I try to open MC 20, I get a message that my trial has expired. So, I go back to my MC 20 license and install as directed. I get the message that the license is installed into MC 20, and MC 20 opens and plays. But when I close MC20, I cannot re-open it, but instead get the same message that my trial has expired. I am using the license I received from Deanna Manns on 8/11/14 which matches the MC 20 license I received today from buy-button@jriver.com.

To reiterate briefly:
I cannot open MC 20
When I reinstall the proper license, I get the message that the license is installed. And when I go to the hep section the license is installed to me.
MC20 opens and plays
However when I close MC20 I cannot reopen it without reinstalling the license.
I have gone through this routine several times now.
Help, please.
tlcmd

Help, please
Logged

InflatableMouse

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3978
Re: JRiver Media Center 20.0.50 for Debian
« Reply #2 on: December 22, 2014, 02:48:55 am »

Could you try this?

Make a library backup, File, Library, Backup Library.
Close MediaCenter
Open a terminal, rename the '~/.jriver' directory to 'jriver-old' or something similar.
Start MediaCenter. A new .jriver dir will be created and all your settings will be reset.
Restore your license and see if it sticks. Close and start MC a couple of times.
If it sticks, restore your library: File, Library, Restore Library. FInd the backup you made in step one.

See if that works.
Logged

linuxdancer

  • Recent member
  • *
  • Posts: 14
Re: JRiver Media Center 20.0.50 for Debian
« Reply #3 on: December 22, 2014, 09:45:59 am »

Thanks for bringing the hovering mouse back!  Just one nit pick thing on it, the icon for the upper left and lower right has the correct orientation facing "\" .  But the upper right and lower left also face the same direction and actually should face "/" 

Thanks!
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13524
Re: JRiver Media Center 20.0.50 for Debian
« Reply #4 on: December 22, 2014, 10:26:21 am »

Thanks for bringing the hovering mouse back!  Just one nit pick thing on it, the icon for the upper left and lower right has the correct orientation facing "\" .  But the upper right and lower left also face the same direction and actually should face "/" 

Thanks!
I'm using the base X11 cursors. In that set I didn't find one that faces the other way.
I know there are better ones and the various window managers alter them and I suspect the DM may as well.
Probably will play with this a bit when the time permits..
Logged

tlcmd

  • Regular Member
  • Galactic Citizen
  • ****
  • Posts: 261
  • nothing more to say...
Re: JRiver Media Center 20.0.50 for Debian
« Reply #5 on: December 22, 2014, 01:04:36 pm »

Of interest, when I finally re-entered my original install key for MC20, it finally "took", but reverted my MC 20.0.50 back to MC 20.0.49. Can anyone explain this?? I think I'll await the next update after 20.0.50 before updating again. Or at least wait until after the holidays.

All y'all have a very Merry Christmas!! And enjoy this number by one of the International Barbershop Chorus Champions of 150 men:

https://www.youtube.com/watch?v=YB8H56sU98c
Logged

audiolover

  • Junior Woodchuck
  • **
  • Posts: 93
Re: JRiver Media Center 20.0.50 for Debian
« Reply #6 on: December 24, 2014, 04:38:45 am »

When trying to install on Debian XFCE I get the error:

dpkg: unrecoverable fatal error, aborting:
 reading files list for package 'libfile-mimeinfo-perl': Input/output error

Any ideas?
Logged

UdoS

  • Regular Member
  • World Citizen
  • ***
  • Posts: 217
  • User
Re: JRiver Media Center 20.0.50 for Debian
« Reply #7 on: December 28, 2014, 11:47:17 am »

Open a playlist an leave the focus in the action window causes the screen not to refresh. Moving the focus out of the action window refreshes the screen instantly.
Logged
Udo

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13524
Re: JRiver Media Center 20.0.50 for Debian
« Reply #8 on: January 02, 2015, 02:21:55 pm »

When trying to install on Debian XFCE I get the error:

dpkg: unrecoverable fatal error, aborting:
 reading files list for package 'libfile-mimeinfo-perl': Input/output error

Any ideas?

Sounds like an I/O error on your hard drive in the apt package lists directory.
Logged

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: JRiver Media Center 20.0.50 for Debian
« Reply #9 on: January 04, 2015, 07:16:44 am »

Hello,

MC segfaults several times in a day on a track change (manual or not). Issue seems coming from DSP.
In DSP, I only use "Volume Leveling" and "Equalizer" features.

My setup:
-Hard: Intel Nuc + USB V-DAC II
-OS: Debian Wheezy 32bits (no gui)
-Soft: JRiver 20.0.50
-Remotes: jremote (iphone), eos (Nexus HD)

Last 3 segfault are:
[ 4710.799855] mediacenter20[4082]: segfault at 0 ip a7cddb5c sp a5ca06a0 error 4 in libdsp_Main.so[a7c7e000+2f3000]
[ 9018.407876] mediacenter20[4655]: segfault at 0 ip b46aab5c sp bfb9de60 error 4 in libdsp_Main.so[b464b000+2f3000]
[ 2382.564420] mediacenter20[3559]: segfault at 0 ip b46d4b5c sp aa9b76a0 error 4 in libdsp_Main.so[b4675000+2f3000]

Furthermore I noticed DSP profiles are not loading at all with Linux version. So the feature that makes equalizer changing with the DSP tag won't work. Worse, profiles can't be delete from MC. It has to be done manually in the "User Settings.ini" file.
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

UdoS

  • Regular Member
  • World Citizen
  • ***
  • Posts: 217
  • User
Re: JRiver Media Center 20.0.50 for Debian
« Reply #10 on: January 05, 2015, 05:53:23 am »

Hi,
MC is getting better and better, but always I see an old guy back: Windows will open in then background. This sucks, especially working with the database and in full screen mode. (Some windows work normal, some don't)
Logged
Udo

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: JRiver Media Center 20.0.50 for Debian
« Reply #11 on: January 05, 2015, 12:55:37 pm »

Hi,
MC is getting better and better, but always I see an old guy back: Windows will open in then background. This sucks, especially working with the database and in full screen mode. (Some windows work normal, some don't)

It is better but there is a lot to do...

25 segfaults in one day. See attachement.

About error 4, I think it is related to "Volume Leveling" in DSP because I disabled this feature and now I only meet error 14 that's far less frequently than error 4.
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13524
Re: JRiver Media Center 20.0.50 for Debian
« Reply #12 on: January 05, 2015, 01:56:39 pm »

It is better but there is a lot to do...

25 segfaults in one day. See attachement.

About error 4, I think it is related to "Volume Leveling" in DSP because I disabled this feature and now I only meet error 14 that's far less frequently than error 4.
I can't duplicate your issue. You haven't provided much information.
What file types?
What are the audio settings for track change?
What is your Audio device?
Are you running Debian Wheezy i386? (the supported distro)

Logged

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: JRiver Media Center 20.0.50 for Debian
« Reply #13 on: January 05, 2015, 03:00:03 pm »

Hi Bob,

Yes I am running the support distro.

My setup:
-Hard: Intel Nuc + USB V-DAC II
-OS: Debian Wheezy 32bits (no gui)
-Soft: JRiver 20.0.50
-Remotes: JRemote (iphone), eos (Nexus HD)

I wrote more info two posts at the top, with MC attached log for error 4.
The file types are primarily flac, and few mp3.
Files are stored in a nas and shared with NFSv4 to the Nuc.
I added screenshots with the audio settings.
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13524
Re: JRiver Media Center 20.0.50 for Debian
« Reply #14 on: January 05, 2015, 03:42:15 pm »

Hi Bob,

Yes I am running the support distro.

I wrote more info two posts at the top, with MC attached log for error 4.
The file types are primarily flac, and few mp3.
Files are stored in a nas and shared with NFSv4 to the Nuc.
I added screenshots with the audio settings.

Can you change the audio track change settings to "gapless" and uncheck the don't play silence box. This has a subtle effect on how the audio device is opened/closed.

As for the NFS mount, what is the mountpoint?
Does the issue happen with only the flac files or with both flac and mp3?

Logged

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: JRiver Media Center 20.0.50 for Debian
« Reply #15 on: January 05, 2015, 03:56:42 pm »

Can you change the audio track change settings to "gapless" and uncheck the don't play silence box. This has a subtle effect on how the audio device is opened/closed.

Done!

The mount point is /mnt/music.

I can't say if the issue happens with mp3 file type but it does with flac for sure. Most of my favorites albums are in flac, so I listen more flac files than mp3 files.
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13524
Re: JRiver Media Center 20.0.50 for Debian
« Reply #16 on: January 06, 2015, 10:59:17 am »

Done!

The mount point is /mnt/music.

I can't say if the issue happens with mp3 file type but it does with flac for sure. Most of my favorites albums are in flac, so I listen more flac files than mp3 files.
Did the track change settings make a difference?
Logged

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: JRiver Media Center 20.0.50 for Debian
« Reply #17 on: January 06, 2015, 11:17:57 am »

Yes error 4 still happens when "volume leveling" is enabled (maybe less often than before the changes). I got error 14 (few times) and 15 (2 times) before and after changes.

I tried something else, I enabled "playing from memory". I read it was not useful when using nas so I stopped using it but when enabled error 14 and 15 don't happen anymore.

In summary:

playing from memory enabled + volume leveling disabled = 0 segfault for 8 hours of playback

playing from memory enabled + volume leveling enabled = segfaults with error 4 in libdspMain.so

playing from memory disabled + volume leveling disabled = few segfaults with error 14 and very few with error 15
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13524
Re: JRiver Media Center 20.0.50 for Debian
« Reply #18 on: January 06, 2015, 01:59:39 pm »

Yes error 4 still happens when "volume leveling" is enabled (maybe less often than before the changes). I got error 14 (few times) and 15 (2 times) before and after changes.

I tried something else, I enabled "playing from memory". I read it was not useful when using nas so I stopped using it but when enabled error 14 and 15 don't happen anymore.

In summary:

playing from memory enabled + volume leveling disabled = 0 segfault for 8 hours of playback

playing from memory enabled + volume leveling enabled = segfaults with error 4 in libdspMain.so

playing from memory disabled + volume leveling disabled = few segfaults with error 14 and very few with error 15

Very odd since I can't reproduce your issue.
Have you tried a memory test?
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13524
Re: JRiver Media Center 20.0.50 for Debian
« Reply #19 on: January 06, 2015, 02:56:09 pm »

Hi,
MC is getting better and better, but always I see an old guy back: Windows will open in then background. This sucks, especially working with the database and in full screen mode. (Some windows work normal, some don't)
Any particular pattern to this?
Particular windows, certain order?
Logged

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: JRiver Media Center 20.0.50 for Debian
« Reply #20 on: January 06, 2015, 03:38:14 pm »

Have you tried a memory test?

Yes I did and it's fine. No error to report.

To clarify the situation:
In my case, check "playing from memory" helps. It solves the error 14 and 15, which is fine. But it doesn't explain why it segfaults when playing files directly from the NAS.

If in addition I disable "Volume leveling", then the error 4 stops, making JRiver very stable.
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5177
  • "Linux Merit Badge" Recipient
Re: JRiver Media Center 20.0.50 for Debian
« Reply #21 on: January 06, 2015, 03:47:12 pm »

Any particular pattern to this?
Particular windows, certain order?

One window I can always get to "pop under" is the final confirmation dialog for "Sync Library."  If I manually try to sync a linux client, it will show the "sending changes to the server" dialog, but the "Local Library Has Been Synced With the Server" will always pop under (either under the main window, or under the "sending changes" dialog). 
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13524
Re: JRiver Media Center 20.0.50 for Debian
« Reply #22 on: January 06, 2015, 03:51:03 pm »

One window I can always get to "pop under" is the final confirmation dialog for "Sync Library."  If I manually try to sync a linux client, it will show the "sending changes to the server" dialog, but the "Local Library Has Been Synced With the Server" will always pop under (either under the main window, or under the "sending changes" dialog). 
Ok, I think I've found something that may solve this. It will be in the next build.
Logged

UdoS

  • Regular Member
  • World Citizen
  • ***
  • Posts: 217
  • User
Re: JRiver Media Center 20.0.50 for Debian
« Reply #23 on: January 07, 2015, 08:26:37 am »

Any particular pattern to this?
Particular windows, certain order?

Hi Bob,

after I did a kernel-update, the problem is gone. What ever I did, I can't reproduce it. So I assume it is fixed.
Logged
Udo

martinmopar

  • Recent member
  • *
  • Posts: 5
Re: JRiver Media Center 20.0.50 for Debian
« Reply #24 on: January 08, 2015, 06:11:51 am »

MC20 audio works great on UbunstuStudio! some tweaks and tricks to get the sound right, but since a studio is not a regular setup I suspect it will always be like that. the sound is amazing with audiofiles up to 4-5000kbps, nice work folks! however, when I tick detach display/Ctrl+6 the display-window sticks at center and over the MC20 window, no edges of any type and can't be moved, resized or anything. trying to play video actually works for about 2 seconds (in the small attached display) then crash, segfault. happens with all video files, other programs running/not running, Mplayer plays the same files without problem so at least I know the setup can handle video. any ideas on this?
Logged
Pages: [1]   Go Up