INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2   Go Down

Author Topic: Playback stop when exiting even with server running  (Read 15608 times)

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Playback stop when exiting even with server running
« on: January 09, 2015, 08:51:21 pm »

I recently started using server mode with JRemote as my primary control method. I used to use Theaterview with a handheld remote. I have server set to start with Windows now.

Occassionally I launch the main JRiver front end and when I exit my playback stops. Server is still running so that is not the issue. I can't seem to find a setting to control this behavior but perhaps it is buried in a menu that I missed.

Any suggestions?
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71286
  • Where did I put my teeth?
Re: Playback stop when exiting even with server running
« Reply #1 on: January 10, 2015, 02:18:06 am »

If you want playback to continue, don't exit MC on the client side.
Logged

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #2 on: January 10, 2015, 09:40:13 am »

Is there no setting I can make somewhere for playback to continue since the server is still running?  I would rather leave my HTPC with just server running most of the time.
Logged

tyler69

  • Citizen of the Universe
  • *****
  • Posts: 946
Re: Playback stop when exiting even with server running
« Reply #3 on: January 10, 2015, 10:00:29 am »

+1
Logged

Dr Tone

  • World Citizen
  • ***
  • Posts: 164
Re: Playback stop when exiting even with server running
« Reply #4 on: January 11, 2015, 01:56:33 pm »

+2

This has been an issue for as long as I can remember.
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41895
  • Shoes gone again!
Re: Playback stop when exiting even with server running
« Reply #5 on: January 13, 2015, 11:00:32 am »

Closing the program stops playback.  I can't see adding an option for that, because it seems pretty fundamental.  Just leave the program running if you want playback to continue.
Logged
Matt Ashland, JRiver Media Center

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #6 on: January 13, 2015, 11:20:14 am »

I think there should be the option to continue playback when media server is running.
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41895
  • Shoes gone again!
Re: Playback stop when exiting even with server running
« Reply #7 on: January 13, 2015, 11:25:21 am »

I think there should be the option to continue playback when media server is running.

Well there is that option -- it's called leave MC running.
Logged
Matt Ashland, JRiver Media Center

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5168
  • "Linux Merit Badge" Recipient
Re: Playback stop when exiting even with server running
« Reply #8 on: January 13, 2015, 11:38:20 am »

I guess minimizing it isn't enough?  Maybe try the "minimize to tray" option if you really don't want desktop clutter.  Then you'll just have two tray widgets instead of one, but otherwise it will have more or less the same screen footprint as media server.
Logged

leezer3

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1568
Re: Playback stop when exiting even with server running
« Reply #9 on: January 13, 2015, 11:42:01 am »

Whilst I don't use JRemote, isn't he saying that playback on the remote device (I.E. through the Ipad speakers) is stopping when the MC interface is closed?

That seems like a bug to me :)

-Leezer-
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71286
  • Where did I put my teeth?
Re: Playback stop when exiting even with server running
« Reply #10 on: January 13, 2015, 11:53:00 am »

If that's the case, he may need to run Media Server at system startup.
Logged

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #11 on: January 13, 2015, 11:57:50 am »

I started using Media Server recently.  I use JRemote about 75% of the time and use Theater View + display + remote control (my old method) the other 25%.  I have the option selected to start Media Server when Windows starts.  This way when my PC has booted up, I can immediately control it with JRemote.

Alternatively, I press a button on my remote control - my monitor powers up, JRiver launches in Theater View mode so I can utilize my display + remote.  I want to be able to close the JRiver front-end (Media Server does keep running when I exit the front-end) but have playback continue.  As it is now, I have to press PLAY on JRemote once the front-end closes.

This is what I want to fix.  Call this a bug or call it a feature request but it sounds like I am not the only person looking for JRiver to behave this way.
Logged

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: Playback stop when exiting even with server running
« Reply #12 on: January 13, 2015, 11:59:40 am »

Hello,

I agree with the author because of this:

-start mediaserver only
-start playback from jremote
-show mediacenter from the systray icon
-close mediacenter

Mediaserver is still running but playback stops.

Imo it is illogic behavior.
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

leezer3

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1568
Re: Playback stop when exiting even with server running
« Reply #13 on: January 13, 2015, 12:06:09 pm »

If that's the case, he may need to run Media Server at system startup.

See the post below yours Jim-
This seems to be happening with Media Server running :)

I'll try and reproduce with Gizmo later; Sadly I've not got any IOS devices.

-Leezer-
Logged

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #14 on: January 13, 2015, 12:18:47 pm »

If any more info and/or log files of some sort are needed please let me know.  I would be happy to provide.
Logged

Dr Tone

  • World Citizen
  • ***
  • Posts: 164
Re: Playback stop when exiting even with server running
« Reply #15 on: January 13, 2015, 06:00:11 pm »

Well there is that option -- it's called leave MC running.

I would if it played well with other full screen apps.
Logged

gvanbrunt

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1232
  • MC Nerd
Re: Playback stop when exiting even with server running
« Reply #16 on: January 13, 2015, 08:17:50 pm »

I don't think some in this thread understand what going on behind the scenes. I'm going to generalize this a lot, but you'll get the idea. The server is serving "streams" to client. Not processing audio. That is why it is a "server". If it processed audio as well, then it IS a client and would have all same baggage as leaving the client running. Not sure what you think the advantage to not having the client portion visible would bring you...
Logged

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #17 on: January 13, 2015, 09:01:35 pm »

If server is running I can still play audio files without launching the client so what is processing the audio?   I dont want/need the front-end functionality most of the time and server does what I need so why keep the front-end running?
Logged

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: Playback stop when exiting even with server running
« Reply #18 on: January 14, 2015, 01:47:26 am »

I don't think some in this thread understand what going on behind the scenes. I'm going to generalize this a lot, but you'll get the idea. The server is serving "streams" to client. Not processing audio.

And some do.

I am running MC with USB DAC. So audio rendering is local.

-start mediaserver only
-start playback from JRemote
-show mediacenter from the systray icon
-close mediacenter

Playback stops...

Unexpected behavior.

I won't be surprised if I couldn't start playback with only mediaserver running, but it's not what happens.
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

AndrewFG

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3392
Re: Playback stop when exiting even with server running
« Reply #19 on: January 14, 2015, 02:19:26 am »

Hmm.  It has been suggested in the past that the MC UPnP DMS (and MC UPnP DMR) should run as Windows Service Application(s); and the MC Front End (and MC UPnP CP) should run as a regular Windows UI application. That is how Microsoft does it in WMP for example. However that would be quite a big change in architecture..
Logged
Author of Whitebear Digital Media Renderer Analyser - http://www.whitebear.ch/dmra.htm
Author of Whitebear - http://www.whitebear.ch/mediaserver.htm

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71286
  • Where did I put my teeth?
Re: Playback stop when exiting even with server running
« Reply #20 on: January 14, 2015, 05:57:51 am »

And some do.

I am running MC with USB DAC. So audio rendering is local.

-start mediaserver only
-start playback from JRemote
-show mediacenter from the systray icon
-close mediacenter

Playback stops...

Unexpected behavior.

I won't be surprised if I couldn't start playback with only mediaserver running, but it's not what happens.
What you describe seems to be a problem with JRemote.

Media Server will allow playback.  You could read about it on the wiki.
Logged

tyler69

  • Citizen of the Universe
  • *****
  • Posts: 946
Re: Playback stop when exiting even with server running
« Reply #21 on: January 14, 2015, 06:40:27 am »

I do not think it's a problem with JRemote, but with how JRiver works. As Lespaul states on his homepage (http://www.JRemote.net/sample-page/) just running the server might have benefits when using audio only. So that's what I do when listening to music (and that's why I have the server in my startup items). But every now and then (while listening to Music through MC (server)) I do open up MC to check something or tag something, etc.. When finished, I want to close MC and keep the server running (and keep listening to my music). However when I close MC, it closes, the server stays in the tray (so it's still running), but the music stops. I think that's not so convinient since one has to open up JRemote and start playback again (I am not talking about playback on an iPhone etc.).
Logged

AndrewFG

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3392
Re: Playback stop when exiting even with server running
« Reply #22 on: January 14, 2015, 06:48:42 am »

If you close MC with the [X] button then you close both the user interface and the server (everything); whereas if you minimize MC with the [_] button the application will either minimize to the task bar or to the system icon tray depending on MC Options | General | Minimize to System Tray.

PS if you are really closing MC with the [X] button, and yet MC "remains" still in the system icon tray then you probably had two instances of MC running (one of which you closed, and the other which remains in the system icon tray). That could happen if you have MC set to Start on Windows Start and you have then also manually started MC again from the Windows start menu..
Logged
Author of Whitebear Digital Media Renderer Analyser - http://www.whitebear.ch/dmra.htm
Author of Whitebear - http://www.whitebear.ch/mediaserver.htm

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: Playback stop when exiting even with server running
« Reply #23 on: January 14, 2015, 06:49:17 am »

Hello JimH,

Sorry if I speak poorly but you missed my point.

We both agree Media Server allows playback with jremote/Gizmo (no matter the remote control).
But if you open MC window (by clicking on "show Media Center") and then close it, playback will stop although mediaserver is still running.
It is the point!

I hope this is more understandable.
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: Playback stop when exiting even with server running
« Reply #24 on: January 14, 2015, 06:51:15 am »

If you close MC with the [X] button then you close both the user interface and the server (everything)

In my case, mediaserver is still running. It only closes the MC window.
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

AndrewFG

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3392
Re: Playback stop when exiting even with server running
« Reply #25 on: January 14, 2015, 06:53:36 am »

In my case, mediaserver is still running. It only closes the MC window.

I added a foot note in red colour to my earlier post above...
Logged
Author of Whitebear Digital Media Renderer Analyser - http://www.whitebear.ch/dmra.htm
Author of Whitebear - http://www.whitebear.ch/mediaserver.htm

cassfras21

  • Junior Woodchuck
  • **
  • Posts: 93
Re: Playback stop when exiting even with server running
« Reply #26 on: January 14, 2015, 07:16:01 am »

Interesting thoughts

Yes I run MC at Windows startup (from MC settings I enabled mediaserver and mediacenter with Theater view display).
By default, MC allows only one instance.
Could this happen even if I didn't allow MC multi instance?
Logged
Media server: Synology DS916+ (Dockerised JRiver MC 22) || Media player: Intel NUC D54250WYKH - Windows 10 x64/JRiver MC 22
HiFi: Matrix i-mini Pro 2015 (USB DAC) >> Atoll IN80 SE (Int Amp) >> B&W CM1 S2 & subwoofer B&W ASW610

AndrewFG

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 3392
Re: Playback stop when exiting even with server running
« Reply #27 on: January 14, 2015, 08:08:35 am »

By default, MC allows only one instance.
Could this happen even if I didn't allow MC multi instance?

I think the "only one instance" switch would only prevent two instances of the same version of MC from running at the same time; but I guess it would not prevent (for example) MC v19 being auto- started with Windows and MC v20 being separately started by the user from the Windows start menu (for example..)
Logged
Author of Whitebear Digital Media Renderer Analyser - http://www.whitebear.ch/dmra.htm
Author of Whitebear - http://www.whitebear.ch/mediaserver.htm

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #28 on: January 14, 2015, 08:16:36 am »

I can confirm that I have the "only one instance" switch turned on and Media Server 20 is running and when I launch the front-end it is version 20.
Logged

Hendrik

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 10694
Re: Playback stop when exiting even with server running
« Reply #29 on: January 14, 2015, 08:22:51 am »

If you close MC with the [X] button then you close both the user interface and the server (everything); whereas if you minimize MC with the [_] button the application will either minimize to the task bar or to the system icon tray depending on MC Options | General | Minimize to System Tray.

PS if you are really closing MC with the [X] button, and yet MC "remains" still in the system icon tray then you probably had two instances of MC running (one of which you closed, and the other which remains in the system icon tray). That could happen if you have MC set to Start on Windows Start and you have then also manually started MC again from the Windows start menu..

This is not true, if the Media Server is running its not another instance of MC, its the same instance, and using X will only close the UI, and the process stays active, running Media Server in the background.

Also, if Media Server is running and you launch MC (the same version of MC anyway) through any other means, it'll not launch a second copy but simply activate the UI of the existing instance.

Note that this only applies if you have MC setup to start MC+Media Server or only Media Server at Windows startup.
Logged
~ nevcairiel
~ Author of LAV Filters

tyler69

  • Citizen of the Universe
  • *****
  • Posts: 946
Re: Playback stop when exiting even with server running
« Reply #30 on: January 14, 2015, 08:50:00 am »

Hendrik,
so as far as I understand, playback shouldn't stop when the UI is being closed, right (when server is running at startup)? At least that's my layman understanding..
Logged

tyler69

  • Citizen of the Universe
  • *****
  • Posts: 946
Re: Playback stop when exiting even with server running
« Reply #31 on: February 12, 2015, 09:58:53 am »

Bump
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41895
  • Shoes gone again!
Re: Playback stop when exiting even with server running
« Reply #32 on: February 12, 2015, 10:00:42 am »

Hendrik,
so as far as I understand, playback shouldn't stop when the UI is being closed, right (when server is running at startup)? At least that's my layman understanding..

Closing the UI stops playback.  Since you want the UI gone, it makes sense that you want the playback gone.  Minimize instead of close if you want to keep it running.
Logged
Matt Ashland, JRiver Media Center

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #33 on: February 12, 2015, 10:21:43 am »

I still feel that with server running playback should continue.  Opening the UI may be for just maintenance reasons and when existing the UI playback should continue (IMHO).
Logged

Matt

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 41895
  • Shoes gone again!
Re: Playback stop when exiting even with server running
« Reply #34 on: February 12, 2015, 10:22:58 am »

I still feel that with server running playback should continue.  Opening the UI may be for just maintenance reasons and when existing the UI playback should continue (IMHO).

Then minimize instead of close.  Pretty simple solution I think.
Logged
Matt Ashland, JRiver Media Center

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #35 on: February 12, 2015, 10:24:33 am »

Why keep the UI running if it is not needed?
Logged

BartMan01

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1513
Re: Playback stop when exiting even with server running
« Reply #36 on: February 12, 2015, 10:27:17 am »

Hello JimH,

Sorry if I speak poorly but you missed my point.

We both agree Media Server allows playback with JRemote/Gizmo (no matter the remote control).
But if you open MC window (by clicking on "show Media Center") and then close it, playback will stop although mediaserver is still running.
It is the point!

I hope this is more understandable.


I can't duplicate this.

I have MC set to run server on start up.  When the system starts up, MC Server is running and in the system tray.

Here is what I tried:
System is running, MC Server is running in system tray.
Start playback from server in JRemote.
Open MC on the machine where server is running using the start menu icon.  Close MC (click red X in upper corner).  JRemote continues to play without interruption.
Open MC on the machine using the system tray icon for 'show media center'.  Close MC (click red X in upper corner).  JRemote continues to play without interruption.
Logged

Dr Tone

  • World Citizen
  • ***
  • Posts: 164
Re: Playback stop when exiting even with server running
« Reply #37 on: February 12, 2015, 10:34:34 am »

I can't duplicate this.

I have MC set to run server on start up.  When the system starts up, MC Server is running and in the system tray.

Here is what I tried:
System is running, MC Server is running in system tray.
Start playback from server in JRemote.
Open MC on the machine where server is running using the start menu icon.  Close MC (click red X in upper corner).  JRemote continues to play without interruption.
Open MC on the machine using the system tray icon for 'show media center'.  Close MC (click red X in upper corner).  JRemote continues to play without interruption.


Not playback to JRemote.  Playback to a local computer sound devices.  ASIO, Directsound, WASAPI whatever.

Playback is started to sound device via JRemote.  Media Center in Server mode.
Media Center is brought up from the Server task bar shortcut.
Media Center is closed, but server is still running.  Music stops.
Logged

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #38 on: February 12, 2015, 10:58:10 am »

+1 for Dr Tone's response.  My same situation.
Logged

BartMan01

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1513
Re: Playback stop when exiting even with server running
« Reply #39 on: February 12, 2015, 11:54:40 am »

Not playback to JRemote.  Playback to a local computer sound devices.  ASIO, Directsound, WASAPI whatever.

Playback is started to sound device via JRemote.  Media Center in Server mode.
Media Center is brought up from the Server task bar shortcut.
Media Center is closed, but server is still running.  Music stops.

The fact that stuff will play locally when JRiver is in server mode is a quirk of the way server was implemented, not an intended feature as far as I can tell.  For example, I can accidentally start a video in MC playing via IR remote when only server is running but there is no UI running so the video isn't visible (I can just hear it).  If you want LOCAL playback of anything with MC, you need to leave the MC UI up and running (minimized if you don't want to see it) or strange things will happen.

Logged

Dr Tone

  • World Citizen
  • ***
  • Posts: 164
Re: Playback stop when exiting even with server running
« Reply #40 on: February 12, 2015, 12:11:58 pm »

The fact that stuff will play locally when JRiver is in server mode is a quirk of the way server was implemented, not an intended feature as far as I can tell.  For example, I can accidentally start a video in MC playing via IR remote when only server is running but there is no UI running so the video isn't visible (I can just hear it).  If you want LOCAL playback of anything with MC, you need to leave the MC UI up and running (minimized if you don't want to see it) or strange things will happen.



Yes, it does other weird things with scanning and getting out of sync with JRemote.  I've since quit using the server functionality for music playback and now start the full blow MC minimized on login through a start menu shortcut.  I wish media center had a configurable option to start minimized.
Logged

R32NJ

  • Junior Woodchuck
  • **
  • Posts: 65
Re: Playback stop when exiting even with server running
« Reply #41 on: February 12, 2015, 02:08:03 pm »

So, it is possible to use JREMOTE to control JRiver without having server mode running?  I guess I thought server mode was required for JREMOTE to operate (that's why I started using server mode anyway).
Logged

BartMan01

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1513
Re: Playback stop when exiting even with server running
« Reply #42 on: February 12, 2015, 02:11:19 pm »

So, it is possible to use JREMOTE to control JRiver without having server mode running?  I guess I thought server mode was required for JREMOTE to operate (that's why I started using server mode anyway).

As far as I know, JRemote needs server mode running to work (the server opens up MC to the network).  The point is that if you want anything playing back locally on any machine you really need to have the full MC UI running on that machine.

If you want it to start minimized, you will soon be able to do that via the command line.  From another post:

Next build:
Changed: The launcher (MC20.exe) takes a /MinMax command to toggle the minimized / maximized state of the program.
Logged

tyler69

  • Citizen of the Universe
  • *****
  • Posts: 946
Re: Playback stop when exiting even with server running
« Reply #43 on: February 12, 2015, 03:00:00 pm »

Closing the UI stops playback.  Since you want the UI gone, it makes sense that you want the playback gone.  Minimize instead of close if you want to keep it running.

I often open up the UI clicking the server tray icon when I need to check/edit/tag something (while listening to music). When finished, I close the UI so only the server stays active. While I would expect the music to continue, it doesn't. In my oppinion, minimizing the UI isn't a solution that takes the use case of just running the server for audio into account.
Logged

BartMan01

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 1513
Re: Playback stop when exiting even with server running
« Reply #44 on: February 12, 2015, 03:43:40 pm »

I often open up the UI clicking the server tray icon when I need to check/edit/tag something (while listening to music). When finished, I close the UI so only the server stays active. While I would expect the music to continue, it doesn't. In my oppinion, minimizing the UI isn't a solution that takes the use case of just running the server for audio into account.

You are missing the point that (as far as I can tell) running the server alone for LOCAL playback of content was never an intended use case.  Running the server is for remote playback of content or for connecting via the network to the running UI.

Someone from JRiver can tell me if I am wrong here, but from the posts above this seems to be the case.

From what I can tell, the fact that you can cause local playback with just the server running is more of a bug (or unintended side effect) than an intended feature.
Logged

Dr Tone

  • World Citizen
  • ***
  • Posts: 164
Re: Playback stop when exiting even with server running
« Reply #45 on: February 12, 2015, 03:53:38 pm »

So, it is possible to use JRemote to control JRiver without having server mode running?  I guess I thought server mode was required for JRemote to operate (that's why I started using server mode anyway).

JRiver doesn't need to be running in server mode it just needs media services enabled as a service.  The full aplication does everything the non gui server mode does.
Logged

6233638

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 5353
Re: Playback stop when exiting even with server running
« Reply #46 on: February 12, 2015, 05:02:24 pm »

I would like to see this change as well - it's actually one of the reasons I stopped running Media Server a while back, because I would often close MC thinking that it wouldn't matter since it was still running in the tray.
 
 
The solution here seems to be following what other applications do: when running in server mode, the "close" option minimizes to the system tray rather than actually closing the application.
 
While there is an already existing "minimize to system tray" option, there are two issues:
  • It adds an additional, redundant, tray icon.
  • It requires that you minimize the program rather than absent-mindedly hitting "close".

Now as far as I can tell, "Media Server" is just an instance of Media Center which already does this, with the difference being that hitting the close button also issues a stop command rather than just hiding the UI/minimizing to the tray.
 
It does not seem to be opening/closing any additional processes when you use the "show Media Center" option, or if you close MC while Media Server is running. And when you open Media Center via Media Server it is instantaneous.
 
 
While you may not want to change the default behavior (though I think it would actually make sense to) an option to prevent playback from stopping if you close MC while Media Server is running would be nice.
Logged

glynor

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 19608
Re: Playback stop when exiting even with server running
« Reply #47 on: February 12, 2015, 05:02:29 pm »

The core assumption seems to be that running in Media Server Only mode is substantially more "lightweight" than running the "full UI" minimized.

This is not true.  When you minimize MC, it unloads almost all of the UI-specific memory, and the memory allocation is cut.  In fact, I just did a test, and here were the results:

Private Bytes:
MC 20 Full UI Visible: ~80MB
MC 20 Minimized to Task Bar: ~40MB
MC 20 Library Server Mode: ~43MB

I didn't do much testing here, but in just that one test, the Library Server mode actually used a tiny bit more memory than when it was minimized (that could have been because it was doing something at that particular moment, the HTPC is in use right now upstairs).

In any case, the different is tiny, and irrelevant on a remotely modern PC.
Logged
"Some cultures are defined by their relationship to cheese."

Visit me on the Interweb Thingie: http://glynor.com/

tyler69

  • Citizen of the Universe
  • *****
  • Posts: 946
Re: Playback stop when exiting even with server running
« Reply #48 on: February 12, 2015, 05:28:19 pm »

You are missing the point that (as far as I can tell) running the server alone for LOCAL playback of content was never an intended use case.  Running the server is for remote playback of content or for connecting via the network to the running UI.

Someone from JRiver can tell me if I am wrong here, but from the posts above this seems to be the case.

From what I can tell, the fact that you can cause local playback with just the server running is more of a bug (or unintended side effect) than an intended feature.

OK, thanks. I read about using the server only on the JRemote Homepage, which seemed to me being a use case, hence my post.
Logged

6233638

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 5353
Re: Playback stop when exiting even with server running
« Reply #49 on: February 12, 2015, 06:03:18 pm »

The core assumption seems to be that running in Media Server Only mode is substantially more "lightweight" than running the "full UI" minimized.
It's more about convenience for me.
I like that Media Server starts automatically when I log in and is always there in the tray, so that MC is instantly available when it is running in server mode.
I don't like that, out of habit, I always end up hitting the close button to "minimize" to the tray when Server is running, which invariably stops playback.

What's worse is if playback was started via a remote while Media Server was already running in the tray, you open MC for some reason and then close it, which stops playback even though Media Server is still sitting in the tray.
As I said above, it's so instinctive to do that, I ended up having to stop running Media Server altogether because I just kept interrupting music playback by closing MC while MS was running.
 
I agree that this is not (or should not be) about "saving resources".
Media Center is currently using a WHOLE 3MB while minimized right now:
Logged
Pages: [1] 2   Go Up