INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2 3   Go Down

Author Topic: Quick start guide for installing JRiver Mediacenter ARM for Raspberry Pi 1 and 2  (Read 134958 times)

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

This guide to installing JRiver's ARM build for the Raspberry Pi version 1 B+ and the Raspberry Pi version 2. There is now an official licensed ARM build.

Mediacenter works best on a Pi 2, but will work on the Pi 1 B+ (especially if you overclock), but the experience is limited. The steps to get MC running on the Pi are somewhat similar to getting it running on a normal linux system, with a few tweaks.

Setup

Hardware/OS setup:

Install Raspbian onto an SD card using the downloaded NOOBS image from the Raspberry Pi website. They have good instructions, and Raspbian works on both the Pi 1 and the Pi 2 (although you need an updated installation medium for the Pi 2).

Configuring Hardware:

At first boot the Pi shows a config utility (called raspi-config). For easy use of mediacenter, I recommend a) setting the Pi to boot into a graphical desktop environment by default (ignore this if you're comfortable with the console), b) choosing the audio output you want by default (HDMI or the Pi's built in audio output*), and c) thinking about whether you want to choose one of the overclock* options in the advanced options. Once you've picked your settings, reboot.

Notes:

Audio: the Pi's HDMI output works great, but the built in stereo jack is not the highest quality output in the world. I wouldn't recommend using it for actual listening. If you have a USB DAC, just ignore that for now, this option is only about the behavior of the Pi's built in audio outputs.

Overclocking: Overclocking can potentially shorten the life of your Pi or cause instability. However, because the Pi now comes with built in thermal throttling, you can overclock using the raspberry pi utility as described above without voiding your warranty. Overclocking makes a huge difference in performance for the Pi 1; I did not find the Pi 1 usable at stock settings, YMMV. Overclocking is less important for the Pi 2, but it definitely improves performance. I have not personally encountered overclocking related instability with about four different Pis, but that doesn't mean you won't. If you decide to wait to overclock you can get back to the built in configuration utility any time by running
Code: [Select]
sudo raspi-configin a terminal window

Software Preparation:

After rebooting, you should be looking at the Pi's desktop. If your Pi isn't plugged into to an ethernet line, take a minute to configure your wi-fi adapter to get internet access. Once that's done, open a terminal by clicking on the icon that looks like a computer monitor. Enter the following into the terminal:
Code: [Select]
sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-get install libx11-6 libc6 libasound2 libuuid1 libidn11 libxcb1 libxau6 libxdmcp6 zlib1g libxext6 libgtk2.0-0 libp11-kit0 libstdc++6 p11-kit libgl1-mesa-glx libcanberra-gtk-module xdg-utils xfonts-75dpi xfonts-100dpi lame vorbis-tools musepack-tools xfonts-unifont

After you enter the first line, you'll be prompted whether to install updates to packages; press "y" to confirm. It may take a little while for the packages to download and install. The same thing will happen after the second line, but it will also likely tell you that some of those packages are already installed; that's fine, this is insurance that you have everything you need.  Now enter the following into the terminal

Code: [Select]
cd /boot
sudo nano config.txt

This will show you the file config.txt in the text editor nano. You'll see a lot of information in the config file already, scroll down to the bottom of the file using the direction keys on your keyboard and enter the following two lines exactly as shown:
Code: [Select]
framebuffer_depth=32
framebuffer_ignore_alpha=1

Then save the file by pressing Ctrl+O, then enter. Then press Ctrl+X to exit, and you should be back at the terminal. Now close the terminal and reboot the pi.

Installing MC:

After the reboot, it's time to install MC:
Code: [Select]
mkdir Downloads
wget -q "http://dist.jriver.com/mediacenter@jriver.com.gpg.key" -O- | sudo apt-key add -
sudo wget http://dist.jriver.com/latest/mediacenter/mediacenter20native.list -O /etc/apt/sources.list.d/mediacenter20.list
sudo apt-get update
sudo apt-get install mediacenter20

If you receive an error message after the mkdir line indicating that Downloads already exists, just go ahead with the follow on steps.

After installation completes, you should see MC in the application menu in the upper left hand corner under "sound and video." Open MC, and you're off!  

Installing a License:

JRiver offers a 30-day trial, but to keep using the software you'll need to buy and register it. Currently a JRiver for Linux license or Master license will work. There are several ways to install a JRiver License, but the easiest way is to do it on the command line.  

When you purchase JRiver, you receive an E-mail with an .mjr file. Download that file to your Raspberry Pi's Downloads directory (the one created above). Then open a terminal by clicking on the icon that looks like a computer and enter the following command:
Code: [Select]
mediacenter20 /RestoreFromFile ~/Downloads/"Media Center20 Linux-YYYYYY.mjr"
Replace the Y's with the numbers from your .mjr file, but otherwise enter the command exactly as shown.  

NOTE for advanced users: This will not work correctly if you try to do it via ssh, because Mediacenter needs a display/xserver in order to run.  If you have used the headless/VNC setup instructions below, try connecting to the pi using VNC and using lxterminal to register your license.

Audio Setup:

If you're using the Pi's built in audio output (HDMI or stereo), it should just work provided you did the steps above. If you have a USB DAC, you'll need to configure MC to address it just like in normal MC for Linux. That means looking under options --> Audio Devices and looking for a hardware device (an entry for your DAC that has something like "front:" or "surround:" in the name).  

Updating:

To update mediacenter (and the rest of your Pi OS) just enter the following line on the terminal:
Code: [Select]
sudo apt-get update && sudo apt-get dist-upgrade
Troubleshooting Audio

If you followed the steps above and are not getting audio output via HDMI, try the following:

Alsamixer:
In the terminal "alsamixer" and you will see a volume bar (a "graphical" mixer displayed using ASCII characters).  Check whether the volume is muted by looking at the bottom of the column: if you see "MM" press the "m" key to unmute and then press escape to exit.  If you see "00" then the output isn't muted and that's not the problem (press escape to exit)

Monitor/DVI issues:
Many monitors expect/request a DVI input, which results in the Pi not sending sound to those monitors by default.  To find out if that's what's causing your problem, open a terminal, and type
Code: [Select]
sudo nano /boot/config.txt and then find the line that reads
Code: [Select]
#hdmi_drive=2  Remove the "#" symbol, and leave the rest of the line intact.  If your file doesn't have that line for some reason, you can just add the line at the end of the file.  In either case, save the file by pressing CTRL+O, and exit nano by pressing CTRL+X. Then reboot the Pi and test whether you can get sound over HDMI. Changing that option in config.txt has resolved no-audio issues for several folks with screens that have those issues with HDMI support.

Pops and Dropouts

Pops or dropouts can be caused by a lot of different things and can be tough to troubleshoot.  Some users have found that adjusting CPU frequency scaling can help on RPi 2's (RPI 1's won't benefit from this tweak).  The following link explains how to set your RPi 2 to stay at maximum CPU frequency (using the performance CPU governor: http://yabb.jriver.com/interact/index.php?topic=95578.msg676554#msg676554

Some notes on getting the most out of MC on the Pi:

The Pi is not a full-featured computer so things will take longer to do on the Pi than on a normal computer. Be patient especially during startup or right after. It might take ten or even thirty seconds for mediacenter to start after you click the icon (depending on whether you have a pi 1 or pi2 and your other settings). Video is not currently supported and the maximize and minimize buttons do not work (at least for me). Other than those two issues, everything I've tested works pretty well.  

An Important Note Concerning Power: Pi's are very sensitive to not having enough power; if you plug in too many power hungry USB peripherals it can cause the Pi to reboot or turn off (and corrupt the sd card!). The safest way to resolve this is to use a good powered USB hub and plug the peripherals into that. The best part is that the Hub can also power the Pi itself, so you still only have one wall plug! Some USB hubs won't work very well due to back-power issues, but a recommended list of hubs is available here: http://elinux.org/RPi_Powered_USB_Hubs.  To be clear, if you're just plugging in a usb keyboard/mouse and a wi-fi adapter you should be fine with the normal power supply; it's things like external hard drives and USB DACs that need more juice.

Additionally, if you don't want to use a USB hub, you may be able to power more peripherals by adding the following line to your config.txt:
Code: [Select]
max_usb_current=1
That line allows the Pi's USB ports to supply more current to peripherals, which has allowed several forum members to use an external Hard Drive without using a USB hub.  [Thanks to Hilton for finding and testing that option.]

Pi's are also sensitive to sudden loss of power: cutting off the power on a pi without shutting down properly can and will corrupt your sd card. For that reason it's important to always shut down your pi appropriately. However accidental power outages do occur, so, as a best practice, consider backing up your sd card with a disk imaging utility once you've gotten everything working the way you want. Another more advanced approach is to hook up a rechargeable battery in between the power supply and the Pi to act as a buffer in case of sudden power loss, and configure the Pi to shut down gracefully when mains power goes out, but that's a more advanced topic.

Running Without a Monitor: If you would like to run the Pi without a monitor attached, that's a slightly more advanced topic.  MC needs some kind of "display" in order to run.  When a monitor is not attached, the pi will not necessarily start it's display, which will prevent MC from running. The following link provides step by step basic instructions that will provide a relatively easy way to run MC on a Pi with no monitor attached and control it remotely.

http://yabb.jriver.com/interact/index.php?topic=95578.msg674431#msg674431

Status of Features:

What I've tested that works for me:


1) Local audio playback of FLACs and MP3s (Pi 1 and 2)
2) Using the Pi as a library client (Pi 1 and 2)
3) Using the Pi as a DLNA renderer (Pi 1 and 2)
4) Controlling the Pi with gizmo or eos (Pi 1 and 2)
5) Streaming to gizmo from the Pi (works on Pi2, not on the Pi 1)
6) Normal window resizing
7) ALSA-compatible USB DACs
8 ) Using an external hard drive with the Pi (some additional configuration required for some drives)

What I have not tested:

1) DSD (I have no DSD-compatible hardware or files)
2) Airplay, etc. (I have no macs or i-devices to test with)


What is not working/supported:


1) Video Playback
2) Maximize and Minimize buttons
Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291

Cool! Great work..  :)

Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Thanks!  Let me know if I'm missing any steps when you get yours up and running  ;D
Logged

glob

  • Recent member
  • *
  • Posts: 11

Thanks heaps mwillems.  I'm up and running on p2 overclocked.  Works on HD recordings fine :)

In case there are other novices like me: At first MC20 appeared under Sound and Video as an app but it would not open.  Then I realised I need to add an extra step (I know nothing about Linux so perhaps it is obvious):  after entering "sudo apt-get update && sudo apt-get dist-upgrade" i had to enter "y" for yes and wait a few minutes for some updates (i think).  And then enter "y" after the next line of code that starts "sudo apt-get".  Then I rebooted and all was well.

I reckon if someone like me who had never touched a raspberry pi before today and is not clever with computers can do it, it is promising for MCARM :)

I bought the Pi2 specifically so I can run MC and connect my DIY DAC by i2s and bypass USB for superior audio.  So that will be the next challenge.  Do you happen to know how to get MC to output i2s on the pi?  Perhaps it already does and I do not have to configure anything?   

Once again, thank you so much for taking time to share your code findings!
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

In case there are other novices like me: At first MC20 appeared under Sound and Video as an app but it would not open.  Then I realised I need to add an extra step (I know nothing about Linux so perhaps it is obvious):  after entering "sudo apt-get update && sudo apt-get dist-upgrade" i had to enter "y" for yes and wait a few minutes for some updates (i think).  And then enter "y" after the next line of code that starts "sudo apt-get".  Then I rebooted and all was well.

I'll make sure to add some clarifications on that.

I bought the Pi2 specifically so I can run MC and connect my DIY DAC by i2s and bypass USB for superior audio.  So that will be the next challenge.  Do you happen to know how to get MC to output i2s on the pi?  Perhaps it already does and I do not have to configure anything?   

I'm sorry not to be more help, but I know next to nothing about the i2s outputs on the Pi.  Some other folks on the forum have used the HiFiBerry Dac's, which I think use i2s, so they might have some ideas.  Regardless, please share your findings when you get it sorted out!
Logged

glob

  • Recent member
  • *
  • Posts: 11

Problem: Audio from the Pi2's HDMI is about half as loud as from my other HDMI sources (blue ray and tv hd recorder).

Question: Anyone have ideas of how to increase the Pi's HDMI volume without undermining the sound quality of MC?  I found posts on the raspberry forum on how to increase volume, but it  involved adding code or installing mixers, and I do not know if they would detract from MC's sound quality.

Thanks for considering :)
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Problem: Audio from the Pi2's HDMI is about half as loud as from my other HDMI sources (blue ray and tv hd recorder).

Question: Anyone have ideas of how to increase the Pi's HDMI volume without undermining the sound quality of MC?  I found posts on the raspberry forum on how to increase volume, but it  involved adding code or installing mixers, and I do not know if they would detract from MC's sound quality.

Thanks for considering :)

Is the audio from the Pi's HDMI quieter with all media software on the pi, or just with JRiver?  If the former, there's not much JRiver can do about it, you'll need to adjust it in the ALSA settings, or possibly elsewhere.  The first thing to check is the volume settings in alsamixer (which should already be installed).  

If JRiver is quieter than other players, check and make sure that volume levelling is disabled.
Logged

glob

  • Recent member
  • *
  • Posts: 11

Everything is quieter; not only MC.
I will investigate ALSA and how to change the settings after work.

I'm wondering - is there a "best" way to configure ALSA to maximize sound quality with MC?  I understand that some digital volume controls can be bypassed so they are bit perfect (sometimes this is achieved when the digital volume is set to maximum), or so they can run at higher number of bits so they introduce less computational artifacts.   Anyone any thoughts on what is best for ALSA and MC?

Thank you
Logged

glob

  • Recent member
  • *
  • Posts: 11

It turns out the alsamixer had the gain set to 44 or about -17dB (this was on a brand new Pi2 build after following the ARM guide for Pi2).   I increased it to -0.3dB (or about that).  Interestingly I could not set the gain to 0dB.   Does anyone know:

Next problem:  For sample rates above 48kHz I change the output format to "no change"; When I play audio then open the dsp settings, MC has switched them back to 48kHz.  My audio interface supports higher rates.  I will try different output modes later (e.g. kernel, direct etc) and see if that fixes it.

(For anyone like me who had never heard of asla I found these links helpful:  https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture
http://en.wikipedia.org/wiki/Alsamixer   http://www.volkerschatz.com/noise/alsa.html)
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Next problem:  For sample rates above 48kHz I change the output format to "no change"; When I play audio then open the dsp settings, MC has switched them back to 48kHz.  My audio interface supports higher rates.  I will try different output modes later (e.g. kernel, direct etc) and see if that fixes it.

Make sure you're addressing one of the hw: devices (they should have a label like "front:" or "surround:" in their description) and you should be able to output higher sample rates.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598

Don't buy ARM devices specifically to run MC on them.
Read the post that announced this beta build:
http://yabb.jriver.com/interact/index.php?topic=95459.msg657558#msg657558

Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Don't buy ARM devices specifically to run MC on them.
Read the post that announced this beta build:
http://yabb.jriver.com/interact/index.php?topic=95459.msg657558#msg657558



I amended my opening post to incorporate this, thanks Bob.
Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291

Found a small error in the instructions.


Download folder doesn't exist by default and a small typo.

Need to do the following to create the Downloads folder.

mkdir Downloads
cd Downloads
wget http://files.jriver.com/mediacenter/channels/v20/latest/MediaCenter-20.0.66-armhf.deb
sudo dpkg -i MediaCenter-20.0.66-armhf.deb

Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Found a small error in the instructions.


Download folder doesn't exist by default and a small typo.

Need to do the following to create the Downloads folder.

mkdir Downloads
cd Downloads
wget http://files.jriver.com/mediacenter/channels/v20/latest/MediaCenter-20.0.66-armhf.deb
sudo dpkg -i MediaCenter-20.0.66-armhf.deb



That's weird, the "pi" user has a Downloads folder by default (or at least it did when I went through these instructions).  

Did you by chance make a new user or log in as root?  If so that may be why there was no Downloads folder (root never has normal user folders in its home folder).  I'll clarify that above if you can confirm.  If the default "pi" user has no Downloads folder by default, I'll note that too.

What was the typo?
Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291

That's weird, the "pi" user has a Downloads folder by default (or at least it did when I went through these instructions).  

Did you by chance make a new user or were you logged in as root?  If so that may be why there was no Downloads folder (root never has normal user folders in its home folder).  I'll clarify above if you can confirm.

What was the typo?

The typo wasn't a typo, the ~ wasn't working so it must be keyboard issue on my end.
I just used the standard pi user and I wasn't logged in as root.
I was running local x not ssh.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

The typo wasn't a typo, the ~ wasn't working so it must be keyboard issue on my end.
I just used the standard pi user and I wasn't logged in as root.
I was running local x not ssh.

Got it; the tilde is the standard shell shorthand for the "home directory." I'll add a note above with workaround instructions.

EDIT: added.  Thanks for the feedback.
Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291

Got it; the tilde is the standard shell shorthand for the "home directory." I'll add a note above with workaround instructions.

EDIT: added.  Thanks for the feedback.

Just confirming Downloads definitely doesn't exist by default.

pi@raspberrypi ~ $ cd /boot
pi@raspberrypi /boot $ sudo nano config.txt
pi@raspberrypi /boot $ cd ~/Downloads
-bash: cd: /home/pi/Downloads: No such file or directory
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Just confirming Downloads definitely doesn't exist by default.

pi@raspberrypi ~ $ cd /boot
pi@raspberrypi /boot $ sudo nano config.txt
pi@raspberrypi /boot $ cd ~/Downloads
-bash: cd: /home/pi/Downloads: No such file or directory


Weird; I checked last night with a new install and it was there by default.  Just for my peace of mind: you were using the default NOOBS Raspbian installation, not the standalone Raspbian image or the net installer?

Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291

default NOOBS Raspbian installation
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Weird.  I'll make a few more changes.
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

Alright, followed the directions to the letter - TWICE.  While JRiver shows that it is playing, I get NO AUDIO.

I have told it to output to the HDMI in the setup at the beginning.  I am hooked up to an HDMI monitor, nothing, nada.

Any advice???
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Alright, followed the directions to the letter - TWICE.  While JRiver shows that it is playing, I get NO AUDIO.

I have told it to output to the HDMI in the setup at the beginning.  I am hooked up to an HDMI monitor, nothing, nada.

Any advice???

If you plug some earbuds into the 3.5mm jack is audio playing there?  If so try typing "sudo raspi-config" and setting the Pi to force HDMI audio out.  If you're not getting any sound from the 3.5mm jack, then it's trying to play to the HDMI output, but it may be an issue with how the Pi is communicating with your monitor.  

Is the Pi connected directly to the HDMI input on the monitor (no adapters, etc.)?  Do you have another HDMI display you can test?  Have you checked the monitor's settings to make sure that it's setup to receive and playback audio?  For example, I have an HDMI monitor with no speakers and only a headphone jack; I had to turn on the audio output in the monitor settings and unmute the headphone jack on my monitor before it would work.  Do other devices/computers successfully play sound to this monitor?

If all else fails, try typing "sudo nano /boot/config.txt" and adding "hdmi_drive=2" to the end of the file (then reboot).  That option is reported to resolve no-audio issues for some folks with screens that have flaky HDMI support.
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

Heard nothing through the HDMI, so I forced it to the audio out jack and heard it, however it was so low, that it is likely playing on my HDMI set, but just too low to hear.

Is there a way to boost the gain in the system?  Is there a 'mixer' or control panel which will give me more gain over the output?

I did get it to play 192k FLAC just fine, but would now like to try a USB DAC, and I am sure it is going to need more gain.

Thanks
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

Also, this is a Samsung TV.  I normally use the FireTV stick with it, and it plays back quite loud.

All settings are at default in the OS and in J River.  I am using both Gizmo and a shared library.

Thanks for the assistance.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Heard nothing through the HDMI, so I forced it to the audio out jack and heard it, however it was so low, that it is likely playing on my HDMI set, but just too low to hear.

Is there a way to boost the gain in the system?  Is there a 'mixer' or control panel which will give me more gain over the output?

I did get it to play 192k FLAC just fine, but would now like to try a USB DAC, and I am sure it is going to need more gain.

Thanks

I get quite loud volume on the HDMI output, so low volume is not necessarily typical.  I have a samsung TV myself and the Pi works fine with it. I assume you've checked the volume settings in both JRiver and on the TV and both are set as high as you can get them?  

If that's the case, try typing "alsamixer" into the terminal and check the system volume levels there.  If they're below 100%, that's probably your problem. 

Other than that, I'm not sure what to suggest except you might want to look around on the Raspberry Pi forums, maybe someone else has had your issue?
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598

I get quite loud volume on the HDMI output, so low volume is not necessarily typical.  I have a samsung TV myself and the Pi works fine with it. I assume you've checked the volume settings in both JRiver and on the TV and both are set as high as you can get them?  

If that's the case, try typing "alsamixer" into the terminal and check the system volume levels there.  If they're below 100%, that's probably your problem. 

Other than that, I'm not sure what to suggest except you might want to look around on the Raspberry Pi forums, maybe someone else has had your issue?
I think in this case alsamixer is his friend.
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

Must be something with the HDMI.  I got it to work fine with the audio output and with a pair of USB Headphones.  My guess there is something about the TV and the HDMI implementation.  Who knows.

BTW: Alsamixer defaults to 44 - very quiet.  You might want to add that to your instructions.

Thanks for the great help!
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598

Must be something with the HDMI.  I got it to work fine with the audio output and with a pair of USB Headphones.  My guess there is something about the TV and the HDMI implementation.  Who knows.

BTW: Alsamixer defaults to 44 - very quiet.  You might want to add that to your instructions.

Thanks for the great help!
Check the mute on HDMI in Alsamixer.
The hardware output for HDMI is either on or off. The volume is controlled on your TV/Audio device.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598

You shouldn't need this anymore.
 libssl1.0.0
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Ok, thanks for the update; I pulled it from the list of dependencies.
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

How do I check the MUTE in Alsamixer?

I see no such option.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

How do I check the MUTE in Alsamixer?

I see no such option.

Look at the bottom of the column; do you see "MM" or "OO"?  If you see "MM" it's muted.  Hit "m" to unmute it.
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

Figured that out, not muted.  I am at a loss.

Any ideas guys?  The TV is a Samsung and it has always played sound through the OpenElec/Lodi I am running, so I know it is not a hardware issue.

TV Volume at 100%
J River Volume at 100%
Alsamixer at 100% - reporting PCM [db gain: 4.00]

Soundcard is reported as bcm2835 ALSA

Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Did you try adding the line to your config.txt as suggested above?
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

Sorry, saw the line in the config already, but it was commented out by default.  Enabled it and all is good.

Display looking for DVI without it and thus wont process audio.

Thanks for the assist.
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

New issue.  I am running to HDMI and the audio is fine.  Playing 192kHz/24-bit seems to work, though JRiver reports everything I play as 44.1kHz MP3 (coming from a shared library on another computer - no DLNA).

However, a friend I am trying to help out is playing the same to a USB DAC and he is getting drop-out using any file type or sample rate.  Played with the buffering in JRiver to no avail.

Any suggestions I can shoot him?
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598

New issue.  I am running to HDMI and the audio is fine.  Playing 192kHz/24-bit seems to work, though JRiver reports everything I play as 44.1kHz MP3 (coming from a shared library on another computer - no DLNA).

However, a friend I am trying to help out is playing the same to a USB DAC and he is getting drop-out using any file type or sample rate.  Played with the buffering in JRiver to no avail.

Any suggestions I can shoot him?
This is controlled by the client option in Media Network configuration on the pi (in your case).
Yours is probably set to mp3, his is probably set to none and the pi doesn't have enough horsepower to play what he's trying to play.
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

Changed in both to make sure there is no conversion to MP3.

However, his is connected to a USB DAC (MSB) and he is getting dropouts, while I am connected via HDMI to a TV set and playback is great.  Our networks are different and our source storage is different.  Assume he needs greater SMB buffering, but wondering where this is set.

Thanks
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598

Changed in both to make sure there is no conversion to MP3.

However, his is connected to a USB DAC (MSB) and he is getting dropouts, while I am connected via HDMI to a TV set and playback is great.  Our networks are different and our source storage is different.  Assume he needs greater SMB buffering, but wondering where this is set.

Thanks
No idea on the SMB.
He's connected ethernet?
You could increase the prebuffering on the Id audio options.
If that doesn't do it you could play with the buffer under the audio device options however I suspect that the issue is more likely bandwidth related if it's happening in the middle of a stream.
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

Yes, connected to the Ethernet on the Pi2.

I assume you mean the pre-buffering in the Tools>Options>Audio, yes?

What about buffering for the USB audio.  Is there anything in the USB audio driver?

Thanks
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13598

Yes, connected to the Ethernet on the Pi2.

I assume you mean the pre-buffering in the Tools>Options>Audio, yes?
Correct
Quote
What about buffering for the USB audio.  Is there anything in the USB audio driver?
Not that I know of. Just the buffering parameters in MC's ALSA device advanced settings.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Thoughts:

1) I would encourage him to try a powered USB hub if the DAC is USB powered.  The Pi may not provide enough power for some USB-powered DACs, which could potentially be causing instability or drop outs.  If the powered USB hub fixes the issue, there are some things he can try on the Pi as well once we've established that power is the problem.

2) Has he checked the ALSA matrix to see if his DAC is actually supported under linux?  It should be listed in the ALSA matrix: http://www.alsa-project.org/main/index.php/Matrix:Main.  Some listed devices require special configuration to work correctly (even some fairly common DACs), and aome devices that aren't listed will still work (or work badly). 

3) Does he have a Pi 1 or a Pi2?  How does CPU usage look during playback?  If he's running on a Pi 1, he may need to overclock it.
Logged

TopDownDriver

  • World Citizen
  • ***
  • Posts: 205

Thanks for the assist:

1) DAC is self powered, though I believe it may require power over the USB as well.  I will check into this.

2) DAC is supported.

3) P2 and it is overclocked as well.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Thanks for the assist:

1) DAC is self powered, though I believe it may require power over the USB as well.  I will check into this.

Try the hub anyway, just to confirm.

Quote
2) DAC is supported.

What model is it?

Additionally, has he tried local file playback to rule out network issues (i.e. play a file on the Pi's SD card just to test)

Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291

Thanks for the assist:

1) DAC is self powered, though I believe it may require power over the USB as well.  I will check into this.

2) DAC is supported.

3) P2 and it is overclocked as well.

Hi there.
Something else to consider:
Is anything else plugged into the USB ports? The Pi by default can only supply 600mA to USB devices across all USB ports.

The other thing to check is if the red LED on the board is flashing off and on at all, or a rainbow square appearing in the top right hand corner of the screen with a monitor connected.
These flash to indicate power problems, in which case:
1) Try a bigger 2.1 to 2.4 Amp USB power supply.
2) Try a shorter or different USB cable.

The Pi is very sensitive to getting enough voltage and current. Poor USB cables or power supplies will cause brown-outs which can cause the dropouts. I have found 2 cables that are the same length and look identical perform differently.

Failing that, are you able to try his DAC on your setup?

There are some other things I can suggest to try with changing USB interrupt polling, but lets not go there till you've ruled out power issues.
Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291

Just an update on my experience with the Pi2 in my little battery powered case.
I've been running the Pi2 at standard 700mHz today and it still plays everything fine. Its running a lot cooler and I suspect I'll get much better battery life out of it too.

I managed to get my little battery setup running for a full day in the office yesterday including a 40 mins drive each way using it in the car.  (Streaming via Wifi to the phone and then BT from the phone to the car)
I didn't use it all day, but it was powered on all day and used for about 4-5 hours including the travel time.
Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

Just an update on my experience with the Pi2 in my little battery powered case.
I've been running the Pi2 at standard 700mHz today and it still plays everything fine. Its running a lot cooler and I suspect I'll get much better battery life out of it too.

I managed to get my little battery setup running for a full day in the office yesterday including a 40 mins drive each way using it in the car.  (Streaming via Wifi to the phone and then BT from the phone to the car)
I didn't use it all day, but it was powered on all day and used for about 4-5 hours including the travel time.

Just FYI the factory default Pi2 clockspeed is 900MHZ not 700 (it's the Pi1 that had a 700MHz default clock); if you've clocked it to 700MHZ, you're actually underclocking (which I expect would dramatically improve battery life).  

I agree based on my own experiments that overclocking shouldn't be necessary on the Pi2 for most applications, it's just more or less mandatory for the Pi1.  I haven't tried underclocking the pi2, but if that its what you're doing, I'd be interested in your observations about performance.

Also, if you want to squeeze out a little more power, you can use the powersave cpu frequency scaling governor; that would probably net some extra battery life too as it downclocks like crazy whenever nothing is happening.  It does result in a performance hit, but if you've got performance to burn...
Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291

Just FYI the factory default Pi2 clockspeed is 900MHZ not 700 (it's the Pi1 that had a 700MHz default clock); if you've clocked it to 700MHZ, you're actually underclocking (which I expect would dramatically improve battery life).  

I agree based on my own experiments that overclocking shouldn't be necessary on the Pi2 for most applications, it's just more or less mandatory for the Pi1.  I haven't tried underclocking the pi2, but if that its what you're doing, I'd be interested in your observations about performance.

Also, if you want to squeeze out a little more power, you can use the powersave cpu frequency scaling governor; that would probably net some extra battery life too as it downclocks like crazy whenever nothing is happening.  It does result in a performance hit, but if you've got performance to burn...

Yes I've underclocked to 700Mhz and It plays MP3 and FLAC fine though it does occasionally stutter at the beginning of FLAC tracks if you have cross fade turned on and are downsampling or upsampling.
Otherwise its a little slower to render album art on JRemote but still just as usable. 
Logged

Hilton

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 1291

Hi!

I'd just like to share an alternative for remote access to the Pi using standard windows RDP which is nice and fast on a local network.
This is a variation on some things I found around the place to make it really simple to remotely login to the Pi desktop.

This method allows you to see the same desktop that's running on the HDMI screen from a remote computer without having a monitor connected to the Pi.
It uses x11vnc which is a full featured and more powerful vnc server than the tightvncserver.
It's also what allows the remote viewing of the HDMI output which tightvncserver cant do.

You'll need to install XRDP too but that's pretty straight forward and the good news is there's a nice noobs install for x11vnc. 

First install XRDP as follows:

Code: [Select]
sudo apt-get update && sudo apt-get install xrdp
Now we edit the config file for XRDP:

Code: [Select]
sudo nano /etc/xrdp/xrdp.ini
Change the xrdp.ini in the editor so it matches this below. When you're finished press control X and then Y at the prompt to save it.
xrdp1 is the profile we'll use to login to the desktop.

Code: [Select]
[globals]
bitmap_cache=yes
bitmap_compression=yes
port=3389
crypt_level=low
channel_code=1

# set empty username because VNC auth
# doesn't actually use username, so no
# point in asking the user for one.

[xrdp1]
name=Active Local Login
lib=libvnc.so
username=
password=ask
ip=127.0.0.1
port=5900

[xrdp2]
name=Clean Session
lib=libvnc.so
username=
password=ask
ip=127.0.0.1
port=5901

If you've installed tightvncserver previously you'll need to remove it with:
Code: [Select]
sudo apt-get remove tightvncserver

Now we can install x11vnc the noobs way.
In the terminal session type:

Code: [Select]
cd ~/Downloads
wget http://goo.gl/MbfUEp -O isx11.sh

and then press enter to download the installer

Once it has finished downloading, type the following and follow the instructions:

Code: [Select]
sudo bash isx11.sh

One last change to Mwillems startup script.

Code: [Select]
sudo nano /etc/MC20start.sh
Copy or edit it to look like this.  Mwillems may want to chime in with the precise crontab settings he's using this with so it checks periodically if MC is running and starts it if it's stopped for any reason.
I'm using the same settings in my script but I only start it once at boot.

Code: [Select]
export USER=pi
ps -e | grep x11vnc || x11vnc :0 -localhost -geometry 1920x1080
export DISPLAY=':0'
ps -e | grep mediacenter || mediacenter20

control X and then y to save

If you haven't created this file previously you'll need to chmod it:

Code: [Select]
sudo chmod +x  /etc/MC20start.sh
And then edit crontab with:

Code: [Select]
crontab -e
Add this line at the end and then control x and then press y to save.
Code: [Select]
@reboot /etc/MC20start.sh

Now Reboot with:

Code: [Select]
sudo reboot
log back in to the SSH terminal session

After a Reboot you can type the following to check all the services are running.
Code: [Select]
sudo netstat -anpt | grep -E "vnc|xrdp"
You should get something like this.
Code: [Select]
tcp        0      0 0.0.0.0:3389            0.0.0.0:*               LISTEN      2018/xrdp
tcp        0      0 0.0.0.0:5900            0.0.0.0:*               LISTEN      2721/x11vnc
tcp        0      0 127.0.0.1:3350          0.0.0.0:*               LISTEN      2057/xrdp-sesman

Now you should be able to use a standard windows remote desktop to login using the ip address of your pi to connect and view your default Pi desktop. :)
VNC will also still work if that floats your boat, but since I mostly work from windows machines RDP works great for me.

x11vnc is still pretty light weight, at idle logged into the GUI desktop I'm using 4% CPU and 10% when playing a 44.1K FLAC. If you go crazy scrolling in the gui it'll use 70% or more of all 4 cores but the audio still didn't stutter for me.  The GUI is nice and snappy!

Mwillems if you want to test this out, tidy it and integrate into your guide be my guest!



Logged

mwillems

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 5181
  • "Linux Merit Badge" Recipient

I'm happy to integrate it over the weekend, but one quick question before I do: does your method run correctly if the device is booted without anything attached to the HDMI output?  Long ago and far away, I pursued an x11VNC-based method, but found that, precisely because it tries to use the actual GUI output, that it didn't work reliably when the system was run truly headless (either x would fail to launch, or the vnc server would fail). 

I'm sure there are configuration steps that will side step all that (and you may have outlined them above), but the main reason I went to tigervnc (or tightvnc) was that it was trivially easy to create a dummy display, sidestepping any issues resulting from the presence or absence of an actual display.

For anyone looking to run the script once a minute to regularly to check if MC is running and restart it, the correct cron entry is
Code: [Select]
* * * * * /path/to/script/scriptname.sh
If you're only running it at boot, you don't need some of the conditional commands in the script.  I'll try and integrate this discussion above.

Logged
Pages: [1] 2 3   Go Up