INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: (Solved) Japanese Font Not Shown Properly  (Read 10242 times)

andyKT

  • Galactic Citizen
  • ****
  • Posts: 250
(Solved) Japanese Font Not Shown Properly
« on: May 12, 2015, 07:55:24 pm »

A couple of Japanese MC20 Linux users posted similar problems on the subject on Japanese FORUM.

They presume the problems as follows;

>Only one font set is being used to disply Japanese Kanji charactors.
  Thesefore, iso10646 encorded font needs to be used.

>Windows version converts charactor cods ShiftJIS→UTF-8, but the current Linux version doesn't.

Attaching a screen shot of the "Japanses" font being displayed as squares.

Thank you.
 
 

Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71472
  • Where did I put my teeth?
Re: Japanese Font Not Shown Properly
« Reply #1 on: May 12, 2015, 08:28:50 pm »

I'm not expert on this, but I would guess that the problem is related to missing fonts.

In MC, you can choose a font under Tools > Options > Tree & View.
Logged

kinomoto

  • Recent member
  • *
  • Posts: 37
Re: Japanese Font Not Shown Properly
« Reply #2 on: May 13, 2015, 04:11:25 am »

Hello.

First, I tell you, I can not understand English , very well.
I will use easy English only.

> In MC, you can choose a font under Tools > Options > Tree & View.

The Problem are not so easy.

Tools > Options > Tree and View

I can choose the Fonts ,  "Lucida" "Unifont" ""User Defined" only.

3 pattern , I did try test.

but can not shown Japanese Fonts.

Thank you.



kinomoto



Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Japanese Font Not Shown Properly
« Reply #3 on: May 14, 2015, 10:01:51 am »

Hello.

First, I tell you, I can not understand English , very well.
I will use easy English only.

> In MC, you can choose a font under Tools > Options > Tree & View.

The Problem are not so easy.

Tools > Options > Tree and View

I can choose the Fonts ,  "Lucida" "Unifont" ""User Defined" only.

3 pattern , I did try test.

but can not shown Japanese Fonts.

Thank you.



kinomoto


You need to use the unifont and it needs to be installed in the OS.
In debian:
sudo apt-get install xfonts-unifont

Logged

kinomoto

  • Recent member
  • *
  • Posts: 37
Re: Japanese Font Not Shown Properly
« Reply #4 on: May 14, 2015, 01:46:06 pm »

>You need to use the unifont and it needs to be installed in the OS.
>In debian:
>sudo apt-get install xfonts-unifont

Thankyou for your reply.
My OS are "Ubuntu Studio 14.04.2 LTS"(32 bit).
But I think , command is same.
Type
sudo apt-get install xfonts-unifont
Install is success.
and
Tools > Options > Tree and View
Change font to unifont......but......
problem is not to good.
Same problem continue.......

For example , Can I open MC's setting file by "gedit" or "vi" ?
I want try add "Codepage=932" , or another code.

thankyou.


kinomoto

Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7403
  • The color of Spring...
Re: Japanese Font Not Shown Properly
« Reply #5 on: May 14, 2015, 01:48:02 pm »

You might try rebooting after installing the font.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Japanese Font Not Shown Properly
« Reply #6 on: May 14, 2015, 01:53:32 pm »

You might try rebooting after installing the font.
This is likely the issue with MC not seeing the font.

MC doesn't use codepages. The language is selected in Tools->Language. Don't change it until you get the display of your media looking right.
Logged

kinomoto

  • Recent member
  • *
  • Posts: 37
Re: Japanese Font Not Shown Properly
« Reply #7 on: May 14, 2015, 02:26:31 pm »

thankyou for your reply.

reboot PC.
But same problem.

I try another Linux PC install JRMC20.
and I try same things.
but same problem.

Is it Ubuntu Studio 14.04.2 LTS useing are so bad ?

Should I try another Linux ?
for example "debian".


Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Japanese Font Not Shown Properly
« Reply #8 on: May 14, 2015, 03:41:26 pm »

thankyou for your reply.

reboot PC.
But same problem.

I try another Linux PC install JRMC20.
and I try same things.
but same problem.

Is it Ubuntu Studio 14.04.2 LTS useing are so bad ?

Should I try another Linux ?
for example "debian".


You might have to reselect "unifont" in MC after rebooting.
If it still doesn't work try this:
xlsfonts | grep unifont
from a terminal prompt. You should see this:
-gnu-unifont-medium-r-normal--0-0-75-75-c-0-iso10646-1
-gnu-unifont-medium-r-normal--16-160-75-75-c-80-iso10646-1
if you don't the fonts are still missing.

You could try the current debian Jessie 64 bit build and use the apt repository here if that above doesn't work.


Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7403
  • The color of Spring...
Re: Japanese Font Not Shown Properly
« Reply #9 on: May 14, 2015, 03:59:34 pm »

I thought the Jessie release wouldn't work on Ubuntu 14.04.2? I'll be testing that shortly.
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Japanese Font Not Shown Properly
« Reply #10 on: May 14, 2015, 04:46:00 pm »

I thought the Jessie release wouldn't work on Ubuntu 14.04.2? I'll be testing that shortly.
I wasn't clear, sorry. I meant he could try installing debian jessie and then trying the 64 bit build on that instead of ubuntu.
Logged

Awesome Donkey

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 7403
  • The color of Spring...
Re: Japanese Font Not Shown Properly
« Reply #11 on: May 14, 2015, 04:50:39 pm »

Ah, right. :) And yes, the Jessie build won't work in 14.04.2 nor Linux Mint 17.1. ;)
Logged
I don't work for JRiver... I help keep the forums safe from Viagra and other sources of sketchy pharmaceuticals.

Windows 11 2024 Update (24H2) 64-bit + Ubuntu 24.04 LTS Noble Numbat 64-bit | Windows 11 2023 Update (23H2) 64-bit (Intel N305 Fanless NUC 16GB RAM/256GB NVMe SSD)
JRiver Media Center 32 (Windows + Linux) | iFi ZEN DAC 3 | Edifier R2000DB Bookshelf Speakers | Audio-Technica ATH-M50x Headphones

kinomoto

  • Recent member
  • *
  • Posts: 37
Re: Japanese Font Not Shown Properly
« Reply #12 on: May 14, 2015, 08:46:55 pm »

thankyou for your reply.

I did try...but...


kinomoto@AY320S:~$ xlsfonts | grep unifont
-gnu-unifont sample-medium-r-normal-sans-0-0-75-75-c-0-iso10646-1
-gnu-unifont sample-medium-r-normal-sans-16-160-75-75-c-80-iso10646-1
-gnu-unifont-medium-r-normal-sans-0-0-75-75-c-0-iso10646-1
-gnu-unifont-medium-r-normal-sans-16-160-75-75-c-80-iso10646-1



Is it , I don't the fonts are still missing ?

If so then can I recover the Japanese fonts ?
How should I do it ?
Please , more support.

Thankyou.

kinomoto



Logged

kinomoto

  • Recent member
  • *
  • Posts: 37
Re: Japanese Font Not Shown Properly
« Reply #13 on: May 14, 2015, 11:35:08 pm »

Excuse me , sir.

I did try them.......


kinomoto@AY320S:~$ sudo aptitude -y install language-pack-ja-base language-pack-ja ibus-mozc
[sudo] password for kinomoto:
kinomoto@AY320S:~$ sudo update-locale LANG=ja_JP.UTF-8 LANGUAGE="ja_JP:ja"
kinomoto@AY320S:~$ source /etc/default/locale
kinomoto@AY320S:~$ echo $LANG
ja_JP.UTF-8


......and , reboot PC....
........but.......probrem is not to good.
oh..........no.........
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Japanese Font Not Shown Properly
« Reply #14 on: May 15, 2015, 10:51:32 am »

Excuse me , sir.

I did try them.......


kinomoto@AY320S:~$ sudo aptitude -y install language-pack-ja-base language-pack-ja ibus-mozc
[sudo] password for kinomoto:
kinomoto@AY320S:~$ sudo update-locale LANG=ja_JP.UTF-8 LANGUAGE="ja_JP:ja"
kinomoto@AY320S:~$ source /etc/default/locale
kinomoto@AY320S:~$ echo $LANG
ja_JP.UTF-8


......and , reboot PC....
........but.......problem is not to good.
oh..........no.........

You did go into the Tools->Options->Tree & Views->Select Font and made sure to reselect Unifont, right?

If it still doesn't work, email me the smallest audio file that will show the missing characters. bob (at) jriver (dot) com. Thanks.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Japanese Font Not Shown Properly
« Reply #15 on: May 15, 2015, 11:30:35 am »

Testing here I've found that the 32 bit build of MC works for this and the 64 bit does not.
Doing more investigation.
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Japanese Font Not Shown Properly
« Reply #16 on: May 15, 2015, 11:43:13 am »

Testing here I've found that the 32 bit build of MC works for this and the 64 bit does not.
Doing more investigation.

It's because the newer unifonts in jessie (and I assume ubuntu) have changed.
What you can do is choose "User Defined" in the font selection then in the "User Defined Font String" box, put
-gnu-unifont-medium-r-normal-sans-16-160-75-75-c-80-iso10646-1

You'll have to type that in by hand unless you've installed autocutsel for copy and paste to/from the desktop apps.
Logged

kinomoto

  • Recent member
  • *
  • Posts: 37
Re: Japanese Font Not Shown Properly
« Reply #17 on: May 16, 2015, 04:07:28 am »

thankyou for your reply.

>You did go into the Tools->Options->Tree & Views->Select Font and made sure to reselect Unifont, right?

Sure.  :-)

>What you can do is choose "User Defined" in the font selection then in the "User Defined Font String" box, put
>-gnu-unifont-medium-r-normal-sans-16-160-75-75-c-80-iso10646-1

Oh !!!!!  That is great !!!!!
I can Japanese font seeing !!!!!!
Thanks a lot for your support !!!!!!
Very , very , thanks for you.

but Can I say some luxury ?
Just little bit , Fonts are unshapely.   :-)

But , but , this is great !!!!!
I will use MC , It became easy to use it !!!!!!

The Problem is all clear.

Thank you very much.

kinomoto  --- Japanese MC fan :-)

Logged

andyKT

  • Galactic Citizen
  • ****
  • Posts: 250
Re: Japanese Font Not Shown Properly
« Reply #18 on: May 16, 2015, 10:22:09 am »

bob, Awesome Donkey and JimH,

Thanks a lot!
Logged

bob

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 13526
Re: Japanese Font Not Shown Properly
« Reply #19 on: May 18, 2015, 11:09:07 am »

The MC posted on Friday (at the top of this forum) should fix this automatically when using unifont.
It also clears up some issues with interline spacing..
Logged
Pages: [1]   Go Up