INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Association file fails to load on install, Win 10  (Read 3322 times)

atreder

  • Member
  • *
  • Posts: 3
Association file fails to load on install, Win 10
« on: September 29, 2015, 06:34:51 am »

Just upgraded my PC to Win 10, got (what appears to be the "usual") error of "wrong OS, reinstall".
So I removed MC19, and attempted to install MC20.


Now get the error "failed to load file associations file, fatal error..." etc.
I have tried to run the install file (MediaCenter200132.exe) as Administrator, no difference.
I have tried to delete UsrClass.dat (from one web suggestion) but it's locked by System.
Another thread suggests that Version 10122 of Win 10 stops "association hijacking", is this what's going on?

Various reboots, in case that cleared the Registry, to no avail.

Suggestions please?
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71319
  • Where did I put my teeth?
Re: Association file fails to load on install, Win 10
« Reply #1 on: September 29, 2015, 06:57:24 am »

MC20 isn't sold anymore, so MC21 would be the best place to start.  It's on the download page.

I don't know of a file associations problem, but anything is possible if Microsoft changed something.  It seems unlikely though.

Antivirus programs or other "security" programs often cause problems like this.  What are you using?

Logged

atreder

  • Member
  • *
  • Posts: 3
Re: Association file fails to load on install, Win 10
« Reply #2 on: September 29, 2015, 10:11:55 am »

I tried installing MC21 (MediaCenter210009.exe) as well, same result.  I'm licensed for MC19 and 20 and would take some persuading to part with more money!   :-)
I don't use anti-virus or anti-malware other than Windows Defender. (Built my first microprocessor system in 1977, never been hit by a virus, and only twice by truly "nasty" malware)

Seems to be a very obscure issue...  I may have to create a dummy user to log in as, then rename UsrClass.dat as that is, it seems, where the Associations are held?

Andy
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71319
  • Where did I put my teeth?
Re: Association file fails to load on install, Win 10
« Reply #3 on: September 29, 2015, 10:39:38 am »

Just as a test, try installing the same file on another PC if you have one.

The problem you're seeing is probably a problem with your machine.  It's not something we're seeing commonly at all.
Logged

CountryBumkin

  • Citizen of the Universe
  • *****
  • Posts: 3352
Re: Association file fails to load on install, Win 10
« Reply #4 on: September 30, 2015, 04:57:23 am »

I have tried to delete UsrClass.dat (from one web suggestion) but it's locked by System.
Another thread suggests that Version 10122 of Win 10 stops "association hijacking", is this what's going on?

Various reboots, in case that cleared the Registry, to no avail.

Suggestions please?

Once you start deleting files and messing with the registry your in trouble.
You mention running Windows !0 version 10122 which I assume is an early beta version (10240 was the last pre-release version). Are you running the final release now?

I think something is messed up with Windows, not the MC install. I suggest you run the Windows "Restore" feature. see http://www.tenforums.com/tutorials/4588-system-restore-windows-10-a.html
Also you can do Windows "system file check" by running the "SFC /Scannow" command. See http://www.tenforums.com/tutorials/2895-sfc-command-run-windows-10-a.html
Logged

atreder

  • Member
  • *
  • Posts: 3
Re: Association file fails to load on install, Win 10
« Reply #5 on: October 01, 2015, 04:00:07 am »

OK, getting there...

I created a new user, Administrator profile.
I switched to that, installed MediaCenter200132.exe under the other profile, entered registration details.  Works fine!

Close JRiver...
Switch back, icon is on desktop, launch it...
New error! "Please download ... Media Center"

sigh... onwards and upwards...
Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71319
  • Where did I put my teeth?
Re: Association file fails to load on install, Win 10
« Reply #6 on: October 01, 2015, 05:59:19 am »

I'm sorry about your problem, but we're seeing a lot of people using Win10 now and we're not seeing this problem.

See if you can eliminate Windows Defender as the cause.  
Logged
Pages: [1]   Go Up