INTERACT FORUM

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: JRiver 21 not importing all files  (Read 9351 times)

ryhaigh76

  • Member
  • *
  • Posts: 4
JRiver 21 not importing all files
« on: March 26, 2016, 10:24:08 pm »

Hopefully someone can help me out. 

I have been using JRiver for about 5 years and have never had a problem until now. 
Recently did a new PC build with Windows 10 clean install and updated from Jriver20 to 21 at the same time.  Normally, when I've had to build a system from scratch what I have done is install JRiver and then manually import a specific folder that i keep all my music in on a hard drive and jriver takes all of it no problem. At worst sometimes I've had to redo some artwork.

With this recent build, I have done the same, and the vast majority of my music has been imported, but not all, and I'm not sure why.

Here are some facts that I am hoping will help with diagnosis.

- I am missing whole specific albums and their corresponding tracks
-Setup =  E. Drive -> Music -> Folders of artist --> folders for specific albums of that artist
- When I initally imported the music folder it imported most but not all of my music files.
- When I do the same thing again, it does not import any additional files.
- When I select specific album folders that are currently not showing as imported, it doesn't import the desired files
- Funny thing is, some of the albums in a particular artist's folder have transferred while other whole albums will not
- The failure of files to show up is always by whole album, not specific files
- I also tried auto-import with settings to import everything, and clean up tags etc, but it had no effect
- If I choose to play a file in these album folders with JRiver by selecting the file in its location folder, JRiver plays them fine, even though it won't import them
- The files are not identified as bad or corrupted
- Virtually my whole library is flac, including the ones that imported fine AND the ones that didn't

Any insight would be greatly appreciated and if I can provide any additional information that may help, I am happy to do so.

Thanks,

Ryan



Logged

CountryBumkin

  • Citizen of the Universe
  • *****
  • Posts: 3352
Re: JRiver 21 not importing all files
« Reply #1 on: March 27, 2016, 06:05:15 am »

Go to "Tools>Options>Library & Folders>Configure Auto Import" look under tasks and see if the "Ignore files previously removed from library" is checked.
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: JRiver 21 not importing all files
« Reply #2 on: March 27, 2016, 07:12:59 am »

CB has a good idea for sure.

Did you move the location of your files from your old system to your rebuilt system?  Did you perhaps add a directory or two that makes the path names longer?  You might be running into the windows file name length limit.  Any file with a total path length of around 260 characters or longer isn't readable by most windows programs including MC.

Have you tried importing just a directory with an album that didn't import initially ?

Brian.
Logged

ryhaigh76

  • Member
  • *
  • Posts: 4
Re: JRiver 21 not importing all files
« Reply #3 on: March 27, 2016, 09:02:29 am »

Thanks for the ideas guys.

The "ignore files previously removed from library" was checked but once I changed it still no difference. 0 imported files.

I've run into the character limit before, but that's not it with the current issue.  I have tracks with longer paths than the ones that are missing.

Any other ideas?
Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: JRiver 21 not importing all files
« Reply #4 on: March 27, 2016, 10:24:57 am »

I think I might have it:  Permissions and ownership.

When you reinstall windows, it generates a new underlying user ID (a GUID maybe?).  If you don't then take ownership of all of your files, you might not have permissions to them.  It gets kind of complex because there's ownership and read/write permissions on the files themselves, versus ownership and read/write on the containing folders.

I think you need to start at the root of your music folder and take ownership of everything below it.  Do a little research and you should be able to find how to do this.  Disclaimer:  I don't use windows daily, but I know a few things about it.

You might start by experimenting with one folder of files that won't import.  Good luck!

Brian.
Logged

ryhaigh76

  • Member
  • *
  • Posts: 4
Re: JRiver 21 not importing all files
« Reply #5 on: March 27, 2016, 01:18:11 pm »

Thanks Brian.  Looked into it and already had full permission and ownership of all files.  Reset these again anyway and retried import and no change.

Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: JRiver 21 not importing all files
« Reply #6 on: March 27, 2016, 01:25:28 pm »

Hmm.  Make a new library and import one of these problem folders and see what happens?

Brian.
Logged

ryhaigh76

  • Member
  • *
  • Posts: 4
Re: JRiver 21 not importing all files
« Reply #7 on: March 27, 2016, 01:27:35 pm »

So I Cleared the library and then imported the big main folder and everything came in.   Bizarre, but I'm happy it worked!!!  Thanks for your advice. 

Logged

blgentry

  • Regular Member
  • Citizen of the Universe
  • *****
  • Posts: 8009
Re: JRiver 21 not importing all files
« Reply #8 on: March 27, 2016, 01:32:02 pm »

Yay!  I hate it when we don't know what fixed it, but I'm very glad you got it working.  :)

Brian.
Logged

markuse

  • Member
  • *
  • Posts: 1
Re: JRiver 21 not importing all files
« Reply #9 on: August 30, 2017, 12:00:59 am »

It's still here, in MC22, and we wouldn't want it to show up in MC23.

I have the exact same scenario as the original post:

I recently had to rebuild my media PC with a fresh reinstall of Windows 10 due to SSD failure.
Next step was reinstalling MC, and importing all my music files. All of those reside on a NAS, in various folders by file type or origin, e.g. \FLAC for ripped flac files, and \HDdownloads\HDtracks for everything downloaded from HDtracks. \MP3Downloads\StoreName for all mp3s from a particular download store, e.g. amazon or emusic... and a few more directories along the same lines. Below those folders I consistently maintain the same hierarchy: \Artist\AlbumName

Two things happened after the rebuild: (may not be related to the rebuild, though)

1. I ripped a number of CDs, moved the flac files to the respective directory on the NAS, and after running the import all but one of the albums had imported. I ran import again, and that missing album was still skipped, even though it was in the correct Artist subfolder, from which all other albums had been successfully imported in the past. No excessively long path names, no special characters, no Windows permission issues. I attempted to run the import multiple times over the following few days, with no success. Note that I was able to play all of the files from that missing album by launching them from their directory, playing them with MC. Then, a week later I re-ripped the same album and ran the MC import again. This time the import worked. Weird!

2. A slightly different issue, with the same result: On another occasion I downloaded a few albums from from HDtracks. I do this a few times a month. (My one addiction.) Those downloads are moved to the respective folder on the NAS right after completion. It always worked in the past, including a week earlier when I downloaded a couple of albums. But this time, none of the albums from the most recent download were picked up by MC while running the import. Numerous attempts were unsuccessful. I checked the import settings, and low and behold the HDdownloads\HDtracks folder had disappeared from the designated downloads sources.
Those download settings for me are 'set and forget', i.e. I configure that during MC installation, and never mess with it again, since my NAS setup is static. Nobody else has the permissions to use my Windows account, the only one with access to the respective source folders on the NAS. (Other household members don't care about resolution or compression - they only get to access the \MP3 folder on the NAS.
So I added that folder back, and of course everything imported now. I've observed the same thing once before, as one of the source folders magically disappeared from the import settings. Obviously, once you notice that, it's an easy fix.
What the heck could cause those import setting to drop one of the designated source folders?
Note: nothing had changed on the NAS. None of the NAS' top level folders, e.g. FileType\StoreName, or \FileFormat were ever removed, replaced, moved around, or corrupted at any time. The only regular changes are additions of \Album or \Artist folders as I acquire new albums. There's really no reason MC should, on its own, decide to drop import sources from its settings randomly. Are there any known conditions that can cause this, e.g. changing certain other MC settings?

Thanks, any input is appreciated!

Logged

JimH

  • Administrator
  • Citizen of the Universe
  • *****
  • Posts: 71045
  • where the buffalo roam
Re: JRiver 21 not importing all files
« Reply #10 on: August 30, 2017, 07:10:41 am »

Try moving the problem album to your local drive and importing from there.  If that works, it may be a NAS problem.
Logged

RoderickGI

  • MC Beta Team
  • Citizen of the Universe
  • *****
  • Posts: 8186
Re: JRiver 21 not importing all files
« Reply #11 on: August 30, 2017, 10:50:27 pm »

1. Weird.
Had you ever ripped that CD in the past, and then removed it from your library? If so, was it in the "Removed" database, and so would not be imported again?
Could the ripped files have been marked as bad, and therefore not been imported into the library? If so, you could have checked in the "Bad" database.
Create Smartlists for the two databases, and perhaps best for all Media Types, and check them if such a thing happens again.

2.Not so weird.
Are there any known conditions that can cause this, e.g. changing certain other MC settings?

It depends on the sequence of steps you used in your Windows recovery process, I would guess. Those settings are stored in the Windows Registry I believe. As you had an SSD failure, it is quite possible that the Windows Registry had some corruption in it.

Did you restore a Windows backup after doing your fresh install of Windows 10?
Did you restore a MC Backup after reinstalling MC, including a restore of settings, and could that backup have already lost this Auto Import setting?
If you did a clean installation of Windows 10, and then a brand new clean installation of MC, are you sure that you remembered to add that sub-directory to your Auto Import settings?
Logged
What specific version of MC you are running:MC27.0.27 @ Oct 27, 2020 and updating regularly Jim!                        MC Release Notes: https://wiki.jriver.com/index.php/Release_Notes
What OS(s) and Version you are running:     Windows 10 Pro 64bit Version 2004 (OS Build 19041.572).
The JRMark score of the PC with an issue:    JRMark (version 26.0.52 64 bit): 3419
Important relevant info about your environment:     
  Using the HTPC as a MC Server & a Workstation as a MC Client plus some DLNA clients.
  Running JRiver for Android, JRemote2, Gizmo, & MO 4Media on a Sony Xperia XZ Premium Android 9.
  Playing video out to a Sony 65" TV connected via HDMI, playing digital audio out via motherboard sound card, PCIe TV tuner
Pages: [1]   Go Up